[CUSTOM BUILD] Galaxy S9 starlte --- Android Q - new build Sep. 16th

I have build a Q-eOS rom for S9 with the alpha sources from eOS.

The build is untested. So use on own risk.

It is really a custom build, because I have made some changes in bootanimation, background, launcher and I have removed all goolag calls which are still in the alpha sources.

download here https://ecloud.global/s/QY7SJCRJ6Ad9LfE

September 16th: new build with recent button fix

1 Like

How about a [CUSTOM BUILD] Galaxy S9+ star2lte - Android Q ?

It’s on my build list.; )

Hi @SuzieQ it was a type error. The build is for S9 starlte. S9+ star2lte I will build as next (I hope over night)

you can download the star2lte build

Hi @harvey186, what a surprise. Thanks for the /e/build.

The Official Lineage OS build uses stock android 10 vendor so encryption is enabled by default. And TWRP Recovery 3.4.0-0 has a hard time with it. What kind of custom recovery do you use?

I’m using also TWRP 3.4. But I never encrypt my device, because it makes offen trouble

Before installing LOS 17.1, I format the /data partition to remove the encryption. But stock android 10 vendor encrypts it on the following reboot.

According to my research, this file should be responsible for this: /vendor/etc/fstab.samsungexynos9810

Do you have any idea what needs to be changed in this file fstab.samsungexynos9810 to override the encryption mechanism?

# Android fstab file.
#<src>                  <mnt_point>         <type>    <mnt_flags and options>                               <fs_mgr_flags>
# The filesystem that contains the filesystem checker binary (typically /system) cannot
# specify MF_CHECK, and must come before any filesystems that do specify MF_CHECK

#/dev/block/platform/11120000.ufs/by-name/SYSTEM        /system     ext4    ro,errors=panic                                             wait
/dev/block/platform/11120000.ufs/by-name/CACHE	/cache	ext4	noatime,nosuid,nodev,noauto_da_alloc,discard,journal_checksum,data=ordered,errors=panic	wait,check
/dev/block/platform/11120000.ufs/by-name/USERDATA	/data	ext4	noatime,nosuid,nodev,noauto_da_alloc,discard,journal_checksum,data=ordered,errors=panic	wait,check,forceencrypt=footer,quota,reservedsize=128M,length=-20480
/dev/block/platform/11120000.ufs/by-name/EFS	/mnt/vendor/efs	ext4	noatime,nosuid,nodev,noauto_da_alloc,discard,journal_checksum,data=ordered,errors=panic	wait,check
/dev/block/platform/11120000.ufs/by-name/CPEFS	/mnt/vendor/cpefs	ext4	noatime,nosuid,nodev,noauto_da_alloc,discard,journal_checksum,data=ordered,errors=panic	wait,check,nofail
/dev/block/platform/11120000.ufs/by-name/MISC           /misc       emmc    defaults                                                                                      defaults
#/dev/block/platform/11120000.ufs/by-name/DQMDBG        /dqmdbg     ext4    noatime,nosuid,nodev,noauto_da_alloc,discard,journal_checksum,data=ordered,errors=panic       wait,check

# VOLD - fstab.star2lte
/dev/block/platform/11120000.ufs/by-name/HIDDEN	/preload	ext4	noatime,nosuid,nodev,noauto_da_alloc,discard,journal_checksum,data=ordered,errors=panic	voldmanaged=preload:auto,check
/devices/platform/11500000.dwmmc2/mmc_host*             auto        vfat    defaults    voldmanaged=sdcard:auto
/devices/platform/10c00000.usb/10c00000.dwc3*           auto        auto    defaults    voldmanaged=usb:auto

Sorry, no idea. But what’s the issue. Format data once more and flash eOS. I don’t lnow if eOS will also encrypt data by default. But I think it won’t.

Hi Harvey, just installed this custome build. I was coming from Oreo and had to get back to stock rom, before I was able to flash to Android 10 (Q).

You made quite some tailoring compared to the standard installation. But no problems, since tailoring back to my taste is of course also no problem.

Thanks a lot!

That could be needed to get the right vendor firmware / partition

Sure, that’s why it is a ‘custom build’ and not an unofficial build ; )

Just tried to go back into TWRP recovery mode, but it failed due to encryption …

After flashing your ROM, I noticed that during start-up the phone mentioned a decryption action (logo etcetera was visible). After the setup I went through the setup cycle where I also introduced my PIN code. The PIN code for decryption did not work when entering TWRP.

Can you explain what happens? How can I decrypt this in TWRP?

PS: Formatted data in TWRP after being unsuccessful to decrypt, but during startup the encryption took place again with same result in TWRP again.

Hi harvey186 I was not able to download your star2lte build, error “file not found”
I am really looking forward to running /e/ as q build! Can you please re-upload the file?

I am afraid he is not active in this forum anymore…

i see…thanks piero

@pinibo/@SuzieQ can one of you upload and provide Harvey’s S9+ build you downloaded earlier since his linked file is no longer available ??

You mean S9+ or S9? The last one I have (STARLTE … only image file dates 20201023), but the first one not.

I’m looking for the S9+ (star2lte)

No problem, however this topic was about S9 Starlte. Good luck with your search.