[CUSTOM BUILD] Unofficial Pie Build for Galaxy S9 - (starlte)

Rom download here

Note: not tested. use at your own risc

1 Like

Thanks for this build :slight_smile: Why is it custom ? What are the modifications ?

And you could create an account on androidfilehost and request developer access (to upload) if you want.

Bootanimation and background is mine :smiley:

I have gotten space on ecloud for eOS builds :+1:

1 Like

Body is too similar to what you recently posted

Right - Bot and artificial intelligence in customer service. It’s about the same subject boot animation and its easy exchange.

The bootanimation.zip can easily be exchanged via TWRP File Manager → /system/media/bootanimation.zip

Hi, I am trying to flash this Rom. But i am getting error.
vendor image on this device is not compatible expected version xxu2csc8.

tan you have the wrong firmware. Do you really have a starlte ? Is there a pie firmware available ?

Yes Its starlte. I tried flashing pie firmware too. But its giving me error again kernel rev check fail device binary 7 binary 2.

OK, which OS is installed on your device ? eOS Oreo ??

Yes I am on oreo currently

I’m not sure, but on some device you have to go back to latest (oreo or pie) stock rom to get the right firmware. From stock rom you can start over with pie eOS. But @archje will know it better

1 Like

Do you have standalone vendor image or any link from where i can download ?

No, i’m sorry. You can check xda or Samsung support sites


My S9 starlte arrives tomorrow. I’m assuming it’s going to run Oreo. Should I update to stock Pie before install this build?

I understand going all the way to Q10 is a no no

yes, it’s the best choice

right, stay on pie til eOS is in Q available

I encountered the same error. I’m on G960FXXS7CTA2_G960FOXM7CSJ5 and cannot get back to previous firmware G960FXXU2CSC8_G960FOXM2CSC8_BTU - Odin just hangs at flashing the system img

I flashed the XXU2CSC8 vendor image extracted from the firmware in TWRP but still the build complained about vendor image.

I removed the vendor image section from the update script and it booted into the boot animation but hung there

do you really have a starlte ?? For me (I’m not a Samsung Guru) it sounds that you don’t have the right eOS version for your device.

Definitely - flashed this last night to get me running on /e/


OK. fine Have you tried my latest build from yesterday ?

no, where can I I get that? can only see 06 01 build in here https://ecloud.global/s/QY7SJCRJ6Ad9LfE