Data transmission per USB to PC not working (Win10 doesn't recognise FP3)

Dear Forum,
I have just installed the e-OS on my FP3, but I cannot use my Usb to transfer data between the phone and my (Win10) PC. The FP3 does not appear as a data medium in the list as it normally should. (Yes, I activated data transfer in thes usb settings on the phone).
I am a newbie to this mobile OS matter, so maybe I am missing something.
I am thankful for every help!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Some generic things that come to mind …

  • Selecting data transfer as the USB connection mode has to be done everytime you connect the phone to a computer (there should be a notification coming up on the phone once you connect it), it’s not a one-time setting. This is a security feature.

  • Make sure to use a USB data cable. There are USB cables around only for charging, which will not work for data connections.

  • Try with a different USB port on the computer.

  • Displaying the folder/file structure of the phone on the computer via USB is done using MTP (Media Transfer Protocol). MTP needs to be set up correctly on the computer side for this to work. Drivers and/or software used with previous smartphones might interfere.
    Furthermore, there are versions of Windows 10 called Windows 10 N, which don’t come with MTP (among other things) included, you would have to actively install the necessary components first.
    See more on repairing MTP trouble in Windows 10 here.


To help with Win10-side debugging, you may use some of the awesome NirSoft utilities :


Thank you very much both of you. I will try to debugg this potential mtp issue as soon as I have some more spare time!

Same problem here. Turned off ''developer options" on the Android phone (OnePlus3). Immediately Windows 10 popped up that my phone was recognized. Working as it should again.

P.s. when I activated “developer mode” again the problem came back. Turned “developer mode” off and fixed again. Don’t forget, USB on phone in MTP mode.

1 Like

Turning off USB debugging in developer mode should be enough. If you don’t have developer options go to “About this phone”. Tap 10 times on the Build number to activate developer mode. Go to System -> advanced and now you should see developer mode. Turn of USB debugging. Turn on MTP mode.

1 Like

Thank you, but I could not find a dedicated MTP option in the ‘developer options’. I deactivated usb debugging and locked the oem bootloader and deactivated the developer mode again, but my issue remains on my desktop Pc. Yet data transmission works on my laptop, so this may really be a driver problem as the previous commentators suggested. (Unfortunately, I haven’t had the time yet to dig into the suggested windows debugging. I’m quite new to this matter.)

  1. Turn of “debugging mode” in developer options on your phone.
  2. Connect your phone with USB cable to PC/laptop.
  3. Android should say that your phone is charging via USB
  4. Change your USB connection on phone from “charging” to “data transfer”
  5. Then Windows should recognize your phone and makes the USB connected sound
  6. You don’t have to do anything on PC/laptop.

But when I do all that and change it to data transfer the notification of connection with my FP3 only pops up for a second on windows and then it stops to recognize the phone as a device completely. (Even in the device manager)

In Windows Device Manager, you may have to activate “Show hidden devices” in the View menu.

I suppose you tried several USB cables already.

“If you don’t see a notification, make sure you use a data transfer cable (opposed to a charging cable)”

Do you have this cable?