[Device Roadmap] Android 9 (Pie) & 10 (Q) : Test builds to support new devices

Manoj will answer you. My post was to make him aware of this.

1 Like

Hi Julien,
If LOS officially starts support for a device in 17.1 then it is easy for us to build the ROM as the ‘hard’ part of the porting is already done. I can add these new devices to the list and make a test build for them.
For now I am working to ensure that the first set of test builds we released in this thread can get OTA updates. There was an issue with the OTA server which we need to resolve.

The whole point of these test builds was to give users a chance to use Pie on their device and update the test builds seamlessly OTA while we add them to the official list.


That’s a good news, I’ll keep an eye on this. :slightly_smiling_face: I don’t really like the official ROM.

great! now i will definitely buy the Sony Xperia XZ2 Compact as my next phone, my Samsung Galaxy A3 (2016) is getting a bit slow + i need a dual-sim.

Very interesting device, but without 3.5 jack :unamused:

:loudspeaker: Update on the OTA builds :

:grinning: The good news is that an updated version of the Updater :slight_smile: has been released which will enable users with test builds to get the builds OTA
:disappointed: The bad news is that this would require a manual flash again the first time for test build users. Subsequent test builds will flow in OTA
Just tested this on a Redmi land 3S check the screenshot below

I have started a build for all devices in the lists here and here

Once done will upload them to AndroidFileHost…the subsequent test build updates will be OTA

The next step after a successful OTA test will be to add these devices to the official supported list.


For more details on the OTA updates for these test builds check the post here

1 Like

Reporting my experience on flashing a
Samsung Galaxy S2 tablet, SM-T813 with an sdcard mounted
through a
linux Mint 19.3 cinnamon (adb and heimdall installed)


  1. I’ve found the device already factory reset

  2. start the device, and finish the setup avoiding all requests from Goo and Sam

  3. enable the developer mode on the device (seven taps on build) and turn the device off then back on but in download mode, i.e. pressing Home + Volume Down + Power

  4. on linux terminal
    a) > adb devices to verify the usb connection
    b) > heimdall print-pit > info.txt to save informations from the device
    c) > adb reboot bootloader to reboot into download mode
    d) > heimdall flash --RECOVERY twrp-3.4.0-0-gts210vewifi.img --no-reboot

  5. Entering TWRP recovery mode
    For me, being not a a “flashaolic”, the tricky part was the proper timing between the two steps here below. Along this step I broke into a cold sweat, since I supposed I entered into a boot loop. Note that if you do not enter TWRP at this stage, you have to repeat the steps c) and d) above.
    Again: the proper timing is the key to escape the cold sweat !
    a) press Volume Down + Power to turn off the device
    b) after the shut down (dark screen) press Home + Volume Down + Power to enter into TWRP recovery mode.

  6. Make a backup of the device in factory state for an improbable, but still useful, future restore (TWRP)
    a) mount an USB OTG (where to save the backup)
    b) wipe > Format data to remove the encryption
    c) Backup > check System + Boot
    d) Select storage > USB OTG and wait until finished
    e) unmount USB OTG and remove the key

  7. Still on TWRP: wiping the device
    a) wipe > advanced wipe > check Dalvik cache + System + Data and swipe to wipe
    b) back to TWRP main screen

  8. Copying the eOS zip file from linux to the device and flashing it.
    a) from linux terminal
    > adb push e-0.10-p-2020081167314-test-gts210vewifi.zip /sdcard1/
    b) wait until the copy is finished
    c) on TWRP
    go back to home screen, tap install and navigate to sdcard1 (panel on the left), keeping Zip signature unchecked
    d) swipe to confirm flash and wait

  9. reboot and setup with eOS

All ended well and now I can start using my very first tablet.

As far I can see, it works properly, but I still encounter problems that I find in my S8 smartphone. For example, on this tablet I cannot add my (webdav) Gandi account with the embedded DAV5x fork, while it works properly with my /e/ account.
On my S8 I have installed DAVx5: there I can add my own Gandi account but not the /e/ one.

Shall I report here other problems or on gitlab ?


Thanks for the feedback and yes pl raise the issues on Gitlab

I have just installed and run this build e-0.10-p-2020081267314-test-z3c with no problems.

I did a ‘dirty flash’ over an earlier unofficial build (e-0.9-p-2020072464361-test-z3c) to preserve my installed apps and data. This worked fine.

The one strangeness was that I have a shortcut to Magic Earth on my Launcher 3 home screen. After flashing the shortcut was still there, but the icone was ‘greyed’, and pressing it give the message ‘App isn’t avaialble.’ When I checked via the app drawer, it looks like the app is not installed. I guess it’s not longer one of the pre-installed apps.

I haven’t run the test plan, because it seems to be focussed on a clean install. If you still need it I can blow away my existing apps and data, do a ‘clean’ flash, and work through the tests. But I’m happy not to do that if you feel the build has been tested enough already :wink:

No need to update the test plan. This build is more to test the OTA and eRecovery. Will be making another set of builds once the eRecovery code has been merged into this branch. Hope to get that done today. Once the build is complete it should show up on all the test devices with the 0.10 build.


tried to use a newer twrp?

I have flashed this build (e-0.10-p-2020081267314-test-z3c) on my Z3C. Should I expect to see an OTA update at some point?

gts210vewifi: Just manually updated, then again automatically. Works well.

Hi! Installed /e/ 0.10 testing version for zangya (bq x2)

sideloading it on previous lineageOS(16), so you can call it “dirt install”

My aim was having Android Auto working thanks to microg integration, but it does not work neither (I’m not saying it’s /e/ fault, just I was not able to make it work in with my car)

  • NO fm radio :frowning: sadly

  • Much better camera app!!

Overall it seems to work fine (calls, im, etc)

I will use it a few more days and then decide if I come back to lineageOS but I wanted to report this here.



Subsequent builds are all OTA.


hee Manoj, no OTA update yet for the YTX703L , is that correct?

Have you not received a single OTA on the tablet?
The first v-0.10…build has to be clean flashed is my guess. I am seeing that in a few posts on this thread. A dirty flash does not help with the subsequent OTA.
All the same have started a build for the YTX703L you can try refreshing the updater in a couple of hours to check,

1 Like

alright i’ll check and if that doesn’t work i’ll try a clean flash

Thanks- I will let you know when a build is available. Was trying to run a build for the YTX703L but it failed due to some issues on our build infra. Will have the team look at it today and then run a new build specifically for this device to test OTA. Will update you.