Device support (Project Treble)

Mhm, interesting. Than LOS must have made any changes in the sources. So I hope in new build it will work again

So, I got myself an Archos Oxygen 63 for a very bargain price. It’s a surprisingly firm build.
It’s not receiving any updates, neither system, nor security. It was released with Pie, with the April 2019 patch, and no updates. I’m trying to argue with the company in email, as UniSOC has clearly released not only Android 10, but even Android 11, for the vendors using their SoC.
Two other problems I have are the lack of OTG, but that’s a software issue it seems, the required xml file is missing, and the quality of the camera, which could very well be also a software limitation, using pixel binning. If these can be fixed in a ROM, that would be awesome.
It’s an A-only Treble device.
It’s OEM unlockable, and it’s plain old fastboot.
No TWRP yet.
Also I haven’t seen any source files.

I think this will be a show stopper.
You can try

  1. fastboot -w for formatting /data
  2. flashing GSI with fastboot.

But if this will fail, your devices is bricked and I don’t know if there is a way to unbrick.

I mean, there’s the switch in Developer Options, like you’d have with stock Google devices. Not sure if it needs any other further unlocking, but probably not.

(Apart from MobiSystems’ File Manager and OfficeSuite apps, it’s a vanilla Android with Google stuff. No fancy custom UI.)

Hi @harvey186,
I’m an incorrigible enthusiast and I’ve a new Treble project: OnePlus 5T ‘dumpling

Actually I wanted to test LeOS ‘R’ but started with ‘Q’ - GSI.

I have tried to install Q-GSI in different ways. Also with this …

I have also used it unsuccessfully: DisableForceEncryption & Permissive_v5.

After reboot I always end up in dumpling’s ‘FASTBOOT’ but not in /e/ OS.

Does GSI specialist @harvey186 know advice?

OK, the List shows arm64 a-only, the app is showing arm64 a/b. And as we know, the info’s are not always right. So first I would try a/b GSi

As I already wrote, I have tried various things, - also a/b GSi and a-only GSI ROMs … without success.

ah, Ok. So the last chance is updating the firmware (but I think you already have done)

At last I would try a GSI from PHH to test, if it’s a eOS (LeOS) issue or a general.

Yeah, OnePlus 5T came with current OxygenOS 10.0.0 (stock Android 10) and TWRP 3.4.0-0.
Neither could I install the grandmaster phhusson GSI ROMs. The device always ends up in Fastboot mode …

OK, good news do me, that the issue is not in my GSI’s, bad news for you that none are working :frowning:

Have you flashed the system.img via fastboot or with TWRP ?
when flashing via fastboot, have you used the command
fastboot reboot fastboot ? The device must booted in fastbootd !!

Here a tutorial from an Android10 superpartition user who have installed GSI successfull

I have flashed with fastboot as well as TWRP.

In TWRP: reboot ends in fastboot mode.

And no, fastboot reboot reboot fastboot I did not use ? I will try again according to your tip.
Thank you, @harvey186 !

Currently LOS 17.1 is running …

any idea how to make ringtone and notification sound to work on poco f1 with any gsi Q .all other sounds work fine

On my dog walk I have thought about your issue. I think I was confused. Your device has Android 10 installed, but it isn’t’t a Android 10 device with super partition. So I fear the fastboot reboot fastboot to get in fastbootd mode wont work :frowning:
Only on devices which where shipped with Android 10 fastbootd is available

it seems that you will need some more things to do

Yeah, I guess so.Thank you very much for thinking intensively about the problems I have caused myself.

OnePlus 5T was released with Stock Android 7.1.1 (Nougat) and has been upgraded to Stock Android 10 (OxygenOS 10.0.0) over time - supposedly including Treble Project support. The standard version of TWRP 3.4.0-0 shows the partition /VENDOR. But there must have been something I missed. I will try to figure it out, because I see this as a GIS learning process.

Devices which where delivery with Android < 8.1 are no treble supported devices. You can ‘treblize’ some devices with special patches (shown in the link above), but GSI will always be very buggy.

Well, I know the requirements for “Trebled Phones”. But your statement is not universally valid, because a few phones received official system software updates from the manufacturers who implemented the official Treble support - for example: Samsung Galaxy S9/S9+ and also OnePlus 5/5T. See also Full Treble on Oneplus5 via Phh-Treble by phhusson. There must be other reasons why I can’t get the GSI-ROMs to work. Maybe only GSI-9-Pie ROMs work and not GSI-10Q/11R? I just have to try it to know…

That’s what PHH has told me :frowning:
I think the problem will be the vendor sources. It seems for me, that the access to vendor diver is different in Q/R as on P. That’s why often P-GSI are working and Q/R-GSI not.
On my MiMax3 the camera doesn’t work with P-vendor sources. I have tried a lot with PHH, but we don’t get it running. After I have upgraded the vendor firmware to Q the camera is working under Q and R.
On my Mi Note 6 pro the same. With P-GSI all working, with Q also, but with R Camera is crashing.

I think if you will get a bootloop and the permissiver don’t solve the loop, it’s an firmware issue.

Yeah, all the information I have found so far on the www suggests that the sticking point is the vendor sources. Just the presence of a partition /vendor is no guarantee for success. Only definitely know I don’t do it.

@Gorets Thanks for this list !

However, the coloured circles are illegible for colourblind readers. :frowning:

Could you please use another way to display this information ? Thanks ! :slight_smile:


I can change the round colored labels to numbers, so would it be better?