Different default launcher

Hi,

Would anybody explain me why when I change the default launcher which is Trebuchet on Lineage into for instance Lawnchair or Nova Launcher, etc. after disabling completely Trebuchet service I loose functionality of the Recent apps button.
I think that in recent eOS builds for some reason Trebuchet service appeared and it also changed a way of getting to the “Clear all” short. Previously I had to swipe down all recent apps to clear all apps since the update I need to scroll right to clear all apps which is the default behavior for Trebuchet. I haven’t updated my launcher, at all.

Anyway, is there any trick to use different launcher totally without active Trebuchet in the background without loosing system functionalities?

Cheers,

1 Like

Do you mean you have Trebuchet in /e/ without installing it yourself?
The default launcher in /e/ should be Bliss.

What does Settings - About phone - Android version (tap on it) - /e/ version say for you?

Hello.

When installing another launcher, Bliss’ bugs show a brief “Trebuchet already stop”. Seen in both 20210814 and 20210828 0.18-GSI.

2 Likes

0.18-q-q20210828132307-dev-tissot

Hmm, Actually I disabled bliss quite long time ago and started using Lawnchair. I think two build prior I’ve noticed that I have to clear all apps in a different way than before.
So Now I have Bliss (disabled), Trebuchet (active in background) and Lawnchair (using it). I would say quite enough for me :-))))

When I disable Trebuchet, too I loose Recent apps button :frowning:

Trebuchet is in “system apps” on my default install’…

1 Like

0.18-20210827132307 enchilada

Confirmation. I just tried disabling Trebuchet and a warning told me I couldn’t uninstall it as it’s a system app part of the /e/OS. In effect, it disables the recent apps button when turned off, so I re-enabled it with App Manager. BTW App Manager was not too happy with one or two of Trebuchet’s activities as it had access to the phone and could read external storage, so I disabled these functions as they seemed unnecessary activities for a launcher.

In fact I replaced Bliss with Omega as my launcher and am very happy with it. Much more adaptable than Bliss.

3 Likes

Do you now have the “recent apps” functionality?

Ok, I can see it, too.

Confirmed, I get this, too.
Odd, but then it’s Android. Whatever works :slight_smile: .

Storage and Telephone were “Denied” for me.
I disabled Trebuchet and enabled it again, and they are still denied.

Same on my phone now that App Manager stopped this access. In fact, it shows that there was never any attempt to use it, so I suppose Trebuchet behaves itself. I reactivated it via App manager, but it can also be re-enabled in the system settings. So in answer to @Doppel-D the recent apps functionality is working again, but since version 0.18 - the latest update - it now works as @cooky describes above: you have to scroll left to find the “clear recent apps” button. I find this an improvement as the scroll function I find easier to navigate.

I have the same trouble here since I installed /e/OS 1.5 on my FP3.
In short : recent app button not functional with any launcher other than Bliss…
I’ll follow this thread with great attention :smiley:
… and continue trying other launchers from the (almost infinite) series in F-Droid, selecting only recent active ones -but in vain, up to now…

To install different launchers was not what brought the Recent Apps functionality back according to this topic here … reactivating the deactivated Trebuchet system App was.

indeed. But the OP chose the title ‘different default launchers’ and Trebuchet suddenly dying just seems the origin of the trouble when actually switching launchers…

1 Like

Exactly. Did you make sure it’s activated?

How do I do this? Trebuchet doesn’t even appear in the app list?

Settings - Apps and notifications - See all … apps - (three dots menu at the top right) - Show system

Thank you!
Indeed I see Trebuchet apparently activated (I didn’t ‘deactivate’ it nor force it to stop). Its announced version is v11, ‘com.android.launcher3’
But activated or not, the trouble stays the same (no ‘recent apps’)
(I restarted the phone, but I see Trebuchet stays deactivated through the process.)
And when Trebuchet is deactivated, even Blisslauncher doesn’t react to the ‘recent apps’ button.
So, I’m going to reactivate it…

1 Like

I really dislike Bliss Launcher and have tried a few others. I am forced to use Bliss because it cannot be uninstalled and whenever I restart my phone it reverts back to bliss and I am forced to constantly reset my default launcher so, like I said I am forced to use the Bliss Launcher. I pretty much hate everyone who makes any tech or app. Either they want to spy on me or they force their options on me. Yeah some of this is free but I’d actually pay someone if they’d come up with crap I’d be happy with.

Yeah, great post, man.

Not via the push of a button at least. Did you try the ADB way in this case? See this post and the following one … Uninstall default apps - #29 by AnotherElk

That it is possible this way was also acknowledged here … Third party launchers - #7 by Manoj

That’s not normal.
Many users here use alternative launchers, even without uninstalling Bliss, and don’t have to do this (including me).

2 Likes