Drops automatic sync (Fairphone 2/3)

I changed from Fairphone 2 to Fairphone 3 (no 3+). Mail-App: same behaviour: After a time it drops/stops automatic sync. Mostly after cleaning app-cache it works again.
MicoG is running well (other apps a registered - should mail too?) I looked many options, but battery optimization is not reachable for app. Other options: no change. Tried Fairmail: Sync ist running well, why not the system mail app? This is disappointing. I would deactivate this app, but also this is not possible. Any ideas or hope for changing?

Can’t confirm. Syncs several manitu.de accounts for me continuously on a Fairphone 3.

(Although this reminds me I haven’t installed the latest update yet, I’m still on IMG-e-0.10-p-2020080666687-dev-FP3, but you even had that on a Fairphone 2, so I guess it still counts).

It is possible, see here … Uninstall default apps - #29 by AnotherElk … and the following post after that.

Thanks for reply. I’m on newest version and no signs, why this happens. Mail disabling automatic sync and shows it “correct” (“Synchronisation deaktiviert.”).
I think, dactivation only over Android SDK/adb is not a way for normal use :wink:

(Vielen Dank. Die neueste Version läuft und: Deaktivieren einer App per adb ist bekannt/kann ich, aber das kann es doch nicht sein …)


there is an issue with Mail notification on /e/-0.11.

You can follow the issue on our gitlab :

Thanks! But after a while and some updates now: /e/OS 0.13-2020120889008

there is an issue with Mail notification on /e/-0.11.
This is NOT the mentioned problem.

SysApp “Mail” suspends synchronization after a certain time (different mail providers). I can’t see why and when. I tried a reset: no changes. After a few hours, sometimes a day, but sometimes also in a very short time, the app changes to “synchronization disabled”. This is NOT usable …

… synchronisation (here) isn’t save. Checked experience is: leaving home WLAN to Mobile-Connection (mixed here - LTE/4G, Edge or nothing), then the mail app on my FP3 stops syncing after some time.

Fix: stop and clear memory cache of mail app - until next time.
Is there a workaround or a fix of this issue?

K-9 mail also doesn’t seem to be syncing or notifying. I’m syncing manually as a workaround.

Xperia XZ1 Compact, with this build: [UNOFFICIAL BUILD] Sony Xperia XZ1 Compact (lilac) e-0.13-q - #59 by petefoth

Which version of K-9 Mail do you have? I am using v5.737 from F-Droid, and before that I was using v5.734. Both versions, and the versions I used previously have always synced automatically with no problems.

Is the problem with your e.email account, or a different account. I use it with several accounts, including my e.email account. All accounts are still working fine for me.

Have you changed anything in the “Settings | Fetching mail” for the account?

I had 5.734 from F-Droid. Just upgraded to 5.737.
Using 2 different email accounts from different providers.
No e.email account.

Fetching Mail Settings:
Local folder size 25 messages
Sync messages from any time.
Fetch messages Up to 64 KB.
Folder poll frequency Every 30 minutes.
Poll folders Only 1st Class Folders.
Sync server deletions. (On)
Mark as read when deleted. (On)
When I delete a message Do not delete on server.
Erase deleted messages on server Manually.

Notifications Settings:
New mail notifications Notify in status bar when mail arrives. (On)
Notifications folders All.
Include outgoing mail Show a notification for messages I sent. (On)
Contacts only Show notifications only for messages from known contacts. (Off now, but I had this On before… May be the problem?)
Sync notifications Notify in status bar while mail is checked. (On)
Notification opens unread messages. (Off)
Notification Settings - System notifications (all On)

I think it’s working correctly now, after I upgraded K-9.

… fine. But I meant the build in app “mail” on /e/ (seems to be a fork of K9). I can’t understand: Breaking syncing is about from 2019. No changes, no fix until now. Manually syncing is NOT a solution. Fairmail can do this save, the sys-app “mail” not??? That’s disappointed. So, mail-app is useless in production and it is still not possible to disabling it and replacing fully (in the gui, I don’t want this via command line etc.) Is this behaviour of sync-failing on any task list?