/e/ easy installer Samsung Galaxy S7 no TEAMWIN? Help please

Thank you for reading this. I am trying to use the easy installer to install e on a Samsung Galaxy S7
I have downloaded and installed the easy installer on to my Windows 10 PC. I have done this so far.

  1. Open the easy install app.
  2. Connect the phone via usb.
  3. Enabled developer mode by tapping on build 7 times.
  4. Searched for Debug but no Android Debug was found. (I had a look in the forum and think this is USB debugging which is now switched on.)
  5. Found USB Configuration and selected MTP.
  6. The easy installer then says your SM-G935F is compatible.
  7. The easy installer downloads 2 files twrp & herolte.zip.sha256sum
  8. I turn off the phone
  9. I press power,home and vol down until a bluescreen appears and it does.
  10. I press volume up to continue and the screen turns blue downloading.
  11. Meanwhile on me PC widi-simple.exe asks permission and I allow.
  12. Then on PC a black box opens
  13. C: Extracting driver files…
    Installing driver(s)…
  14. The black box closes after30 seconds with nothing else typed.
  15. The easy installer says press power ,home and vol down until the device turns off
    15 The easy installer then says press power, home and vol up until Teamwin appears but it does not come on the screen.

This is how far I have managed to get so far. I would really appreciate a little advice from anyone who knows where I am going wrong. I have installed SDK Platform tools and that has not made a difference either. Thanks in advance.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @Degoogleme,

Assuming you are stuck only at the point I think you describe, here is the very long explanation!
It is reliably reported that when one reboots a clean and original Samsung phone the system will check the whole phone, including the Recovery and Download mode, and attempt to clean it of any non-Samsung material. The trick to make the first launch of TWRP requires patience and timing skills.

If you believe that you flashed TWRP, then allowed the phone to boot back to Samsung, you must go back and reflash TWRP

Put another way, when you first want to use a newly flashed TWRP, you really don’t want to reboot, you are likely to lose TWRP.

Put another way, if you see the Samsung original recovery, you don’t have TWRP and can assume it was overwritten, you must go back and reflash TWRP.

For first time access: you need to Force Stop but interrupt System reboot and then access Recovery mode.

Understand how the instructions below match the concepts above.

Memorise the second instruction: to access Recovery mode:
“Press and hold [Volume Up + Home + Power] buttons, perhaps over 10 seconds, don’t let go of any buttons as the screen changes (more than once) be prepared to keep the three buttons pressed until you finally see TERP wording.”

Start the procedure after you are given the indication that TWRP flash succeeded

Force stop [Volume down + Home + Power] get the timing right, it might take 10 seconds.
The screen will change, but,
keep the buttons fully depressed, so that the phone stops but does not start to restart
You must react at exactly the point where the screen goes black (black, as in OFF), you may feel a vibrate,
Move the finger holding [Volume down] to [Volume up] so that you change to “access Recovery mode”.

For reference - General Samsung instructions

Not all Sumsung phones have exactly the same hardware switches, some have a bixby button. If in doubt check a reliable Samsung source to find the hardware switches to achieve each of the following for your model. (Much older Samsung models with removable battery, are obviously dead easy to “Force stop”.)

  • Always find your way home:

“Soft restart” or “System boot”:
Mostly (phone on, but operator is lost), press the Volume Down and Power buttons together for around 10 seconds until the phone restarts.

  • Access Download mode:

With the phone off, press and hold [Volume Down + Home + Power] buttons. (7 - 10 seconds).
Use volume buttons to navigate.

  • Access Recovery mode:

With the phone off, press and hold [Volume Up + Home + Power] buttons, perhaps over 10 seconds.

1 Like

It looks like there are problems with the flashing TWRP step in the actual beta version 0.12 of the easy installer,
I you want to install /e/ today, it’s more efficient to use the direct method, we can help you if you need

Do you really know that for sure? If you keep on suggesting to follow the HOWTO, how do you think the installer can be improved to not having a problem flashing TWRP?

On a different note: it would be really helpful if people could upload the logs so we can finally understand what the problem is.
How to find the logs is described in Howto troubleshoot issues with the easy-installer

My assumption - and if I understand aibd correctly it’s what they think, too - is that after flashing of TWRP (and I’d like to see in the log if that was successful or not) one has to reboot to TWRP immediately (that’s how it was on my Fairphone 2, too), otherwise it will get overwritten by the stock recovery.
Which makes this an issue of timing when pressing the right buttons on the phone. Which wouldn’t be a problem of the installer alone but could also happen while flashing manually.

i am sure of nothing (by principe) and because i haven’t any device compatible with the easy installer and i have loaned my computer to a friend because i can’t plug it to the electricity

That’s what i was thinking too, but

a user says that flashing with Odin he saw the blue advancing bar on the download mode screen, and it wasn’t present with the easy installer,

another user share a log where the easy installer stop just after installing the USB drivers

so i deducted it wasn’t a simple press button timing problem but a flashing problem.

Do you remember which topic that was in?

Hi Piero

Thank you for the info its been a great help. I followed your instructions [HOWTO] Install /e/ on a Samsung smartphone with Windows easily

  I have got to stage 8 part 3 and deleted the 5 items on the list. I got the red error message but the phone would not let me go back to Wipe to go back and  select a different (exfat) system. I waited an hour but the and tried switching off and back on again. The phone just comes up with twrp home screen but I dont know how to get back in to the menus. 
  I tried the next step of installing /e/ rom to internal storage on phone from the PC but when I connect the phone neither the phone or internal storage are shown on PC. 
 Have you any idea what I have done wrong?

The /e/asy installer also does not offer an Undo function. Opposite the blue 'Continue' button, i.e. where the green Donate button is, a helpful ‘Back’` to last point function should be integrated.

Witch TWRP version have you installed on your s7 please ?

Even if using Windows you can read the Linux guide i wrote for more details ( most of the steps are common )

@Degoogleme you chose a nice name :black_joker:
Points to experience in this environment?

In the anonyme’s guide for Windows,

after step 8)a)2., you have to tap back to the main menu and reboot the device in recovery again ( as the device screen tells you to ) before following step 8)a)3.

@Anonyme please correct it…

Hi Piero

Thanks for getting coming back to me. I installed this version twrp-3.5.0_9-0-hero2lte.img .Do I need to try a different one?

I think so, as :
twrp 3.3.x-x works well for android 7 nougat, android 8 oreo and android 9 pie.
twrp 3.4.x-x was designed for android 10 Q and was not working for previous versions.
i don’t know twrp 3.5.x-x but it is suppose to be working for android 10 Q and android 11 R

Hi Piero

I am on Android 8 and have tried both 3.3 and 3.5 tar files and I still cant get into TWRP any suggestions.
Here is the log file which may tell you where I am going wrong. Just cant get into no matter what I do it seems.

Odin engine v(ID:3.1303)…
File analysis…
Total Binary size: 43 M
Get PIT for mapping…
Firmware update start…
NAND Write Start!!
Remain Port … 0
All threads completed. (succeed 1 / failed 0)8 so should

All seems good with that log,

Have you think of deselect the auto-reboot option ?

I have tried thank you for your help Piero. Its not working for me but I am going to give the phone to a friend who is a little more technically minded than me. Thank you for all your help. Merci.

After flashing the custom recovery, you have to reboot to TWRP #before# any other boot attempt