/e/ install on Samsung Galaxy A3 (2016) a3xeltexx - ALMOST - failed

Having recently installed /e/ for a friend on a Galaxy A5 I had little difficulty though I reluctantly had to use Odin to install TWRP. With this similar device I ran into several problems as I wanted to do an install solely with my Linux computer. The first problem was with heimdall. Although it recognised the device with the “print-pit” command it failed to flash the latest TWRP and gave the error “Failed to receive file part response”. This is apparently a known bug with the SM-A310F device.
So I had to go back to Winblows and after several attempts finally managed to flash the 3.4.0-0 veersion of TWRP. I made the mistake of accepting the “read-only” mode and had to reinstall and try to put a password on the device beforehand. Apparently at the second attempt I was not offered the “read-only” choice so went ahead and tried to flash the latest test version of /e/ with Pie, but ended up several times with the Error E1001 “failed to update system image” apparently because it couldn’t create /cache/recovery/ directory, saying it didn’t exist. I tried again sideloading the /e/ file in the hope that the one I put on a USB stick was the source of the problem.
Though the adb command said the sideload was successful I failed to locate the file on my device. I tried again to flash the Oreo version of /e/ but ended up with the same Error E1001.
At this point having spent most of the afternoon searching for solutions to my problem, I gave up in despair as TWRP warned me not to reboot without a valid system. So I just powered off.
I decided to leave a message here in the hope that the closure for maintenance of the ecloud server would not paste my message to to /dev/null.
However, never say die!
I just wanted to check that my new A3 wasn’t a total brick, lovely and light though it is. So I decided to reboot into recovery and was relieved to see my dear TWRP was still their. This time it asked if I wanted the “read-only” mode but forewarned I refused expecting to be asked for a password but no query popped-up and I was back in the usual TWRP screen, so on the off-chance I thought I’d give it one more try. I plugged my USB stick in and selected the latest test version of /e/ with Pie. In for a dollar, in for a dime as they used to say and swiped to start the flash expecting another Error 1001, but the blue progression bar started to be filled as it does with a normal OTA update, and fingers-crossed I awaited the result. Joyful at the sight of the famous “1” result indicating success, I rebooted and now am delighted to have what seems a perfectly good working system - only problem was being unable to sync with my wife’s /e/ account - due to server down I suppose. For the moment I shall see if I have the courage to go through the Manoj’s long check-list for volunteers he had invited to test all its functions. Weather is unbearable hot here in SW France at the moment and my fingers end up sticked to the keyboard as I write this. Hope the end of this month sees calmer, cooler weather and I’ll find the courage to update my impressions of this Pie version of /e/.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @Grendel was this build the official ROM or the test build?

You can change this choice later in TWRP by enabling or disabling “Mount system partition read-only” in the Mount section.

TWRP tries to save a configuration file on the phone (depending on storage setup and encryption this may be possible or not). If successful, TWRP remembers the settings via this file and doesn’t need to bring up this read-only prompt again.

Because this is not what ADB Sideload does, it doesn’t just transfer a file to the phone. ADB Sideload does the same as if you select “Install” in TWRP and select a file to install.
Once ADB Sideload ends with a success message, whatever you wanted to install is installed.

This can be a false alarm of TWRP. As far as I have seen it is not known why TWRP gets this wrong sometimes.
I don’t know how Samsung devices behave, but normally there should be no harm in just trying to boot. Either it works, and you’ve won … or TWRP was right and you “just” need to try whatever you tried to do again.

The test build: e-0.10-p-2020081067156-test-a3xelte.zip
Up till now can’t find any problems - only that there seems no way of creating labels for Contact groups as you could with the oreo version.
I forgot where I found your checklist spreadsheet file.

Thanks for the tips about the new TWRP version. I admit that I should have looked up more information on how to use it before flashing it, but I was used to the older version which doesn’t offer the “read-only” option.

hi all, just wanted to say I am surprised to see this post. With me installing /e/ on the a3xelte / a3xeltexx went without any problems and really smoothly. I do remember from in the beginning, when i still had to install TWRP, that I did not use Heimdall but did it a different way. I could not get Heimdall to work on Windows. Is Heimdall currently in the /e/ instructions for this phone? If so perhaps good to replace it by the alternative, that was also discussed in this forum i remember.

From a brief web search I came across several people complaining of the same “failed to receive file part response” which seemed to be a bug specific to the 2016 A3. Here:

Otherwise Heimdall under Linux seems to work with most other phones or so I read. I came across one person suggesting a hack workround, but it meant inserting a section of code in one of the heimdall files, which I was reluctant to do.

Perhaps we should just put an alert for this phone. Otherwise with Odin no problems.

TWRP 3.3.0-0 is the more secure version for eOS ROMs Oreo 8.1.0 and Pie 9.0

TWRP 3.4.0-0 checks for failures and boot loops on several Samsung devices. TWRP 3.4.0-0 is perfect for LOS 17.1 ‘a3xelte’ builds.

This is an open issue on Contact for some time.

I bought an A3 2016

And i installed the latest version


now my phone reboots endless…
But now my phone

Hi all,
I try without success to install /e/ until I finded e-0.10-p-2020081067156-test-a3xelte.zip

With many builds, I fall into the wifi bootloop problem, even the last one e-0.11-o-2020082870470-dev-a3xeltexx.zip.

I need to say that the last version of LOS (lineage-17.1-20201018-nightly-a3xelte-signed.zip) cannot connect to wi-fi but do not reboot as e-xx does.

Now my phone is up and running :wink:

Hello Grendel. Yesterday I had the same problem to put TWRP on my Samsung A5 (2015) SM-A500FU with Heimdall. I’ve been working hard half of an entire days, close to throw my device in the trash. And finally I’ve found a post very interesting, and succeed to put TWRP on the phone. There is a problem with Heimdall, or computers have a problem with Heimdall. It depends on the USB port you plug your phone. I guess it is a problem with the chipset inside and the buses. On some ports the process runs, on others not. I change of port, and it run. JMH

Hi there,
I had the same “failed to receive part response” problem when trying to flash TWRP with heimdall for a Samsung A5 (2016).
I managed to solve the problem simply by using SUDO before the command and was able to install TWRP 5.x
Now /e/ works great on the phone.

I just installed a3xelte on my Samsung Galaxy A3 2016, (after having installed LineageOS) via TWRP. The system seems to run correctly, I have correct access to my /e/ account, apps are running fine. But everytime I switch off and reboot the phone, I get a screen saying there is a problem inside and that I should contact the manufacturer. I tap on OK, and I get on with using my phone, but I’m a little worried. So far I haven’t noticed any disfunction, so I don"t know what to make ot it.
Any advice ?

Hi, that has been reported as a bug, seems most users find it not a big issue.

thank you [aibd]
I don’t find it very upsetting either.
More annoying though, the fact that when I use bluetooth in my car, for example, I need to authorize the radio everytime again and again (by typing the secret code). It’s not practical at all… I tried to search if I could authorize the device once and for all, but I can’t seem to find the option.

Thanks in advance for your tips

I do not want to sound defensive of /e/ !

While possibly it could be a version conflict in Bluetooth, it seems to me that the car is making an issue of not “pairing for life”. Is your issue audio, or phone Bluetooth or both? :slightly_smiling_face:

Well… My car certainly never asked that to any of our previous OS (lineage OS or Android)…
So I would tend to believe that it’s /e/ which changes the game …

1 Like

I guess that is a bug. I just got the opportunity to try to pair with a Skoda, and my A3 (2016) appears to fail to open a dialogue to make the pair at all!