/e/ installation on galaxy s9 plus can't get into Teamwin

Don’t update your stock ROM anymore

I had the same issues. Please see THIS thread.

If you are in the USA and have updated the stock ROM to Android 10 (not sure about Android 9) I don’t believe you can get the RMM to normal. I have tried everything. This means the bootloader is unlocked but Knox/RMM blocks (edit: due to regional lock, non USA phone being used in USA) the TWRP flash to the bootloader. I had the same issue.

EDIT: If I could go back in time I would buy direct from the eStore or use different hardware (non Samsung).

@Redsidriver also read THIS.

If you are in the USA you are experiencing what I just went through, DO NOT UPDATE your stock OS or you will be stuck in RMM prenormal (EDIT: and you won’t be able to flash anything, TWRP or any “official” ROMs lower than Android 10 (Q), nor "non-official ROMs)

@Redsidriver, I woke up thinking, have you had a working SIM card in the phone?

Then, just looking for what you might have in common with @egx470, what part of the world are you? and was the phone sourced locally? Good luck.

Im in the U.S. and i bought it on Ebay . I believe it shipped from Florida . I do have a working Sim in it right now . When i first got the phone I was on ATT but just last week I switched to T Mobile. Unfortunately last night i finished updating my phone to what SuzieQ recommended. Here is the link I bought it from .

Thats rough i sat with exactly the same problem yesterday, but i just kept doing that step over and over and after the 10th or 15th try it just worked. Some thing i found online were some people saying it was important to when you were trying to get to the TWRP and you have to hold power+bixby+volumedown you dont lift your fingers you just move the finger on volumedown to voulmeup as soon as the phone goes dark, i dont know if that is what did it for me but after i did that it only took two trys and then it worked. Good luck.

1 Like

If your Galaxy S9+ ‘star2lte’ is ever to work with /e/OS ‘Q’, then a stock Android 10 must be installed first - no ifs, ands or buts unfortunately.

As has been repeatedly demonstrated, the prospective /e/OS user needs to be aware of all eventualities before switching operating systems. “When the child has already fallen into the well”, there is a lot of crying and of course the others are always blamed for one’s own misfortune.


Im moving away from Samsung hardware here in the USA. From what I see they are manipulating Knox/RMM to lock out one’s ability to flash TWRP/non-offical Samsung operating systems if they are used outside the geographical area they were designed for.

Anyone have links to good non-Samsung hardware reviews in this community?

xiaomi oneplus essential motorola


1 Like

Thank you @piero. OnePlus will be my next phone. I struggle to support a company like Samsung when I see them making decisions to do what we see on this thread.

1 Like

:rofl: i wasn’t crying just stating a fact that it was your advice. I’m still holding out hope obviously i still need to do more research and there will be more mistakes made along the way . In the end if it doesn’t work for me oh well the phone still works as it currently sits. I knew that was a possibility of doing it myself especially because I’m brand new at this . So please don’t take it as me passing all blame on you.

Thank you for sharing! :smiley:

I think you should stay confident!

Vendor tells you it is an international version. Perhaps it may have a Regional lock, which takes 7 days to undo??

What I would really like to see is evidence of the Regional (or other) lock.

Maybe any lock will be revealed with:

adb getprop

Or, install Termux and run


The idea is then to search for any known locks. (Lock, FRP, Rlc). Whole output will be too big to post directly, will need a “paste bin”, say, https://haste.tchncs.de/.

1 Like

I do plan to keep trying but for now I have to do some more research on how to get past the issue . I thought I did enough research before hand but turns out I didn’t . I do appreciate all the information yall are giving me . Like i said before I am brand new to this so i am nervous because i don’t want to end up with a 400 dollar brick

is totally non-invasive, it just reads and outputs some data from the system!

1 Like

This is good advice.

I haven’t seen the evidence in any code. The only evidence I have is from what others have told me/I have read and my inability to flash anything to my stock S9+ (SM-G965F/DS) which updated to Android 10, Q. I can’t get TWRP on this phone nor can I flash to Android 8 or 9. Very frustrating. Thank you for all your help @aibd.

I wish I could help with this but I finally sold the phone. Sorry.

1 Like

just some data … with my ‘star2lte’ there are 297 lines of information.

The input of the command
adb getprop
reports for me:
adb.exe: unknown command getprop

With ADBcommand
adb shell getprop
however, I get the above 297 lines of information

Examples ‘adb shell getprop’ Commands

adb shell getprop
Get Android system properties info.

adb shell getprop ro.build.version.sdk
Get SDK API level.

adb shell getprop ro.build.version.security_patch
Get Android security patch version.

adb shell getprop ro.board.platform
Get Soc info.

adb shell getprop ro.build.version.release
Get Android version info.

adb shell getprop ro.vendor.product.model
Get Android device model.

adb shell getprop ro.product.manufacturer
Get Android device manufacturer.

adb shell getprop ro.serialno
Get ADB serial number.

adb shell getprop ro.oem_unlock_supported
Get OEM unlock status.

adb shell getprop ro.bootimage.build.fingerprint
Get Android device build fingerprint.

adb shell getprop ro.boot.wifimacaddr
Get WiFi MAC Address

1 Like

If it is any comfort I confirmed with Chimera that their RMM tool works with BIT1 & BIT2 but beyond it no longer works. This means that when your phone updated to Android 9 (Pie, BIT7 as pointed out by @SuzieQ ) this route was lost. This happened before going to Android 10.

1 Like

I am very sorry to write that suggestion without correct Linux/Windows instructions.

With the 300 lines we now search the text for lock, FRP, Rlc. or any other clues. Such searches reveal this from an unlocked and productive Samsung:

[dalvik.vm.lockprof.threshold]: [500]
[ro.frp.pst]: [/dev/block/platform/13540000.dwmmc0/by-name/PERSISTENT]
[sys.oem_unlock_allowed]: [1] 

Interesting FRP has been displaced as a lock, but still a trace of it!

The reason that I think it will provide a clue is that one of the more intrusive methods of unlocking, seeks to interfere with:


Hence my interest in seeing what properties these private-apps may have left on a “locked” phone.

1 Like

Yeah, in our daily routine we always forget the small but very important hint which OS our host machine is running.

Even though the majority of the /e/users posting here work with a Linux derivative, the vast majority of all general personal computer users use MS Windows as the operating system for their PC, notebook, laptop …

This is an official Samsung notice on a original Galaxy Box.

European model: This product should be used with a SIM card provided by a mobile operator from the Europe region (defined as EU/EEA, Switzerland and the following countries outside the EEA:


If you want to use SIM cards from countries outside the European region, you must first make a call for at least five minutes using the SIM card of a European provider within the European region.

It doesn’t have to be a SIM from the country where you got your Galaxy either, what’s important is that a European Galaxy does 5 minutes of voice calling using a SIM from a European carrier (here “Europe” refers to the EU and the European Economic Area, not the geography term).