/e/OS on Google Pixel 2 XL not booting

I just bought a Pixel 2 XL to flash it with /e/OS by following the documentation on the homepage: https://doc.e.foundation/devices/taimen/install

The phone was reset by the owner and by me another time. It’s just plain Android 10 on it and that’s it. No password, nothing.

Everything works fine until the chapter " Installing /e/ from custom recovery". The problem is, that I want to boot into TWRP, but all I end up with is the splash screen of Teamwin and that’s it. It doesn’t go any further. I downloaded ALL images on https://dl.twrp.me/taimen/, but it’s the same with each one of it.

What I see and what I do is the following:
I flash the device with
fastboot flash boot twrp->VERSION,-taimen.img
I am then redirected to the bootloader, where I select Recovery Mode.
I then see a warning, saying The bootloader is unlocked, etc.
Afterwards, a Google screen appears with an unlocked lock on the bottom, followed by the frozen TWRP splash screen.
Sometimes I also use adb reboot recovery at the splash screen, which basically sends me once more into this loop. But it doesn’t go any further.

I really don’t get the mistake I am doing. Any help?

This device has specific TWRP installation procedure : https://twrp.me/google/googlepixel2xl.html
In short : boot temporary to .img, push .zip, install .zip.

Did you try this way ?

1 Like

this should definitely be included in the /e/ documentation!

Hello @Gabriel,
your “taimen” runs with Android 10 and a specific Android 10 Bootloader-firmware. /e/ for taimen dev (oreo) runs on basis Android Oreo 8.0.0. I know from other devices that this combination can cause installation problems.

Therefore my tip: Do an OS downgrade from StockROM Android 10 to Android Oreo 8.0.0. Then repeat the complete installation procedure from /e/ on a Google Pixel XL 2 - “taimen”.

1 Like

Hi guys.
Thanks for the fast reply!
@smu44 - I kept on trying and reinstalled the factory image provided by Google and then restarted the procude in the manual which got the TWRP-bootloader running.

@archje - I just have the sideload step running. Let’s see, but I feel I get into troubles after what you said. While sideloading, my screen also turns black. I don’t want to interfere, but I am going to reload in a minute.
OK, update:
I installed the stuff via sideloading, but it cancelled somehow. On the next boot, I get booted into LineageOS’ recovery screen. Here I can do some stuff, but sideload will cancel after 47%. I’ll go with factory reset to Android 8.0 and try once more.

I have another thing, which is false in the documentation, I will look it up and post it as soon as I have time.

There are umpteen examples. Here his only three mentioned:

We have seen such bootloop issues on most devices when we try to downgrade the OS.”

Oreo does not work for most devices.

trying to downgrade the OS.”

1 Like

Ok, the other issue I found:

In the manual, it says to use either
fastboot oem unlock
fastboot oem unlock-go

Both didn’t work for me. But I used
fastboot flashing unlock

Ok guys. So small wrap up, before I get to the next problem.

I got the Pixel 2 XL and use adb as well as fastboot over Ubuntu 18.04.
Preparing the installation and flashing, I downgraded the phone to Android 8.0 from the Google factory images and I followed the whole bootloader unblocking procedure in the manual. I booted into TWRP with fastboot boot path/to/twrp.img and followed the rest of the manual. From here I went two ways:

a. following the rest of the manual, however sideloading stops at (~47%) until finishing. However after step 2/2 the shell on the phone says Unable to find partition for path ‘/cache’
b. uploading the .zip file from /e/ with adb push eOsimage.zip and installing it under TWRP’s install.

If I go into TWRP system reboot, I already get a warning, that no OS is installed. I also used the vbmeta partition, like suggested in this forum thread here, leading to this xda-developers article, but honestly I don’t know when and where within the procedure I should do this.

@archje, the first post you have shared gives a hint on how to install /e/ on the Pixel 2 XL, but honestly I am so confused by the multiple references and that the procedure is not once explained properly.
I bought the cellphone especially for the reason to flash it with /e/ yesterday. I would have gone with another phone otherwise. It took me the whole day to see, that the proceeding from the manual is probably not as straight forward as it looks like and that barely anyone - except for wilson in this thread - made it to install /e/ on this phone. Has anyone ever made it to install /e/ on Pixel 2 XL from the the manual? I am not far from giving in :cry:

let me hold my breath for a moment, but a brave [ Swipe to Reboot ] brought the “dreamlte” to the initialization.

Ohh, that would be a pity. Let the first frustration disappear and then we’ll find new ways. If @wilson makes it, then other users will be able to do it too.

Have you tried this [UNOFFICIAL BUILD] Google Pixel XL 2 - “taimen”? It is a /e/ 9-pie /e/ experiment. @Unknown’s e-0.7-p- Test builds have always worked in the vast majority of cases.

1 Like

HAHAHA, good one. I was just wondering, since everytime I installed any of the taimen images I got into the bootloop.

Well, I tried following his approach with building the GSI, but I really can’t follow the thread. I have the same question than @wilson, but I do not find the answer to it. Next, for the GSI, I have to choose my build type - or flavor - as they call it, but I cannot see my phone in the list. So that’s not really leading me anywhere.

Well I wanted to, but the image is not online anymore. When I try to download, there are no more mirrors available. I asked @Unknown to reup the image. Let’s see.

I just don’t understand, why I am sent into the bootloop all the time. I just want to have a Google free OS :man_facepalming: And I don’t get, why the cookbook on this site doesn’t work. That’s frustrating, even though it seems not too difficult.

Thanks for your help, mate!

Maybe a small consolation, up to /e/ OS 9-Pie was migrated: GrapheneOS 10. It’s a hardened Android without G°°gle

I got LineageOS running from an unreleased image, so at least I am not as stupid as I thought. But still a lot of Google inside, so I could switch to Android One.

I am not sure, if I’ll give Graphene a try, I’d really would have liked to get /e/ on my device. I’ll wait for @Unknown and then see what happens. I am still not very confident…

@Gabriel, I also want /e/ OS to work on all officially supported devices like other custom roms. Until that happens, an alternative OS may have to be used as a placeholder. Unfortunately, this currently applies to several devices from the /e/ potpourri. But I’m still confident - and I want it to stay that way.

1 Like

But why officially stating, that the devices will run /e/OS if it doesn’t. It’s a shame, I could have bought another phone, which installs the OS easier, if I knew the trouble before. I did not go through the whole forum to check out how good it goes, but it explicitly says, that the device is able to run the ROM. OK, @wilson got it running somehow and I try to mimic his approach, but it’s anything but easy and it requires a selfmade GSI. If it is that cumbersome and the provided ROMS don’t work, then just take the Pixel 2 XL from the list of supported devices.
I am used to Raspberries, Linux and all and thus I know, that custom solutions take some time. But this here is rather half-baked. I really want this to work, as I like the OS when it runs (from what I saw). But the whole procedure just scares me off and takes away the enthusiasm I had in the first place. Sorry for the clear words, but we’re both German so I know you can take a direct opinion.

Anyway, I really like to thank you once more for your help and your encouraging words! You keep me trying! I’ll give the whole procedure some more tries until my girlfriend get’s upset. Afterwards, I’ll be done for at least the week. Maybe there’ll be some advances in some days.

I’ll write, when I progress.

I appreciate sincere words in plain language, so you have come to the right place.

I’ve gotten excited about a similar case before. At the moment only an alternative customROM helps against frustration.

I’m pleased about the decision you made to continue and I am looking forward to new news soon.

unofficial builds here for those who are interested