/e/ OS 'Q' alpha builds are coming!

I’m now trying the docker build (docker-lineage-cicd) and I see an error early on, but so far it continues… Trying to build river:

> docker run --rm -v /xtra/e-q-docker/src:/srv/src -v /xtra/e-q-docker/zips:/srv/zips -v /xtra/e-q-d
ocker/logs:/srv/logs -v /xtra/e-q-docker/ccache:/srv/ccache -e BRANCH_NAME=v1-q -e DEVICE=river
 -e CLEAN_AFTER_BUILD=false -e REPO=https://gitlab.e.foundation/e/os/releases.git build-e
[Thu Aug 27 23:52:01 UTC 2020] Starting build for river, v1-q branch
+ build/soong/soong_ui.bash --dumpvar-mode TARGET_DEVICE
23:52:35 Build sandboxing disabled due to nsjail error.
build/make/core/product_config.mk:223: error: Can not locate config makefile for product "lineage_ri
23:52:35 dumpvars failed with: exit status 1

Should this be posted as an issue at https://gitlab.e.foundation/e/backlog/-/issues ?

We had got a couple of issues to be fixed on the build side for Q. Hope to get the team to resolve them by next week.

1 Like

Most of your builds are for mobiles which are no longer available for sale. If i want to install a eOS on brand new phone, there is hardly any option available. I request you to kindly build ROMs for mobiles which are atleast available in market for buying.


1 Like

hi @ankit221215, welcome to the /e/community.

we are numerous who like to use second hand-devices for morals, ecologicals, politicals and economicals reasons.

we are users more than customers

i could advise you the Samsung Galaxy A5(2017) with 3GoRAM that i would buy if i have enough money, awaiting for the A10e in about 3years

Edit : some Xiaomi and the Oneplus have powerfull hardware


All of the phones listed at the top of this thread are available new according to gsm arena, even the Sony Xperia Z3 Compact which is quite an old phone with it’s 2014 release date! There’s a few listed on ebay uk.

One of the reasons why we still support ‘old’ devices is to avoid e-waste. Not everyone can afford to throw away their phones after a year of use…even those that can afford to do it prefer to retain the old smaller, easy to use handsets. Having said that we do plan to add newer devices to our our list. the problem is to get hold of their source code to port them.


LineageOS for microG has recently switched to ASOP Android 10 (Q). Here the second build lineage-17.1-20200826-microG-starlte.

1 Like

It is greatly appreciated that you recognize the need for supporting older phones.

When you already have an old phone, then it is obviously most sustainable to use that for as long as possible.

If you want to buy a used phone, then important details to watch out for is that it a) is supported by /e/ (or at least supported by LineageOS which should make it more likely to later be supported by /e/ as well), b) has replaceable battery (so it can last much longer).

Samsung Galaxy S3 i9300 fits the above requirements and used to be popular as used phone, also because of its modem isolation The similarly branded and seemingly slightly more popular i9305 is not supported in LineageOS.

Nowadays i9300 and i9305 are disappearing (at least in Denmark where I live), and is also arguably too slow to run the newest releases of Android.

It seems the best option that fits the above requirements nowadays is the Samsung Galaxy S5 Neo.
Please consider adding support for that model in /e/ - it is supported in LineageOS and works fine there.

Please note the ‘Q’ builds have been updated in the table above…more devices are being added to the list. The zip files are tagged ‘dev’ which means testers will not need to manually flash the official builds when they come out later.


Ah, FP2 is on the list, I am impatient to try it on FP3 :slight_smile:

:grin: :grin:
Yessss! I was waiting to try this on my 6T, just saw this on the list now!!! Gotta backup everything then GO!
Think this made my day, THANK YOU TEAM


Any chance to get the public repos on gitlab updated to reflect the new builds? Specific fatal errors in the public repos make me think that they don’t reflect what got released…

Yes, that’s great. But on my FP2 it doesn’t boot. It’s trying to start but after some time booting it restarts to recovery.

Did you try a clean flash of the /e/ Q ROM on the FP2

So I’m quite relieved that it isn’t there for FP3 yet :grin:
I tend to install such pieces of software to my daily driver :grin:

Yes. I did a factory reset first and (just in case) tried to install it via adb sidelload and TWRP install function and it was always the same. The image might have been corrupted during download (I didn’t find a checksum the verify its integrity) but at least during install there was no error.

Well, it’s an alpha build so (better safe than sorrow) I created a full backup first… :wink:

Did a clean install (format data, wipe etc) eOS Q on Oneplus 3T but it failed.

All steps seemed to go ok through to the bouncing ball for a minute or so (is it only me by the way who sees the e logo with the bouncing ball as the back end of a dog with a bouncing poo? Might be too many failed installs on my other device! :sweat_smile:) but did not get as far as “my data is MY data” and rebooted into recovery (twrp).

I tried rebooting recovery again, then system, same result. So it’s powered off for now.

@Manoj, Is there a new recovery in this ROM?

@chrisrg @ff2u all : We have started a new build for all devices with updated vendor source code…that could be the reason these builds are failing
Will update the links to point to the new builds once they are available