/e/ Q for FP3: Looking forward and being patient

Hello to all /e/ developers,

Judging the recent progress in the Moto G7 ‘Q’ dev builds, a new Q build for the FP3 may not be too far away.

Looking forward to it while being patient, and wishing you all the best!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

The FP3 pie builds are currently being tested. Should be available in 1-2 weeks as soon as the testing is done.

The Q build for FP3 has some issues …

  • NFC not working
  • MTP connection not available
  • hotspot not working
  • Fingerprint issue
    which need to be resolved …again being tested and fixed.

There’s a Pie update available right now (0.12-2020102981459)… think I need some extra courage this time to install :smiley:

Actually, I’m going to miss the much-criticized task bar rearrangement and cleanup in my current 0.12-2020093076095 build - it really grew upon me!

1 Like

Have a look here https://images.ecloud.global/dev/FP3/IMG-e-0.12-q-2020110282350-dev-FP3.zip

1 Like

Thanks @harvey186 (it’s not visible to me without the full link)!

What type of Q build is this? Beta?

Is it possible to test this Q build without a loss of userdata? E.g. flash via fastboot without wiping?

no way

1 Like

when I push the lnk, the download is starting

it’S a test version

Then I cannot try it unfortunately, it is really annoying to validate the banking apps when setting up a smartphone

I tried flashing it to my FP3+ using following commands like at https://doc.e.foundation/devices/FP3/install:

fastboot flashing unlock
fastboot -w
fastboot flash system system.img
fastboot flash boot boot.img
fastboot flash vendor vendor.img
fastboot flash dtbo dtbo.img
fastboot flash vbmeta vbmeta.img
fastboot flash userdata userdata.img
fastboot flashing lock

There was no product.img, so I omitted it.
The first boot went fine, everything worked fine, but when I reboot, the boot screen with the animated logo stays for a long time, then it reboots into recovery saying “Can’t load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factory data reset and erase all user data”. When I choose to “Format data”, it will erase my data and reboot with into the normal setup tool. So I can use my phone until I reboot :expressionless:

Any ideas? I know that FP3+ is not officially supported yet, but the normal operation already seems pretty good with this version.

I have the same problem. Even when I try to do the factory reset like described here: https://support.fairphone.com/hc/en-us/articles/360048350352-Erase-all-data-factory-reset-FP3-FP3- I ran into the same message at step 5.

Edit: to specify I also have the fairphone 3+, but I did not try to install the pie version, but the q version, as described here: https://doc.e.foundation/q-beta-fp3

I think the pie version is just for the fairphone 3 and does not come with drivers for new camera and loudspeakers.

I did an OTA update and now the issue is gone. I think it must have been this issue: https://gitlab.e.foundation/e/backlog/-/issues/2013

1 Like

I just successfully installed https://doc.e.foundation/q-beta-fp3 on my FP3+.

Will there be the possibility to update from FP3+ beta to the stable version without loosing userdata?

And does someone may know if these app signature issues are because of the beta?