Easy-installer error (Samsung Galaxy S9+ with Android 10)

I tried to install /e/ OS on a Samsung Galaxy S9+ with Android 10 but I encountered an error during installation. The log file is as follows:

2024-01-12 16:54:07,816 DEBUG [JavaFX Application Thread] e.e.i.EasyInstaller [null:-1]
OS name = Linux
Java Home = /snap/easy-installer/33/easy-installer-linux-x64
Current working dir = /tmp/hsperfdata_akg
ADB folder path = /snap/easy-installer/33/easy-installer-linux-x64/bin/adb/
2024-01-12 16:54:07,973 DEBUG [JavaFX Application Thread] e.e.i.EasyInstaller [null:-1] language = de, country = CH
2024-01-12 16:54:08,169 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] initialize()
2024-01-12 16:54:08,176 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] loadSubScene(null)
2024-01-12 16:54:08,370 DEBUG [JavaFX Application Thread] e.e.i.EasyInstaller [null:-1] Detected screen’s size = 1920.0 x 1053.0
stage’s size = 1440.0 x 1024.0
2024-01-12 16:54:20,314 INFO [JavaFX Application Thread] e.e.i.EasyInstaller [null:-1] stage is closing
2024-01-12 16:54:20,317 DEBUG [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] onStop()

Does anyone have suggestions how to get around this problem and complete the installation? Many thanks!

If that is the whole log Howto troubleshoot issues with the easy-installer it implies that Easy Installer did not even attempt to detect the device.

Were you asked to press a continue button (was it off you screen ? can happen on a wide screen laptop!)

Or … there are a few preparatory screens to walk you though some things you have to do first. You might concentrate on those to see if anything was missed.

1 Like

Many thanks, aibd, for your reply. I tried again and am now getting stuck at a much later point: After going to much of the Easy-Installer process, the Samsung Galaxy S9+ shows a blue screen saying “Downloading…” (attaching a photo doesn’t seem to work right now; I’ll try again later). The logfile can be downloaded here:
For the moment, I’m still hoping the installation process will continue, so I’m leaving the device connected. But I’ll have to deconnect it at some point and try the whole process again - only I don’t quite know what to do differently… Many thanks for any further help!

P.S.: This is the screenshot of Easy-Installer on Linux Ubuntu 22.04.3 LTS while the phone shows the blue “Downloading…” screen.

The Download mode screen shows


While this remains you cannot install any Custom ROM.

Maybe after a Factory reset you did not re-enable USB debugging ?

The Easy Installer log looks OK; things progress OK, until wait-download.sh cannot complete. (As said already bootloader / Download mode is locked.)

There are a few words on the subject here Know your hardware – Samsung # OEM unlock.

This is a generic page for USB debugging https://doc.e.foundation/pages/enable-usb-debugging.

Any Google account must be removed. Often we find that the device needs to be online to lift some mysterious lock, please watch for that lock indicator to change if you get the phone online.

Edit Is the phone new?

The phone may be protected against a Custom ROM if you have not used it “normally” for a minimum of a week or two.

You might attempt “Check for Updates” within the existing Samsung UI. If remote monitoring applies this forces a connection.

1 Like

Many thanks for these very helpful additional hints! I now got to the blue Downloading… screen. How long should I wait before I restart in recovery mode (pressing “on”, “Bixby” and “volume down” at the same time)?

On the blue screen it now says OEM lock off.
It is a refurbished phone, which was used before refurbishment.

The actual way that you do the button presses is critical and I word it differently in Your first boot into TWRP.

My memory is that you can do the “Special reboot” as soon as Easy Installer tells you to. [1]

Do not be distracted by the “Do not turn off target” this is a static screen on the device.

Good to hear the lock gave no further trouble.

1 Like

Thank you very much for these additional pieces of information - I now managed to complete the installation, using the very helpful explanation you shared concerning the button presses. I’m very happy it worked!


This topic was automatically closed after 180 days. New replies are no longer allowed.