Easy Installer installation issues Samsung Galaxy S9

Hi I get stuck installing eOS on Samsung Galaxy S9 with Easy installer. Aufter downloading screen

and first reboot with Bixby/Vol. down/power I get stuck in the samsung (?) recovery (see picture). However I do not get into e-Recovery mode. I know its a bit tricky oressing vol down/bixby/power and then vol up/bixby/power but I have the feeling of missing sthing.

I have latest Easy-Installer installed
I have Android 10 latest update from samsung

However tried “update from adb” but it failed.

I can not get into e-recovery? :thinking:

Perhaps tell us if you might be struck at this point:

I wrote an article here which includes a little video, if you think the above might apply to you.

Know your hardware - Samsung #Your first boot into TWRP

THX just reading through and tried. Will try again but however it failed.

Assuming Easy Installer would be trying to install e-1.9-q-20230310268292-stable-starlte.zip

… we see from https://gitlab.e.foundation/e/os/releases/-/releases that e-1.9-q-xxxx is expected to have an Android SPL of 5 Feb 2013

Is there any chance your current Samsung SPL is in advance of that ? That info should be in About phone > Android version … or perhaps Software version / revision.

… or you may find clues in the log … or paste it here.

Hi, I just installed using Odin and TWRP, so I just can not check anymore.


Hi, I got the same issue as @FFP3 twice: 2 years ago with a S9 and today with a S8, so I abandoned the Easy Installer and reverted to manual install.

Despite a quick switch between Volume - and Volume +, as described on @aibd 's tutorial, I would still enter the Android recovery.

Both times I solved that by using Odin3 (dowloaded here) to install the TWRP. Still I had the same issue there, but the trick that worked was to disable Auto-reboot while the phone is connected to Odin (on the left in Odin’s window, in the ‘Options’ tab between ‘Log’ and ‘Pit’ tabs). Only with that, I managed to avoid entering the Android recovery.

Then, the TWRP steps are rather easy, but there was a final hurdle: I was unable to copy the .zip ROM file into Internal Storage (and the TWRP folder wouldn’t show up). Maybe I did a wrong wipe? But luckily I had a microSD card, I was able to copy the .zip file onto the card and insert it to support the install, so I solved that.

Again a huge thanks the /e/ team and community for a great improvement in user privacy!!
My comments here are only to help other users adopt /e/OS, not to criticize the wonderful project :wink: