Easy Installer Samsung Galaxy S9 no Teamwin

I followed your expanded steps precisely but it still shows the white Android with the red exclamation mark and loads the default Android recovery menu rather than TeamWin.

I have tried different cables and different USB ports on the desktop (including USB3 on the rear) and nothing seems to make this work. I also tried running the installer as Administrator and that didn’t make a difference either.

The log from my most recent attempt a few minutes ago is here:
haste[DOT]tchncs[DOT]de[FORWARD SLASH]olarefoyog[DOT]yaml


I am using Easy Installer v0.15.0 on Windows 10 x64 on an older Acer desktop.

I really hope you can help as this is getting ridiculous and i am almost entirely out of options…

Thank you for sharing the log. You might hold on for a second opinion but this is my highly selective cut from your log (idk why pasting the log failed for you!) hastebin

2022-08-20 21:32:46,846 DEBUG [Thread-10] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)C:\Program Files\easy-installer>"C:\Program Files\easy-installer\bin\heimdall" flash --RECOVERY "C:\Users\TV\AppData\Local\easy-installer\sources\starlte\recovery-e-latest-q-starlte.img" --no-reboot 

2022-08-20 21:32:50,948 DEBUG [Thread-10] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)Downloading device's PIT file...
2022-08-20 21:32:51,072 DEBUG [Thread-10] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)ERROR: Failed to receive end PIT file transfer verification!
2022-08-20 21:32:51,072 DEBUG [Thread-10] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)ERROR: Failed to download PIT file!
2022-08-20 21:32:51,073 DEBUG [Thread-10] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)Ending session...

2022-08-20 21:32:51,478 DEBUG [Thread-11] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)"waiting for recovery"

I interpret that as a fail. The Recovery never transferred as I see.

Btw the Samsung cable definitely doesn’t work for this. The Easy Installer couldn’t detect the phone when using the Samsung cable so i had to use a different one… as you suggested previously.

1 Like

Thanks for that… it does seem like a fail indeed. Do you think it’s possible the cable i am using is to blame? It’s relatively new and not known to play up though.

Is there a cable for sale somewhere online (ebay perhaps) which is guaranteed to work for this process?

The cable can be a bit trial and error, your log does show many “attempts” before proper contact but this is seen quite frequently.

If you were to try the “manual” instructions Install /e/ on a Samsung Galaxy S9 - “starlte” you might find this guide useful [HOWTO] Install /e/ on a Samsung smartphone with Windows easily. (It seems I mentioned both links already, maybe not to you though!).

Please don’t rush to start, but you will get a chance to test the cable with Odin, when you get to the point, so any weakness in the cable might be revealed at that stage.

Prenormal was already mentioned, if this was an issue it will show on the Download mode (aka Odin mode) screen. I think you are already aware that this would be a blocker.

Ok, thanks for the info. I will give have to try the manual instructions another day and see what happens from there. I expect any errors in the manual process will be far more obvious than with the somewhat automated Easy Installer.

Thanks for all your help and feedback. I really appreciate your time and effort. Thank you.

1 Like

Did you finally manage to finish successfuly the install?
I am stuck in a similar situation an would apreciate your feed if anyway you found how to solve it.

Just as a cross reference to others; you have reported your install problem solved apparently due to KG : Prenormal here Installation of e/OS fails on Samsung S9 DualSim - #7 by Arken. Thanks.

No, unfortunately not. I will need to attempt to try the manual installation instructions (Install /e/ on a Samsung Galaxy S9 - “starlte” for my particular model) sometime when i have the time and patience. The Easy Installer attempts to automate the use of the commandline tools and steps which would have otherwise been the only way to install a non standard Android version like /e/

If you install manually yourself please let me know how you go.


My problem isn’t solved quite yet but i will give the manual installation a go sometime and see if that helps. Thanks for the info regarding the prenormal state… i will check for that next time i go through the steps.

When looking through the manual steps i need to select the correct device. I have a single sim Galaxy S9 (SM-G960F) but the only available options for this model state “dual sim” in the Sims Slots column. However, when i hover over the words Galaxy S9 the mouse over popup states:
SM-G960F (single sim???)
SM-G960F/DS (presumably the DS is dual sim???)

Is this suitable for my single sim SM-G960F? There’s no separate single sim only option i can see

1 Like

I think so…


I think so…