Easy Installer stops on Tap on ‘Do not install’ - [Edit, TWRP.apk] - SM-G950F

Hi guys, I bought a used Samsung Galaxy S8 (Factory resetted) and tried several times to install /e via the Easy Installer. It always stops on the Step Installation with the last command Tap on ‘Do not install’.

The last few lines from the log read like this:


exit value = 0

2022-01-14 13:12:20,891 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] loadSubScene(uiRoot)
2022-01-14 13:12:20,892 ERROR [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] No interface to load!
2022-01-14 13:12:20,892 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] ResetNextButtonEventHandler()

I am on Ubuntu 20.04.3 LTS.

What can I do? Do you need any additional information?

Hi @L30nhard, welcome to the /e/ forum.

Your post comes right on top of another Easy Installer, dreamlte failure: No new Easy Installer instructions/steps after 'Do not install' TWRP.

I was incredulous at first. I cannot see how this workflow could work, but I do not actually know this device. An issue with Easy Installer is that it makes life easy by automating the process, but if a user does not know what to expect and Easy Installer takes a wrong turn we are stuffed!

Now I see from your image that we are talking about the TWRP app, well indeed we do not want that! The expected behaviour is that a certain step (I am being deliberately non-specific as I do not know the device) sends a signal to Easy Installer to pick up and continue. What in my opinion you are experiencing is the pattern of Reboot / Power Off does not send such a signal. What I am saying seems consistent with the part of the log you show, but we cannot see the step immediately before.

Rather than add more here, please can you read the other thread, including trying to compare what you have actually done with the manual instructions linked there. Please ask if you need more information. Please can you add the full log in case these three reports are not actually the same and something else is involved!

…and eventually https://doc.e.foundation/support-topics/report-an-issue!

Edit. Unlikely, but a failure in two way communication can be caused by USB cable or USB hubs on the PC as found in this case [LIST] Devices working with the Easy Installer - #78 by aibd - note in that case the evidence was in the log!

Hi @aibd,

I already worked through the other post, but I did not want to hijack it, so I created this new one. I am stuck at exactly the same point that he was.

Here is a link to the log.

I already tried what @piero suggested, namely:

  1. Wipe the needed partitions (advanced wipe)
  2. /system, /data, /cache, and /davilk-art-cache,
  3. Install the e-latest-stable.zip
  4. Reboot to system

But I always get the error Failed to mount /preload (Invalid argument). But out of curiosity, how could I do step 3? Via adb?

I also did the manual install, but always failed at the topic * Installing a custom recovery* at point 7, because I couldn’t boot into recovery.

When we find

because I couldn’t boot into recovery.

the solution is often found here Your first boot into TWRP.

When you say you tried

Wipe the needed partitions (advanced wipe)
/system, /data, /cache, and /davilk-art-cache,

this instruction is to be applied with TWRP which is required, so an adb command will not help us at this point (I think). So that stage would be done after we establish IF you have a working TWRP.

I assume you cannot confirm this?

In your log I do see

Uploading RECOVERY
RECOVERY upload successful

Please tell me how it goes with improving your button pressing technique! :slight_smile:

Hey, I uploaded the e installer file old school style via usb into the phone, wiped all the partitions, ignored all errors and installed the file.

And now it works :slight_smile: So basically I left the installer behind and finished in TWRP.

So obviously, my pressing technique got better :sweat_smile:

Now I only have the problem that I can’t import an ics file in the default calendar, but I happily take that problem. Thanks for all the help :+1:

1 Like

Great news! Happy to help. I have taken the liberty of re-titling this thread.

Addressing the next user facing this issue, when you see this Installation screen,

it is important that you have ALREADY done your Your first boot into TWRP which would have first resulted in you seeing one or both of these screens on your Samsung.

All of the steps on the Easy Installer screen require you to be working in your newly installed TWRP.

For instance, this is the device screen for the first step Tap on ‘Wipe’