EasyInstaller Re-requested OEM Unlocked after wiping Samsung S9

I ran the easyinstaller and was able to get all the way to the TeamWin screen. Went through the wipe and the easyinstaller began to attempt to install /e/ os. Within a minute or so the easyinstaller kicked back an error saying it had problems and I should go back and enable the OEM unlock. Only at this point all I can get to is the TeamWin screen. I tried rebooting and I only get the Samsung S9 opening screen it goes black and then reboots back into the Samsung S9 opening screen again. AND REPEAT.
I can get back into TeamWin, but there is no OS on the phone. How do I get /e/ os install at this point. I am lost and need help.

To any who read this… I wanted to follow-up and let all of you know, after researching more and youtubing some and thinking I had a plan, I rebooted in TWRP and when I did the EasyInstaller jumped back into the installation and eventually finished.
I will say it was nervous for me and I was fearful of bricking the phone since it was for someone else, but it all worked out. Just first time performing these steps is… well terrifying when I am not sure exactly what I’m suppose to see.
OK well, I know more now and can’t wait to try it again in the near future.


1 Like

Good to see it worked out in the end :slight_smile:

Would you say that the section Your first boot into TWRP (Know your hardware - Samsung) is basically what fixes/explains the situation you ran into at first?

I am still trying to think how to reproduce the reported issue. :slightly_smiling_face:

Did the phone already have TWRP on it?

And/or, how did Easy Installer manage to flash TWRP if the phone was locked?

I looked over the notes and that really doesn’t cover what I saw. I did run into the problem of first boot before this problem, but what I found was if I held the Bixby button and Power button with my thumb and finger in one hand and used the other to switch the volume from down to up that got me into the TeamWin screen just fine. It is a little tricky though.
What I saw came after that when my computer screen showed the easyinstaller start to continue through the process. It looked like it was working on it or communicating with the device to install and then failed. It stated for me to recheck the OEM Unlock option pointed out earlier in the process was toggled. Only There was no way to get back to it since that OS was erased.

It was after reviewing some Youtube vids that I was going to try something else to get the e OS installed on the device. I decided to reboot my device (at this point I still had the easyinstaller up on my computer. I had not closed it out). Just after rebooting back into the TeamWin screen that the easyinstaller kicked back into action and continued the installing process. AND yes it finished successfully.

Hope this helps.

Yes the TWRP was already on it and no the phone was not locked. It was more like the easyinstaller maybe had a communication glitch and couldn’t install the during that round until I rebooted the phone and the communication was reestablished.

1 Like