Echo in VOIP calls

When calling someone with speakers on, they hear a strong echo of their own voice (I don’t hear any echo on my end). I tried with Signal and the phone app, and it only happened in Signal. I am sure it didn’t happen with my previous phone.

I tried this when calling an iphone and an other android, happened with both.

Looks a lot like the issue for the Galaxy S7.

Anyone else experiencing this issue ?

Phone: Fairphone 3
OS: /e/ stable 0.9-2020072965352 (happened with previous version as well)

Echo in apps:

  • Signal: Yes
  • Facebook Messenger: Yes
  • Phone: No

EDIT: Tried on more apps (see above for results). Plugging in headphones or stopping speaker mode stops the echo. If the phone is in speaker mode, it does not use the same mic as normal calls, so this might be the source of this issue.

It’s very strange as a problem, and by the way Signal has no settings to change regarding voip calls.
The only one that comes to my mind is this: in the privacy section, activate the “Always relay calls” function, because maybe by making the data stream of the call take a different path, maybe this annoying problem could disappear.
But it’s just a hypothesis

I tried the “Always relay calls” solution, but as I expected, this didn’t change anything. Plugging in headphones stops the echo. Stopping speakers mode stops it as well.

I noticed the phone has 2 microphones. One at the bottom when making a normal call, and one at the top when making calls with speakers enabled.

My guess is that the phone does not stop the second mic, or at least does not handle it correctly and thus creates an echo.

This is not related to Signal, as this happens in Facebook messenger as well.

I didn’t know that FP have two mics…wow…

Anyway, it seems to be a bug on android 7 on the FP devices; this is a link where it’s explained: (
And it’s seems also that has been fixed on android 9…if I have read it right

Thanks for the research! The link you provided is for the FP2 but I use the FP3.

I’m afraid it’s the same :pleading_face:
I tried more researches on fairphone website, but without success

This problem is common to a lot of phones. I use a Samsung Galaxy S5 and have exactly the same problem with Signal and any number of SIP clients. There seems to be no solution although turning down the volume sometimes lessens the echo enough for the person on the other end to not abandon the call. Very frustrating.

My current solution is using earphones, these are easy to carry around so this is good enough for now (but a fix would very much be appreciated)

For me, earphones are, figuratively, a pain in the arse. Scrambling to plug them in to the phone in order to answer an incoming call before it is abandoned or goes to voicemail raises my heart rate a bit too much.

1 Like

OK, if anyone’s still here, the problem seems to be due to the noise cancelling mic picking up sound from the earpiece/speaker. It’s a common problem with non-stock ROMs and, as far as I am concerned, the main barrier to sticking with them. Recently I had to go back to stock on a GT-I9300 because I intend using it as a doorbell/intercom. This necessitates use of the speakerphone setting which produces intolerable feedback on /e/. Going back to stock fixed it immediately. Being so outdated brings its own problems but that’s a story for another day.

1 Like

I’m “here” :slight_smile: and wanted to say thanks for the follow-up, @Vaughan. I remain hopeful that this issue can be resolved soon!

Is there a issue in the bugtracker? I also have this problem and know at least 2 other phones that have the same problem.

Any news regarding this topic? Is there currently activities ongoing by the /e/ team?

Same problem here, (Moto Z Play), and really a pain with Signal, which I use a lot. The echo when using loud speaker is much worse than when using normal speaker.

Moto phones seem to have varying degrees of echo problems in ‘voip’. I can confirm that Moto E2 (surnia) generates a very bad echo that apps like Signal can’t eliminate, whereas Moto G4 Play (harpia) works without echo when using Conversations or Signal.

Other apps like aTalk will also result in an echo on harpia. So it seems also apps have varying degrees of additional echo cancellation.