eDrive synchronization issues

We are trying to fix a bug in /e/ drive synchronization.

It seems to happen in specific cases, for specific users only. If you have issues with eDrive synchronization, please report the problem here with as much information as possible:

  • version of /e/ OS
  • device
  • possibly a log (logcat)
1 Like

Bonjour j’ai en soucis de synchronisation des notes sur le compte /e/. Je suis sous oneplus 6T.


I have just spotted a syncing issue on my mobile device.

This affects only the documents, all other elements are syncing OK (mail, calendar, contact, photos, screenshots …etc.).
The computer client is working fine.

Version of /e/ OS : cf. screen shot attached.
Device : Samsung S9+

I haven’t got around getting some logs.
I hope this will still help you in solving the problem.

Best regards


Hi Gael,

I have retested the synchronisation.
I also looked at posts on sync issue such as

Unfortunately the sync on the documents folder still does not seem to work.
All other elements are syncing OK (photos, calendar, mail…etc.).

Do you have any update on this?
Should I use the NextThink app to sync documents?

Best regards


Hi @Jeff pl check some of the issues raised here
If yours is a similar one add your comments to an existing issue else raise a new bug with details .

Dear all,
I am also having sync issues.
I have a Samsung S9+ (SM-G965F) purchased from e.foundation with e installed. Present version is /e/OS 0.7-2020010636666 (Android 8.1.0).
It never correctly made the sync with the cloud.
In my ecloud, the only device listed is a GT-I9505 (Samsung S4) for which I made a test in installing eOS manually. That one correctly synced. The SM-G965F does not and it does not show up in the device section. I do not use the S4 anymore.

On the S9+, both my e.email and contacts are active in the “user & accounts” section on the phone.
The agenda does not sync, nor does the gallery nor the contacts.
I have regular errors on the phone when it tries to sync with the cloud but I can’t retrieve the errors. I can see them when they show up but can’t copy them and don’t know where to look for them.
For the contacts, I tried to manually export them as vcf from the phone to my laptop and tried to import them to the contacts in the cloud but they are not accepted. The error message (in French) is “contacts défectueux” (faulty contacts). Which I don’t understand as they are exported from the phone and sent by e.email !

Any help will be highly appreciated

Update: I noticed that the VCF file exported from the contacts on the phone is version 2.1. Maybe this is the reason why the file is not accepted by ecloud which I guess requires version 3.0. Does anyone have a workaround for this ?

Update2: my guess was correct. I managed to convert the vcf file exported from contacts on the phone into vcf version 3.0 using vcard2to3 (https://github.com/jowave/vcard2to3). I then manually import the vcf file to the contacts on ecloud. But I assume that any future changes made on the phone (or the cloud) will not sync. Does anyone know how to force “contacts” on the phone to use vcf version >=3.0 ? The current version of “contacts” on my S9+ (purchased pre-installed with eOS in November '19) is 1.7.21

Good evening, I managed to fix my note synchronization problem by setting my ecloud account on the application.

Sorry for the late answer, if it helps.

I report a Nexcloud synching issue: the only way I found to synch my Document folder is to activate the Pictures and videos synchronization, BUT when I do so, my DCIM photos and videos of my phone also synch do Nextcloud, which I don’t want.

1 Like

Hi all,

Just so you know, the sync issue on the document folder is still occurring on my side.
I have rechecked the sync settings of my account on the mobile phone : “Pictures and videos” is on.

Only the sync on the document folder does not work, all other elements are syncing OK (photos, calendar, mail…etc.).

Any thoughts on this?
In the account settings on my mobile, should I try to either :

  1. Deactive the “Pictures and videos” and then reactive it?
  2. Remove my /e/ account entirely (backup needed just in case!) and re-adding it?

Any though is appreciated. :slight_smile:

Best regards