Error in installation instructions, unable to make backup

I’m running into issues installing the latest version of /e/ (e-0.7-p-2020030644075-dev-mata) for the Essential PH-1 (QP1A.191005.014).

First, I think this part just needs some clarification:

  1. Unlock bootloader
 fastboot flashing unlock
  1. Unlock critical partition
 fastboot flashing unlock_critical

After running the first command, the device restarts, then it shows “No command” below a dead android and begins to bootloop. I believe it’s necessary to hold the volume down key when the Essential logo is displayed to get back to the bootloader, then the second command can be executed. After running the second command, the device restarts again, and it’s necessary to hold the volume down key again to get back to the bootloader. Please let me know if I did something wrong here.

  1. Temporarily flash a recovery on your device by typing:
 fastboot flash boot <recovery_filename>.img

This command threw an error:

Sending 'boot__b' (48712 KB)                       OKAY [  1.569s]
Writing 'boot__b'                                  FAILED (remote: 'No such partition.')
fastboot: error: Command failed

I cross referenced the LineageOS documentation and the TWRP documentation and discovered that I needed to switch to the other slot first:

$ sudo fastboot getvar current-slot
current-slot: _b
Finished. Total time: 0.000s

$ sudo fastboot set_active a
Setting current slot to 'a'                        OKAY [  0.164s]
Finished. Total time: 0.165s

Then I had to change the name of the partition to flash:

$ sudo fastboot flash boot twrp-3.2.3-0-mata.img 
Sending 'boot__a' (48712 KB)                       OKAY [  1.706s]
Writing 'boot__a'                                  FAILED (remote: 'No such partition.')
fastboot: error: Command failed

$ sudo fastboot flash boot_a twrp-3.2.3-0-mata.img 
Sending 'boot_a' (48712 KB)                        OKAY [  1.673s]
Writing 'boot_a'                                   OKAY [  0.465s]
Finished. Total time: 2.140s

Now I can boot into TWRP, but I’m unable to create a backup. Every time I try, I get an error:

Updating partition details...
Full SELinux support is present.
MTP Enabled
Updating partition details...
 * Total number of partitions to back up: 3
 * Total size of all data: 2371MB
 * Available space: 102014MB
 * Backup Folder: /data/media/0/TWRP/BACKUPS/PM1LHMA790901689/1970-04-13--14-37-18_PPR1180610091
Can not create '/data/media/0/TWRP' folder (Operation not permitted).
Failed to make backup folder.

I suspect the issue is the data partition is encrypted but I never set a password and TWRP never asks for one. I read here that I should try setting a password, but I can’t get to the regular Android home screen anymore. I’ve tried starting TWRP with “Keep Read Only” and “Allow Modifications”. I’ve tried unmounting/mounting the data partition. I’ve tried changing the active slot. Nothing allows me to create a backup and I’m hesitant to proceed at this point.

Could the fact that I’m downgrading from Android 10 to 9 be causing any issues?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Absolutely, you must downgrade to stock pie 9 first then flash /e/ pie.

Ok, that would be good to mention in the documentation. How do I do that? Do I need to undo anything I’ve done so far? Please be very explicit because I’m new to this.

Surprising that you are in the Essential subforum but didn’t check any threads. Also, I checked the documentation. The Upgrade instructions mention installing the Pie firmware but the regular Install instructions do not. That will have to be fixed I guess. Maybe they didn’t think anyone would be on Q and downgrading.

See if this thread may be of help.

Hi @marcdw Just to clarify does a user need to flash stock Pie before flashing /e/ Pie even when they are on Q ?
If this can be confirmed I can add that bit to the documentation.

I’ve never been on Q but Google makes so many changes to the underlying structure, especially the firmware partitions, that it might be necessary to install matching firmware. Not really sure.
On my LG G3 I could run anything from KitKat thru Oreo with no firmware changes. Not the case with more modern hardware I think.

Thanks. I guess I overlooked that thread because it’s not exactly what I’m doing. Are the instructions for upgrading to stock Pie the same as for downgrading to stock Pie?

Yes I believe so. Whether upgrading or downgrading to a particular firmware one is essentially starting from scratch. Either the installation guide in the wiki or my post should be doable coming from Q (fingers crossed of course).

I was hoping to get time to backup my ROM, if possible, go to Q and then back down to P. Alas, fighting with ROMs on another device delayed that idea. :frowning:

Hello @Quaternium, if it is really necessary to downgrade from StockROM Android 9, you can find Android Builds for Essential Phone here > Previous Builds > Pie 9 - P Release 12 - PQ1A.190105.090 plus Flashing Instructions.

1 Like

Are you still planning on adding something to the documentation to address this? I was hoping for some “official” instructions from the /e/ team.

Q or LOS 17.0 is not yet in the picture for /e/ as far as the development is concerned. May come up much later this later. We had not expected the Q to Pie revert should be an issue but unfortunately that seems to be the case now.
Will be adding a generic instruction to all users to revert to stock Pie before flashing /e/ Pie Also will add that they avoid any downgrades below Pie altogether as it tends to brick most devices.

Well, I finally got past the major hurdles so I’ll post my steps in case it helps someone else.

Even after flashing PQ1A.190105.090, I still had to specify the slot when flashing TWRP:

$ sudo fastboot flash boot_a twrp-3.2.3-0-mata.img

Touch wasn’t working in TWRP, but I didn’t want to flash a patched version, so I followed these directions to install TWRP on both slots. I had to push the TWRP installer to the device first, then install it with another adb command:

$ adb push /sdcard/
$ adb shell twrp install /sdcard/

After booting back into TWRP, touch still wasn’t working, but then I switched to the slot I was originally on and everything was fine. I was even able to make a backup :slight_smile:

Finally, in order to sideload the /e/ image, I had to restart the adb server with root permissions:

$ killall adb
$ sudo adb devices

Hopefully the instructions can be amended to include some of these differences.

PS: this is a minor gripe, but I noticed many (all?) of the instructions on the /e/ website have this as the last step:

  1. Once installation has finished, return to the main menu, tap Reboot, and then System

This should say “tap Reboot System, then swipe to confirm” or similar. There’s no need to return to the main menu as the reboot button is on the adb sideload screen.

Hey @Quaternium, during my original testing I also used those directions you linked and had the issue with touch on one slot but not working on the other. That was weird.
Anyway, the /e/ install and upgrade instructions for the mata didn’t take into account our TWRP touch issues and whatnot.

When you said touch was working on one slot, was that on the slot you fastboot flashed the image (boot_a) or the other? I wonder if flashing the TWRP image to both slots and then installing the zip afterward would work for touch. Did that with the 2018 image but don’t think so with the official. :thinking:

We’ll need to get the steps squared away so the documentation can be fixed. Now that I’m not working due to the virus, I have the time and won’t mind starting over for some testing. Using just the official TWRP without the aid of the 2018 patched image.
Well, I may scour the XDA threads first in case someone has steps to ensure touch works without a bunch of extra steps. :grin:

Normally there is no swipe to reboot in TWRP. As soon as you tap System or Recovery, the phone reboots immediately. The only time one has to swipe to reboot is if there’s some kind of informational screen that needs attention (such as No OS Installed or some.such).
If for some reason a swipe-to-reboot action is needed one will do so anyway.

You got /e/ working with touch and all ?

Yes. Are you having any problems?

i had a lot. But now it is fine. And … a lot of minor bugs that were in Nougat are now gone. All good

It appears the installation instructions have been partially updated. I’d like to suggest a couple amendments.

First, I’m glad that we’re now warning users about downgrading. It would be even more helpful if we provided instructions for installing the correct stock firmware image. Something along the lines of:

  1. Check the Android build version under Settings > About Phone. If the version is PQ1A.190105.090 (not sure what it should say exactly), skip to Unlocking the bootloader.

  2. Download this firmware image.

  3. Follow the flashing instructions at the bottom of this page.

Also, this part still hasn’t been clarified:

I have a question about this part:

  1. Temporarily flash a recovery on your device by typing:
 fastboot flash recovery <recovery_filename>.img

When did this change from fastboot flash boot? That always gave me issues because the slot wasn’t specified. Does fastboot flash recovery flash the image to both slots? Or is it still necessary to set the active slot first?

Did anyone else find it necessary to install TWRP using the zip file documented here in order to get touch working? Or can anyone confirm that this is no longer necessary?

If the /e/ team is too busy, perhaps I could submit a pull request to update the documentation.

Sorry I didn’t see your post until now. Work has resumed and I’m doing six days a week. Fell behind on forum reading.

I wasn’t aware the documentation was updated. If so, the fastboot flash recovery line is of course wrong. Doesn’t apply to A/B devices.

As far as the TWRP zip is concerned, it is only necessary to flash if you intend to keep TWRP installed or at least keep it installed long enough to finish various installation tasks. It patches the ROM boot image to use the fastboot flashed TWRP image.
I mentioned in my updated ‘tutorial’ which TWRP image is needed for touch. To this day I have no issues with touch.