Factory data reset

Hello everyone, I have a samsung s9 + that would need to be reset to factory data, but unfortunately when I perform this procedure it starts with the TWRP app, I don’t know how to use it, someone kindly could tell me if I should uninstall this app or where I find the instructions to use it? I bought the SAMSUNG from the site with the system pre-installed. example a problem that the device gives me and that the screen does not split in two, Netflix no longer works after the update to 0.22. Thanks a lot x who can help me.

It depends slightly on the installed TWRP version. To be sure post a screenshot or foto of the start screen and from the delete section, or if you feel adventurous enter the delete section and accept the pre-selection when it includes data, cache & dalvik and nothing else because the possibility exists that you or your phone will feel miserable if it goes wrong ;- ) and if so, as a side note, I could not be held responsible for that because I warned you ;- )

TWRP is a “Recovery” rather than an app ! TWRP | FAQ. You might try some reading here to get more familiar with things. Know your hardware - Samsung

There is another thing involved here. /e/ solution shop phones were delivered with Android version Oreo. The 0.22 OTA was actually an OTA Android version Upgrade to Android 10.


If lost, keep using the back button till you reach the first screen (Home).

To get out of TWRP > Reboot > System

To Factory Reset > Wipe > Swipe to Factory Reset.

1 Like

Thanks for your interest, I apologize but I do not understand what you are asking me, I speak and write only in Italian, I wanted to know how to reset and restore my samsung s9 + given the problems I have. But I don’t know how to manage TWRP before it was easier now with TWRP I don’t know how to make the right choices. You ask me for the screen schot but I don’t know what you mean for me it’s Arabic, bear with me but I’m 67 years old. Thanks anyway.

Grazie per l interessamento, chiedo scusa ma non capisco cosa mi chiedi, io parlo e scrivo solo in italiano, volevo sapere come resettare e ripristinare il mio samsung s9+ visto i problemi che ho. Ma non so gestire il TWRP prima era piu facile adesso con il TWRP non so fare le scelte giuste. Mi chiedi lo screen schot ma non so di cosa parli per me è arabo, porta pazienza ma ho 67 anni. Grazie comunque.

I managed: “To get out of TWRP> Reboot> System”
but the part of “To Factory Reset> Wipe> Swipe to Factory Reset.”
I don’t know how to do it, the loading of / e / starts and everything is as before. if i uninstall the TWRP app maybe it works?

e tutto è come prima.

Di solito questo reset di fabbrica non distrugge le tue cose come le foto, ma distrugge i dati delle tue App.

Penso che la cosa da guardare prima sia il passaggio ad Android 10.

Prima conferma che sei su Android 10 come ‘penso’

Impostazioni > Informazioni sul telefono > Versione di Android.

Se è Android 10 ora e avevi Android 8 Oreo, allora il telefono avrà un aspetto diverso dall’aggiornamento. Potrei sbagliarmi, ma credo che il comportamento dello split screen sia cambiato tra 8 e 10.

Ti suggerisco di non fare danni con la TWRP finché non escludiamo tutto il resto. TWRP non è un’applicazione, è quasi un altro sistema. È lì per riparare una recovery {recuperare} se qualcosa va storto.

O forse non ho capito bene. Il sistema /e/ è così instabile che il telefono si avvia solo su TWRP? Non avete affatto un sistema /e/ utilizzabile?

Tradotto con www.DeepL.com/Translator (versione gratuita)

and everything is as before.

Usually this factory reset does not destroy your stuff like photos, but it does destroy your Apps data.

I think the thing to look at first is the change to Android 10.

First confirm you are on Android 10 as I ‘think’

Settings > About phone > Android version.

If it is Android 10 now and you had Android 8 Oreo, then the phone will look different since the Upgrade. I might be wrong, but I think the split screen behaviour changed between 8 and 10.

I suggest you do no harm to TWRP until we rule out everything else. TWRP is not an application, it is almost another system. It is there to fix a recovery if something goes wrong.

Or, perhaps I misunderstand you. Is the /e/ system so unstable that the phone will only boot to TWRP? Do you have no usable /e/ system at all?

The system is android 10, I would like to restore the factory data because it doesn’t work anymore disney+ and it doesn’t split the screen in two parts allowing to manage or see two running apps probably some library or program got corrupted. I was thinking of doing a FACTORY DATA restore.
Before you launched it it would reset everything and restore the system, now it warns me that it resets everything then the screen goes black and the TWRP program starts with all its menus that I am not able to manage. Exiting the program the system restarts and nothing has changed. Thank you for your availability, I am waiting.

Translated with www.DeepL.com/Translator (free version)

I still need to understand this better :slight_smile:

the system restarts and nothing has changed

You originally did factory reset to try to fix Disney+ and split screen.

Then, this new problem started and you can never get out of TWRP.

Is that right?

OR you still do not see Disney+ and split screen and you want to change something?

does not perform the factory reset, the robot does not exit and immediately restarts the “e” icon …
if I uninstall the app? maybe it does the reset or I do some trouble.

The ‘Official TWRP App’ is not recommended. It is safe to uninstall it.

I checked about split screen. It has changed between Android 8 and 10. If this is an issue it would be good to look for a guide in your own language.


the TWRP app I have not installed it I was already present on the phone.

l’app TWRP non l’ho installata io era gia presente sul cellulare.

Factory reset is found at Settings > System > Advanced > Reset options.

I recommend that you do not use the ‘Official TWRP App’ it is not recommended.

If the /e/ solutions shop supplied the phone with the TWRP app installed, I believe it was a fault but I believe another user mentioned this recently. Please don’t use it, and I know that it can be problematic to uninstall. (We can return to that when the phone is ok)

I ran: “Settings> System> Advanced> Recovery Options”.
the problem is that TWRP is activated automatically and I don’t know what choices to make. I tried to exit the TWRP program and it immediately restarts Android “e /” and does not restore factory data.
Thanks to the availability.

Io ho eseguito : “Impostazioni > Sistema > Avanzate > Opzioni di ripristino” .
il problema è che si attiva TWRP in automatico e non so che scelte fare. Ho provato ad uscire dal programma TWRP e immediatamente riparte Android “e/” e non ripristina i dati di fabbrica.
Grazie per la disponibilità.

In TWRP > Wipe you see

At the bottom of the screen is the “switch” Swipe to Factory Reset. You drag this to the right, and the reset will continue.

Grazie ho fatto, tutto ok. ho anche rimesso TWRP, ME LO CHIEDEVA. GRAZIE ANCORA E DIO TI BENEDICA.

Thanks I did, everything ok. I also put TWRP back, ASKED ME. THANK YOU AGAIN AND GOD BLESS YOU.

1 Like

good evening mr, aibd, i still come to disturb you for the following problem. Netflix does not work after 2 minutes of viewing it stops and reports me an error (5.7), the guide suggests me to update the device or turn off and on again or reset system settings.
Disney + also the same problem and I finally uninstalled it.
Amazon prime gave me problems at first, now it works.
I don’t know what to do, what do you suggest to me?
Thank you and I’m looking forward to it.

buona sera sig, aibd, vengo ancora a disturbarla per il seguente problema. Netflix non funziona dopo 2 minuti di visione si interrompe e mi segnala errore (5.7), la guida mi suggerisce di aggiornare il dispositivo o spegni e riaccendi o ripristina impostazioni di sistema.
Anche Disney+ lo stesso problema e alla fine lo ho disistallato.
Amazon prime mi ha dato problemi all’inizio , ora funziona.
non so cosa fare, cosa mi suggerisce?
La ringrazio e resto in attesa.

If I am right that you were running Oreo when you previously installed Disney+ … I wonder if it would work any better if you reinstall it now that you are running Android 10 ?

Netflix works with about 2 minutes of film then fails.

Disney + doesn’t even start.

Well … I just installed Disney + from Apps but, in deference to the great man, I was not able to sign up to the T&C, so I cannot test the app. Then I did this search on the forum … Search results for 'disney' - /e/ community … it does not look as if I will be streaming any Disney any time soon. Scuse sincere.

Later edit: I found this Netflix unusable since 0.13 Q on S9+ (#2536) · Issues · e / Backlog · GitLab