Fairphone 3 with E/OS going in and out of connection with 4G+ all the time after latest update. URGENT

Hi BST. How did you adjust APN settings I can only select? Also using KPN and BEN.

Hi, I went to network settings; SIMs; clicked the sim, scroll down to Access Point Names; use the + button in the upper right corner. Then I added APN according to KPN settings I found in another topic here somewhere. Note that this did not fix my problem, but if you want to try that is how I did it.

Exactly, no fix needed if you have no problem.

Your report of … “something like apn changed with /e/OS version upgrade” seems sub-optimal; most of the ideas I ever had about this are already seen in my replies to existing apn threads. I am out of ideas.

1 Like

Thank you very much for all your help. I got it working with the APN but after latest update problem is back

Well if you can document that this is repeatable, and show where the error is you could Report an issue against https://gitlab.e.foundation/e/os/android_vendor_lineage/-/blob/v1-t/prebuilt/common/etc/apns-conf.xml?ref_type=heads, if that was the problem.

For me it is repeatable. Steps are as follows:

Turn on the phone with 4g enabled. 4g+ initially works, but if I look after 10-15 minutes, the 4G+ symbol is gone. If you use an app which requires an internet connection, it will show “offline”.

It can also be repeated using the following steps:
Phone in 4G+ mode. Turn on wifi. Let wifi connect. Wait for 30 seconds. Turn wifi off. At this point 4g+ reconnects for a short time, and then drops the connection and goes offline. For me this is repeatable every time.

1 Like

Sorry I am not that technical. How do I show where the error is?

Do you have a problem if others could get problems via your device’s security holes with you not even trying to prevent the preventable?

"But what has all of this got to do with you? To put it simply: it’s entirely possible that your computer, your smartphone, your smart TV or your robotic vacuum cleaner is part of a botnet and is being remotely controlled right now - without you knowing anything about it.
It’s your responsibility to make sure that you take action to prevent others from taking control of your technology and using it for attacks."

“Attackers primarily exploit weaknesses in Microsoft operating systems and Android devices to hijack end-user systems. However, if you use a different operating system, you can’t afford to be complacent.”

(Source … why phrase myself when I can quote.)

1 Like

Learned something new again. Thank you AnotherElk

Of course you are right, but we are not all understanding each other here, and I did not make any link in my mind that @eosfan would avoid updating his phone because of this issue. :slight_smile:

I would have, to do exactly that. So happy with the additional info.

While I understand it is useful to discuss why one would update or not, it is a bit diluting for the original problem being discussed. Would it be okay to get back to that? I will need to get a new phone if I don’t fix this problem and I would rather not :slight_smile:

1 Like

Please can you try to give me exact APN settings which actually work for you … then we could try to match them against apns.config.xml … later see what changes after an update … and again after your carrier APN reset … to see in what way an update changes your APN setting adversely.

Or step one show me the published APN settings for your carrier and plan.

Offer open to @BST if you like !

Thank you for trying to help. Currently, I have no APN settings that keep working. If I reset APN settings to default the phone reconnects in the same manner as a restart would do, but then it has the same behaviour as decribed above. If mobile internet has been turned off and then on, or if wifi is turned on and then off, the connection will be unstable with every APN setting I have found for KPN as a provider.

1 Like

I am really not sure @BST but the report in Post #14 looks to me similar to a “lazy connection” from your carrier.

Conversations with a carrier can become infuriating, I know, but maybe there are “local issues” ?

I do not mean to just deflect responsibility from /e/OS … is just a thought.

In Settings > Network and internet > Mobile network > Preferred network type > I have always been able to use “(recommended)” (locally it is LTE). Does 4G show recommended for you ?

To check the signal strength on the phone, Settings > About phone > SIM status > Signal strength.
Checkout Ideal Cell Phone Signal Strength https://novotech.com/learn/m2m-blog/blog/2022/12/20/the-ultimate-guide-3-ways-to-check-lte-4g-or-cell-signal-strength/.

Thanks again for trying to help, really appreciate it. I understand why you would say that, but if I put my SIM into a Xperia XA2 with e/OS/ on it, there is no problem so I don’t think the carrier is the issue here.

I even bought a Samsung of the same type that is sold in the shop with e/OS/ to test this, and also in an S9+ there is no issue, so it seems specific for the Fairphone3 (for me at least). I’ve used the FP3 for 6 months with previous versions of e/OS/, and then the issue did not exist. I turned 4G on several times a day after leaving the office or home, and it always worked. I updated it to 1.15 and then the problems started.

And to awnser your question about 4g: yes, this is indeed shown as recommended.

The mobile network in Signal strength says connected, in service, Signal Strength -102dBm 37 asu. For the other KPN sim it shows -100dBm 40 asu. That seems bad according to the site link. Perhaps the FP3 is not very good combined with this provider.

I’ve also tried this with a Pixel4a with e/OS/ (as you can see I am really motivated to find out what is going on) and it works fine with -101dBm 37 asu. I’ve turned wifi on and off multiple times, and 4g connection is restored and works without trouble. I have the impression that it is specific for the FP3.

What I have noticed here, is that if I activate the network traffic monitor, that always shows on the P4a and on the FP3+ it turns off. Is that perhaps an indication that the connection is lost?

That seems different to my phone. If I turn on network traffic monitor and place the phone in a powered down microwave oven the monitor stays open and registers zero traffic.

I’ve also noticed something interesting. If I take out one of the SIMs and put it in the Pixel (which only has one sim slot), both seem to be stable with one sim in them. If I put both sims in the FP3+, they both become unstable… so maybe it had something to do with how the software handles 2 sims?

Okay, that is different behaviour. Perhaps it is also related to the provider in some way. I think the way the sims behave in separate phones and together in one also may have something to do with the original problem. Perhaps it is a combination of both, provider and the fact that both sims are in the same phone.