FP3+ e/os 1.5 : no automatic updates since 31/10/2022

I have a FairPhone 3+ with e/os 1.5. I have not been proposed to automatically update the current v1.5 to v1.6, v1.7. Any reason for that?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Are you on the stable branch!? I guess you’ve Android R (11)? If so, you should be offered to update to 1.6.

Looking at https://images.ecloud.global/dev/FP3/ and comparing it with https://images.ecloud.global/stable/FP3/, it seems likely you are on the /e/OS Q (Android 10) dev(eloper) version which has not gotten updates anymore.

If you can verify you’re on Q, you will only be able get to R or S manually now, not through the updater (OTA). Once you have done so, you should again be able to install future updates OTA.

1 Like

Indeed, It is 1.5-q and android 10. So will do the update manually to R or S. Could you tell very shortly the difference between S and R? What should I install for a long-term use?

R = Android 11
S = Android 12

I guess this already answers most of your question :wink: Of course, Android 12 will be supported longer than Android 11.

I only changed from Q-dev to S-dev some weeks ago and cannot complain, but be prepared that there are some visual changes in S that might need some getting-used-to (most visibly, much larger quick setting icons which results in fewer quick setting items shown at first swipe). Oh, and I noticed that for the first time, the set of “power off”, “reboot”, “screenshot” and “emergency” options are available through the quick settings (so not necessarily requiring a press of the power button), although given I skipped Android 11, I cannot say if this was an Android 12 or 11 first.

P.S.: From what I read in other topics in this forum, you might not need to unlock the bootloader to upgrade to S. It seems that other FP3 users have been able to upgrade from Q to R or S through the /e/ Recovery via sideload or from SD card, keeping (most of) their data and settings, even when their bootloader was locked. As you can see, I can only say what I read from others here. Of course, you can also manually upgrade from a computer (most likely this is how you first installed /e/OS), but I don’t know right now in how far this allows to take over data and settings.

1 Like

Thanks a lot for your complete answer.
I guess I will go for S.
Yes, my plan was to save all my data to the SD and to do a manually update like I did for the first installation. I will have a look on the topics that you mentioned.

Is that what you were referring to? : [HOWTO] Update /e/?

I can’t recommend a specific topic right now.

In your link, I see that it still assumes that the recovery on the phone should be TWRP (note the topic originates from 2019). /e/ has its own recovery now, this is what I was referring to.

Try to boot into your FP3+'s recovery to find out if the /e/ recovery is already installed – if so, have a look at its options. In the best case, it allows you to install the S installation file directly from an SD card, but on my own FP3+, this option is not available (I heard from others about the option to install from SD card being available to them in the /e/ recovery).

1 Like

I did it with

  • turn on usb-debugging in developer options
  • adb reboot recovery
  • adb sideload “zip-File”

All settings and data was kept. I hope this works for you as well.


It worked!
So simple!
I updated to 1.7-s. Looks like a new phone. Way faster!
Thx a lot


Hi there,

Thanks a lot for previous advises and this is a post to add my successfull “adb sideload” update process with my FP3 from :
Android Q e-1.5-q-20221031230909-dev-FP3.zip
Android S e-1.8.1-s-20230203257074-dev-FP3.zip

Looks like it was frozen at step 2/2 after adb sideload but I rebooted, waited 3-5 mins loading and I confirm now update is ok with 1.8.1-s-20230203257074-dev-FP3



Well, if it does work indeed from :
Android Q e-1.5-q-20221031230909-dev-FP3.zip
Android S e-1.8.1-s-20230203257074-dev-FP3.zip

it does not work to Android R as it keeps saying

Update package verification took 0.3 s (result 1).
E:Signature verification failed
E:error: 21

Update on the go to Android S… Reboot on the way…
It has rebooted and it works under v1.8.1-s and it didn’t loos e any date. So fast and nice.
Thank you /e/.

Which Android R install file did you use to try?

If you get a message like this at the adb sideload ... step, just enter the “Apply update” menu and then tap on “Update from ADB” (the names may not be exact).

adb: sideload connection failed: device unauthorized.
This adb server's $ADB_VENDOR_KEYS is not set
Try 'adb kill-server' if that seems wrong.
Otherwise check for a confirmation dialog on your device.

For me it seemed to freeze, too, with the last line shown on the phone screen being “Step 2/2”. After waiting a few minutes, I found out I just needed to go back to the previous menu, and then a success message would appear: “Update installed with status code 0”. Then I rebooted from within recovery and everything worked smoothly, without data loss.

I tired
and both told me that the signature was not valid whereas with e-1.8.1-s-20230203257074-dev-FP3.zip it didn’t say anthing, no warning, just install directly.

However, since I install it, my FP3 is quiet buggy. I hope it will get better in near future.

The error message is correct then. Those current stable files are in a different format and don’t work with ADB sideload like the current dev files do (notice the “IMG” in the filename, apart from those ZIP files having much different content compared to the files without “IMG” in the filename).
Fitting install instructions for the stable install files are these here … https://doc.e.foundation/devices/FP3/install … or you can get stable files in the sideloadable OTA format via the URL list in https://ota.ecloud.global/api/v1/FP3/stable.
It’s a bit messy right now with those two file formats around.

1 Like

Do you think I can do a sideload from
to switch from dev to stable and remain to the same version 1.8.1?

Well I tried sideload IMG-e-1.8.1-r-20230204257076-stable-FP3.zip (https://ota.ecloud.global/builds/full/stable/FP3/e-1.8.1-s-20230203257059-stable-FP3.zip) and once it reaches 47%, not just at the beginning as it was the case for IMG-e-1.5-r-20221028230215-stable-FP3.zip or IMG-e-1.8.1-r-20230204257076-stable-FP3.zip , it tells me the same thing : “the signature is not valid”.

$ adb sideload e-1.8.1-s-20230203257059-stable-FP3.zip 
serving: 'e-1.8.1-s-20230203257059-stable-FP3.zip'  (~47%)


Should I click “Yes”? Should I wait for a 1.8.x superior to 1.8.1 to do the update from dev to stable?

I don’t think so, but I could be wrong.
I was under the impression changing from dev to stable or vice versa would require a new install with wiping data, but I don’t know the current status of this.

1 Like

v 1.9. is sooooooo much better than 1.8.1. I got a very smooth phone!
Everything is again snappy but mail.
Mail is closing immediately after launching. Notification are coming but if I click on it, it launch mail but it close immediately also.
I hope a v1.9.1 will come soon to fix that.