FP3: From 0.23 Android 9 to /e/OS 1.x - seeking clarity

I don’t know what the recovery build is but if it’s as @AnotherElk says then you may already have it installed. Which again leads to confusion on why should some devices need to revert back to stock ROM if the OS provides all it needs?

Anyway to answer your question, as I wanted to play it safe, I went with the latest R build available: IMG-e-1.6-r-20221129238947-stable-FP3.zip. The S build is supposed to be for testing, or so I understood. I will cross that bridge when I need to upgrade again.

What I would do in your situation is install FairphoneOS and follow the /e/ install guide. This way if things go wrong you at least can fallback to a working phone, albeit with Google, and plus you gain some hands-on experience before going for the real challenge :slight_smile:

EDIT: By the way you will notice that FP provides instructions for all Windows, Mac and Linux but /e/ does not. I would recommend following the guide as closely as possible which is why I ended up using Linux. So when you are ready to install /e/ and you want to try with Linux, let me know as there are easy ways to run it in your computer without having to install it and it will cause no harm to your computer.

This has nothing to do with the recovery, and on devices required to revert to stock when upgrading the underlying Android version /e/OS is not in a position to provide everything, that’s why they have to revert to stock.

There’s more on the phone than the OS and the recovery. There’s additional stuff like firmware parts which get provided by the phone vendor, tailor-made for the Android version supposed to run on the phone. Of course the stock ROM will have these parts included.

Fairphone and the e foundation have an official partnership in place, so the e foundation gets everything from Fairphone in this regard to include in the /e/OS builds for Fairphone devices. But there’s no such official relationship with every vendor of every phone able to run /e/OS, and just grabbing these parts from stock ROM files without consent is a legal issue, so certain devices have to get updated “missing” parts by making a complete install of the stock ROM, should the need arise.

Just my understanding.

I don’t know if it helps but on my FP3 with R 1.6 stable, an adb sideload with R 1.6 dev just made the device a dev device. Thoose little apps I had on it, are still there

@AnotherElk @sam-a You were wondering before how it would behave…?

1 Like

That’s really good to know, I think it would be nice to add a foot note or something to highlight the importance of rolling back to the device’s original or stock ROM. The current state of the docs is quite scary actually, the opposite of beginner friendly. And I agree /e/ can’t make guarantees for every single device but most definitely should when it comes to those that are sold directly through their site. At least those pages should have special attention to these type of details.

Edit, I have deleted the original content of this post.

Apologies to all readers this post did not provide clarity, as it seems to be based on assumptions I cannot validate. Thanks to @AnotherElk for the subsequent post.

Perhaps of interest if you are looking at LineageOS for FP3 …

It all seems complicated.

Official (in their terms) LineageOS for FP3 was initially based on groundwork done by the e foundation for porting /e/OS to the Fairphone 3 …

“Since the /e/ foundation published the sources for FP3 support this was used as base.”

Usually first there would be LineageOS on a device, then /e/OS for the device would get based on this. In case of FP3 /e/OS got released first and official LineageOS was based on work done for /e/OS.

Hi, reflective_popcorn,

Thanks, I’d be very interested in trying this! If not tonight or tomorrow, maybe next week…

Hi Elizabeth,

Sorry for the delay it’s been rather busy with all the holidays and haven’t checked in much. Merry Christmas, Happy new year and all that jazz by the way :slight_smile:

Here’s a quick list of instructions on how to do that. Note that these instructions are for Windows only. I know it’s possible to do the same with MacOS but I’ve never tried.

I can’t post more than 2 links for some reason so I think it’s best to leave a quick video that walks through this process just in case, but here’s the written version.

  1. Download the Linux image, for simplicity I suggest Ubuntu since it’s widely popular and supported.

  2. Optionally, for better security, verify the download.

  3. Download Balena Etcher, Rufus, or some other tool to flash the image into a USB.

  4. Plug the USB, making sure you’ve backed up everything in it as it will get overwritten.

  5. Run whatever program you chose to flash the image. The instructions are very simple, just make sure you select the correct drive to flash to. This will take a few minutes.

  6. Once it’s done flashing the image, without removing the USB drive, restart the computer.

  7. This is the tricky part. Enter into the BIOS/UEFI boot menu by interrupting the boot sequence pressing one of the function keys. This step is equivalent to how we access the bootloader on smartphones holding Power + Volume Up/Down.

    Typically it’s one of F2, F10 or F12 but it varies from manufacturer to manufacturer. It’s shown during the loading screen but sometimes it flashes to quickly to see properly so you can also look it up online. In any case, make sure you spam the right key as the computer boots up.

  8. Once you are in the boot menu, you should see an option to select the drive to boot from. Select the one you’ve just flashed and it should continue the boot process with Ubuntu instead of Windows. You may not see the boot menu but at least an option to change the boot order, in which case you need to move the USB option up to the top. This will tell your computer to find a OS to boot into in that order, looking for external drives first.

  9. Do not remove the USB drive while you are using it. Do not attempt to install Ubuntu, you will see an option to do that but that’s not what you want. When you are done you can power off normally and then remove the USB drive.

  10. As you need to download a few programs and files it’s probably best to have a decent sized usb drive.

1 Like

Booting and running Linux on Mac hardware can be a bit more tricky than on Windows hardware. I would strongly recommend running Linux as a Virtual Machine instead using VirtualBox on your Mac,

If you really want to live boot into Linux on your Mac, then best to follow a Mac-specific guide such as this one


why, why why?
why is it not possible for /e/ to fix this? it would be so much more easier to update through the system updater setting.

1 Like

found it already in another topic……

This is great, popcorn, thank you very much! And happy new year etc. to you too :slight_smile:

Thank you petefoth as well, for your comments, recs, and links.

I think I’ll start with popcorn’s description, and look at HTG if I get stuck.
I have Windows 10 on my Mac as a VM in Parallels (been using this for years, because of one program I used for work that is Windows only. Once I get my phone updated, replacing that with a Mac-able program is my next project). So using that seems easier to me than installing another virtual machine (but we’ll see!). EDIT: hm, adding a VM is starting to sound easier than running Linux on a USB…

It says here this topic will close in 6 days, so I’ll try to do this and provide feedback before that happens!

Indeed. @Manoj: Can this topic be kept open longer?

1 Like

If you are already comfortable with that, then just go for it. It’s also probably safer as you can dispose of VM if something goes wrong. The main “issue” with VMs is to ensure they can read peripherals and external drives like USBs or phones. Never tried this with phones myself but it shouldn’t be any different I suppose?

Last night I installed Android 11 from Fairphone. I spent almost 5 hours on it, and succeeded only thanks to the help of a very helpful member of the Telegram group.
Next step: install eOS. (I guess I mean “flash” instead of “install”?)
Said genius also suggested that using a virtual machine for this is suboptimal.
So today I thought, rather than a VM I’ll try the Linux-bootable USB method. So I managed to create that, but

  • there were error messages during booting that I was too slow to get a picture of. (although the whole booting up process took several minutes)
  • when I went to look online for the instructions to flash eOS, Linux (Ubuntu) couldn’t find a wifi adapter.
      • So I plugged in the Ethernet cable - via USB adapter - but that filled that last of my 2 USB ports, so nothing available for the phone. Oops! (I did find the Advanced network configuration dialog, but wasn’t sure I would be able to fill in all the data it wanted for wifi. Yes, it was lazy or chicken (or a little fed up) of me not to try.)
  • So I told Linux to power down, and at some stage a similar amount of error message appeared to that on startup, but this time it didn’t go away on its own. I took a picture, waited some more, and then aborted.

When I booted from the USB, I had the option of installing Ubuntu alongside the Mac OS. If I did that, would it be easy to move between the two? Like, read instructions on the Mac and carry them out on the Linux? Would Linux find my phone in its USB port? (It found the Ethernet connection quite automatically.)

How did I do this in May 2020? If Mac was not an option then either, it could only have been on the Windows VM… Maybe I’ll try that…
I have been a little leery of the Easy Installer, but it’s starting to look sorta good… But I actually wanna try a command line procedure if I can. I have to do some other stuff right now. In the meantime, I’ll be mulling which method to try next time, ie tonight or tomorrow.
PS: I tried carrying out the Linux instructions on my Mac; thought I might get lucky :smiley: but: no go.

What was the reason the VM option was ruled out? It wouldn’t be my first choice if you had access but if you can get it to recognize plugged in devices i.e.: your smartphone, you should be good to go.

I know there’s a Linux distribution designed to work specifically on Macbook, called Asahi. Maybe you can try this instead of Ubuntu. Unfortunately, I cannot give any advise on how to boot from a Mac with neither distribution as I’ve never tried doing this on a Mac.

[FINALLY! Linux on the Macbook M1 (bare-metal)

Found another video that seems to have step by step instructions.

How TO install ASAHI Linux On M1 Mac (STEP BY STEP)

Edit2: I don’t see an option to run this distribution as a live OS bootable from an external drive (maybe there is and didn’t look long enough). Installing a distribution just to flash a ROM seems overkill and, as it’s still an alpha version, maybe you want to hold on and try a VM first…

I think that’s the entire gist of anti-VM warnings: that it can be tricky to connect external devices. I’ve been using Parallels for many years, and it used to be almost always difficult, and has gotten much better.
But! It’s not working now, with Windows 10. I could swear it worked in 2020, but I’m pretty sure that was before I got Windows 10 (I held on to XP as long as I could. :-).
Now, when I plug in the phone it immediately shows up in the Windows device manager, but the terminal does not recognize the adb and fastboot commands :frowning:
Next step: try a Linux VM.

And it doesn’t show up with any exclamation mark (which would hint towards driver trouble)?

What does that mean exactly? Is there an error message?

Not anymore. Thanks, @Manoj.

It did, and then I installed drivers from here: https://adb.clockworkmod.com (can’t remember what page of this site I found that link on) and then it didn’t.

Along the lines of “‘adb’ is not recognized as an internal or external command, operable program or batch file” or something very like that.

And thank you for putting in the request to keep it open longer :slight_smile:

Current adb and fastboot commands are available in the Android SDK Platform Tools.
For Windows they come as a ZIP file to unzip to any folder you like. The command line by default will have to operate in that folder in order to find the commands.