FP3 latest update corrupt, doesnt work

how do I get there? Is it over the factory data reset? Or is it the thing were I have to push the power button very for long

Press and hold power+vol down, yes the screen with start etc.

1 Like

If I press and hold the power button and then chose “start” it says: “can’t load android system. You continue to get this message, factory data reset and erase a device”

this basically means I can forget all my data, doesn’t it?

I did not even get to chose between slot A and B

You must type these commands on your computer.

Don’t choose anything. This is already Fastboot Mode. In this mode …

  • Connect your phone to a computer via USB.
  • If not done already, download the current Android SDK platform tools to the computer and unzip the ZIP file to a folder you can navigate to easily.
  • Open a command line/ terminal and navigate to the folder to which you unzipped the tools. If you are unfamiliar with the command line/ terminal, here’s a really good and short 1 page introduction to everything you need for now … https://tutorial.djangogirls.org/en/intro_to_command_line/
  • Execute the commands.
    fastboot devices … will display an ID of your phone if the USB connection and the fastboot command work, it’s a good test before doing anything else.
1 Like

I am struggling with this step. Is there anyone familiar with macs and can tell me which commands I have to use? (Sorry, I really am not an expert in these things…)
That would be so nice!


I am in the “platform-tools” folder now, but if I enter “fastboot devices”, it says command not found

Use the ls command to see whether “fastboot” is actually in the folder.
If it is, try ./fastboot devices

The ./ part should force the system to use the fastboot command in the current folder (and not look for it in a set of command folders known to the system … I think).
If this works, you just have to prefix every fastboot command with ./


Hello, sorry to bother you again with this.

I set my boot partition to ‘a’ from ‘b’ and my phone refuses to, well, boot. It defaults to recovery with the option to try again or wipe. Trying again just drops me back into recovery.

‘a’ had 0.11 and ‘b’ has 0.12. I’ve put the boot partition back to ‘b’ and it’s still running. Is there anything I need to do to get the ‘a’ partition to boot?

Regards :slight_smile:

Thank you! Unfortunately, it did not work. I changed the slot and then chose „start“ in fastboot mode (that is right, isn’t it? Or do I have to do it in recovery mode?). It said „can’t load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factory reset and erase all data“. With the other slot it says „can’t load Android system. You continue to get this message, factory data reset and erase a device“…

Is there anything else I can do? Any chance to save my data?

That is the same behavior as me.

Could you go to this topic Issues with last OTA update, and reply by describing your exact situation?
You can look to my response, and if you are exactly in the same case, I think you can just mention my description and say it is the same for you.

There are users here for whom switching the slot back after the update simply worked, and there are users here for whom this didn’t work … I don’t know what’s wrong in the latter case, sorry.

1 Like

To be more specific: in the 3-4 cases that I saw where people had 0.12 from September 30 and updated to a new version of 0.12 on October 30, they all got both slots unusable. (But maybe other people had only 1 unusable, and did not post about it.)

Maybe coming to the Oct. 30 update from any version can cause this?

@athair_birb for your 0.12 version, you are not talking about the Oct. 30 update, right? It is an update you made in late Sept./early Oct.?


I updated back in September. It’s not the Oct 30 build

Edit - Version: 0.12-2020093076095

1 Like

Okie doke, I’ll wait it out :smile:
Thank you

Hey AnotherElk,

I have the same problem as Julian on a Fairphone 3. I have followed all the first three steps you mentioned on a Windows 10 OS, but when I execute the command fastboot devices my phone is not found.
If I look into the device manager, I see an Android device with a yellow signal, which suggests that drivers are missing so that Windows would recognize my Fairphone. I have tried various drivers, but none of them makes Windows recognize the Fairphone. What can I do?

Are you in fastboot mode when you try to run these commands? On your device, you should see a black screen, with white, red (and green, when the selected option at the top is “START”) text, and with the first red line stating “FASTBOOT MODE”.
If not, you can get there by holding power-button + volume-down for ~3sec (until you see “Fast Boot Mode”).

If that is not the issue: have you downloaded fastboot from the link of the second step?

Note: if you encounter this issue following the update proposed yesterday, I fear that doing those steps won’t help (it is also the case for me).
Could you tell us any way how it went, whether you are able to boot with the slot changed, or if changing the slot do not help?

1 Like

Yes, I am in exactly in this Fastboot mode that you describe (black screen with white and red text, “Start” on top and first red line is “FASTBOOT MODE”). Is it maybe a problem that in the last line it say “DEVICE STATE LOCKED” also in red letters?