FP3: Unable to update from 1.5q-dev to r-stable - "Failed to find update binary"

I have been told there is no way to do an OTA update from q-dev to r-stable, so I tried to upgrade using adb sideload

However, adb doesn’t see my device (“adb devices” always come up empty, and the first instruction of the upgrade guide, “adb reboot sideload” always complains about missing driver/devices)

Here is what I tried so far:

  1. Followed the instructions to install adb and fastboot and got the Android SDK platform tools
  2. Tried the instruction for manual installation of adb drivers (since the automatic version didn’t work for me)
  3. When that didn’t work, tried Google’s ADB drivers
  4. When that didn’t work, followed the FP3 instructions to install an ADB driver
  5. Tried two different USB cables
  6. Tried on two different computers
  7. Unlocked the bootloader in developer options
  8. Tried both with booted phone connected via Charge / File Transfer / PTP / MIDI / Tethering and in Fastboot mode
  9. Tried pretty much everything in this Stackoverflow article
  10. Rebooted the computers several times

Just when I gave up all hope, I just wanted to reboot my device from Fastboot, and instead got onto an e Recovery screen. There I could select “Apply update” - “Apply from ADB”, which sounded just like what I want, but wasn’t covered in the instructions I had found so far. But in that mode, my PC would suddenly see the device.

However, trying to install the 1.6-r-stable image via that mode failed (“Signature verification failed”). Overriding that led to “Failed to find update binary” on the phone.

Doing anything else via adb in that mode would only lead to “error: device unauthorized”

So it seems my ADB drivers are not to fault. I rebooted and noticed I had forgotten to enable ADB debugging. Doing so, I would now see the device, could do the adb reboot sideload, but would get the exact same error messages as in the e recovery.

So how do I get around those error messages?

There are FP3 documentation problems caused by dev and stable builds coming in different formats currently.
dev builds get installed via ADB sideload (the way you tried), but stable builds get flashed with fastboot while the phone is in fastboot mode.
Here are instructions which currently apply to stable builds …https://doc.e.foundation/devices/FP3/install.


I am guessing that the main issue is the documentation which does not make clear that dev and stable builds require a different instruction set – as said by @AnotherElk.

… maybe you are right …

Are you using Windows ? Might the second part, Windows, of the following post clarify this Windows / FP3 issue ? FP3: From 0.23 Android 9 to /e/OS 1.x - seeking clarity - #16 by aibd.

1 Like

There was no real issue judging by the description in the first post.
First ADB didn’t detect the phone because USB Debugging was disabled at the time of trying.
Then ADB didn’t detect the phone in fastboot mode, which is the expected result. Only the fastboot command works in fastboot mode, ADB doesn’t.
With the /e/OS recovery on, ADB detected the phone, as it should.

Thanks for the hint!

I am now using the instructions you linked, and get stuck at the stage where I “Unlock the bootloader”:
“adb reboot bootloader” works, but
“fastboot flashing unlock” only replies with “waiting for device”.

It seems I can get ADB connection in recovery mode and when fully booted using USB debugging, but not in Fastboot mode.


EDIT: Seems Fastboot needs a different windows (10) driver, as I now get the “Android” entry with exclamation mark in device manager. Investigating what driver to install…
EDIT2: Yep, that was it. Using Windows update, I got a driver that worked.

Ok…so all I got for my efforts was a factory-reset 1.5q-dev install. :frowning_face:

On Windows this could indeed be a driver issue. Fastboot mode uses a different driver than ADB does.
Does Windows Update offer optional drivers perhaps with the phone connected in fastboot mode? (For detailed instructions see e.g. here - section “Prerequisites” - step 3.)

Be aware that unlocking (as well as locking) the bootloader will force a factory reset, deleting your data on the phone.


That is correct.

What about the install of 1.6-r-stable? Did it fail?

Must have misttyped the .sh command somehow. Strangely, the phone did reboot after that, but obviously didn’t flash the new image :face_with_diagonal_mouth:
EDIT: Now flashing, let’s see…

To summarize some pitfalls I encountered using Windows 10:

  • Dev and Stable builds need different approaches for flashing/updating on an FP3
  • ADB will work while booted or in recovery, but not in Fastboot mode
  • ADB and Fastboot may need different drivers on the computer, and you need to check that they are both installed
1 Like

For others perhaps reading along …

This wasn’t always the case, and hopefully will be resolved somehow.

ADB will work while the OS is running with USB Debugging enabled, or while an ADB-capable recovery (like the /e/OS recovery) is running. ADB doesn’t work in fastboot mode, only the fastboot command does.

ADB and Fastboot will need different drivers on Windows, and in case something kept Windows from installing them automatically (and successfully), you need to check.