Gigaset - GS290 - gs290 - Documentation Suggestions

Thank you, version 30.0.5 worked for me. I have now a fully functional /e/OS running on my GS290. Thank you all for your assistance! And special thanks to Gigaset for the software repair of my device.

By the way, where can I find the sha256 checksums for the recovery image on this page?
I only can find the checksum for the system image.

Why does the fastboot process not work the current fastboot version? Is this a failure in fastboot
or in the /e/OS images? Should this bug be reported to the fastboot maintainers?

1 Like

Nice to read your device is now fully working ! :smiley_cat:

The link is missing on the page, but available :
I created an issue : sha256 sum missing for /e/ Recovery (#3995) · Issues · e / Backlog · GitLab

About fastboot : I guess you’re referring to the binary from SDK Tools ?
It addresses directly to the firmware, so it may be a firmware problem.
As I can understand, you had no problem using latest fastboot with stock ROM (and firmware).
So, the question may be : why is /e/ using an old firmware ? Or : why didn’t Gigaset publish the latest firmware ?
I don’t know enough of the GS290 /e/ building process to reply to this myself :frowning:
Fastboot is maintained by Google, so it’s unlucky they feel concerned about AOSP custom ROM :wink:

1 Like

The latest fastboot version is 31.0.3 and it did NOT work. I needed the old fastboot version 30.0.5

Then, it’s a Gigaset problem with their stock firmware :frowning:

Hello World!

I’m new in the /e/-community and just finished successfully the /e/-installation on my Gigaset GS290 - after 2 weeks of struggle with problems, trial and error.

Many thanks to GS290-contributors on the community-pages for their helpful hints! Without their discussions, I’d still be sitting here trying to flash my device.

However, the clues are quite spread. Here comes a brief summary of problems and solutions in form of a how-to-listing (without any warranty):

1: The official /e/-installation-guide should be updated since it doesn’t work anymore with 2021-software.
Problem: the latest Android-SDK-tool-version r31.0.3 (adb, fastboot) cannot reliably communicate with the latest version of Android 10 on this phone type. Some simple functions work, sometimes, but flashing images doesn’t.

Thus, if your phone had already been updated to the latest Android, then the installation course has to be started with a backdate:

2: Preparation: Android in developer mode (7x click on build), Android debugging enabled, Default USB configuration: USB file transfer enabled

(Windows) PC with internet connection. A magnifying-glass will be helpful. GS290 booted into the fastboot-mode (phone off, then vol+ plus power to start into a tiny boot-menu on the phone screen, choose fastboot-mode using vol+ and then start it using vol-). The GS290 (now in fastboot-mode) will be connected via USB to the PC. Windows update now will offer the phone driver necessary for the use of adb and fastboot: download and installation.

3: An /e/-guideline explains how to revert an /e/-phone back to stock-ROM Android; on that page is a download link to a stock-ROM with the name; that file contains a complete Android 10 for GS290 from 2020: download and extraction into any folder of your choice.

4: (Windows) The phone driver, that has been installed before, works with adb and fastboot, but not with SPFlashtool.
The MTK driver can be downloaded from the link in the /e/-guideline, and extracted into a folder of your choice.
Unfortunately, the install-batch is from the time before Windows 10 and has to be modified, which is easy.
(this batch contains an unnecessary Windows-version-check that leads to an installation-error, solution:
insertion of a line:

set osrecognized=1

below the 7 for…do…-lines to make the batch running through even if no Windows-version has been identified)
Now the batch can run to install the driver.

5: SPFlashtool can be downloaded from the link in the /e/-description and extracted into any folder of your choice.

6: SPFlashtool starts with a click on flash-tool.exe and should be used according to the /e/-description to flash the content of onto the phone.
After the flash processes are finished, the phone will boot into the usual Android setup; the next steps will need: Android in developer mode, Android debugging enabled, Default USB configuration: USB file transfer enabled, OEM unlock enabled

7: The /e/ for GS290 can be downloaded and extracted into any folder of your choice (3 partition images: boot.img, recovery-…-GS290.img, system.img).

8: The old version of the Android SDK-tools r30.0.5 is available here: (alternative: …
(the usual Android-site offers only the latest version)
After download, it can be extracted into any folder of your choice (installation with PATH, etc, is not necessary, it’s enough to use the complete path when entering fastboot commands, and to use the complete path of the .img that shall be flashed. That’s going to be a long command line, but clear and straight forward in structure, and it avoids trouble, when you have different tool-versions on the same computer)
Under Windows you may simply try in a normal terminal:
C:<complete path to fastboot.exe>\fastboot devices -l
to see if the program starts and recognizes a connected phone that runs in fastboot mode.
However, a good result of “fastboot devices -l” doesn’t guarantee that fastboot flash commands work.
The following command ensures that the bootloader is unlocked and the phone ready to receive /e/:
C:<complete path to fastboot.exe>\fastboot flashing unlock

9: Installation of /e/ requires 5 fastboot command lines as described in the /e/-installation-guideline.
(example for Windows)
C:<complete path to fastboot.exe>\fastboot flash --disable-verity --disable-verification boot C:<complete path to boot-image>\boot.img
C:<complete path to fastboot.exe>\fastboot flash recovery C:<complete path to the recovery-image>\recovery-…-GS290.img
C:<complete path to fastboot.exe>\fastboot flash system C:<complete path to the system-image>\system.img
C:<complete path to fastboot.exe>\fastboot -w (this wipes user data)
C:<complete path to fastboot.exe>\fastboot reboot

10: After booting the phone into /e/ you will be able to receive the latest /e/-updates.

Any comments, corrections or better ideas?

I never tried /e/'s Easy Installer, because I read that it doesn’t work anymore on GS290.
(Is the Easy installer a GUI that calls a sequence of fastboot commands? Then the fastboot-version might have to be changed back to r30.0.5)

It probably makes sense to keep a copy of both, the containing Android 10 for GS290 from 2020, and the r30.0.5-SDK-tools, at a safe place. Nobody knows how long those files will be available on the internet, and once they have been replaced with newer versions, the chance to flash a GS290 might be gone for good.

Some observations:

  • I first tried the /e/-installation under openSUSE 15.3, but–due to error messages–I got the feeling that phone and computer cannot understand each other (phone running in Fastboot mode, and Fastboot running on the computer, cable plugged, but only basic adb/fastboot-functions worked sometimes, sometimes not, and flash-attempts resulted in error messages).
    Then I tried it under the debian-fork pureOS 9.0 that has quite different software under the hood, but with similar problems, at least I could unlock the bootloader, but I wasn’t able to flash any img-files.
    Then I tried it with openSUSE 15.2 without better success.
    Depending on the Linux-distro, adb and fastboot may need sudo commands to avoid permission errors.
    During those trials with r31-tools and the latest Android 10 on the phone, I encountered error messages like those:
    “terminating with uncaught exception of type std:out_of_range: basic_string”
    “fastboot: error: boot partition is smaller than boot image”

  • (!!!) In fastboot flash command lines it is a difference to write the partition name large or small:
    e.g. “boot” is correct, but “BOOT” surprises with a new error message
    “FAILED (remote: This partition doesn’t exist)
    fastboot: error: Command failed”

  • If something goes wrong with fastboot commands, then inserting of “-v” (verbose) after the word “fastboot” shows more details on the screen

  • (!!!) Downloading the r30-SDK-tools can be dangerous: r30-tools are being offered for download on several websites, and all files I saw had precisely the same name, but one had a slightly different size and completely different hash value (hidden malware?). I believe the google-link above is reliable.

  • All 3 flash processes run well using the old r30-tools even in combination with the latest 2021-Android 10 on the phone, but after booting the phone into /e/, Wifi couldn’t be turned on, and BlueTooth errors popped up, which indicates a broken system. Therefore, I first backdated the phone to the 2020-Android-image using SPFlashtool, then flashed again the /e/-images (using the r30-tools), and now my GS290 runs stable under /e/ including Wifi!


I had a hard time finding the correct driver, finally ended up here:

Don’t forget to reboot Windows after installing :slight_smile:
A sidenote on the GS290, wifi connection is very slow compared to my MOTO G6 and this causes the video’s to play choppy.
I did a download test and it took 50 minutes to download a 430MB file, on MOTO G6 it took only 18 minutes.
Besides the speaker of this phone has a very poor quality, a review stated:
Compared to same class
» 88% of all tested devices in this class were better, 5% similar, 7% worse
I would not recommend this phone for anyone who likes music and video’s.


The only way I know, is to use mtkclient from bkerler. This tool can backup all partitons from a mediatek device (and should be done before you switch to /e/os) - and reflash them in case needed. But this is not as easy as to backup and restore with TWRP!

Thank you so much for recommending this driver download - I was pulling my hair out trying to get the SP Flash Tool to work because it wasn’t giving me any prompts or feedback whatsoever. Installing this driver did the trick!

I am trying to install /e/ on a GS290. I did that before, a year ago, without problems. Now the instructions do not make sense to me:

  1. " Try the /e/ Recovery (limited functionality)" – what does that limited functionality mean? What does it apply to?

  2. /e/ Recovery for stable build” and “/e/OS build : Q stable” both link to the same page… is that intentional? I don’t understand this.

  3. (By the way, that page has as header “dev”, should that be “stable” ?)

  4. Anyway, now I have a file <recovery-e-0.20-q-20211215151799-stable-GS290.img>. Should I rename that to “recovery.img” ?

  5. Then the instructions talk about <system.img>. Where do I get that?, the page doesn’t say! What is it? I do have an old version when I was installing in Dec. 2020…

Sorry, but I am completely in the dark here. Help much appreciated.

Ah, OK, @Jan-ops79 and @Kurtn helped me out on Telegram /e/ community.
2. I overlooked that there are two files on that page: the img and the zip …
4. Can be renamede for the sake of shortness, or copy-past the name.
5. system.img is in the zip.

My questions solved. Suggestions 1 and 3 still open.

In the text of the instructions there should be a warning that updating stock Android (before installing /e/) should NOT be done beyond the security update of May 2021.
There are two places in the text where this should be mentioned.

If one updates beyond May 2021, then this problem happens.

1 Like

Hi @sugit, strangely nobody has raised this as an issue on Gitlab according to this GS290 Gitlab issue search.

Hi @aibd, well I had that problem (i.e. after installing /e/OS - WiFi and Bluetooth not working)
and someone on the Telegram community was so kind to suggest this problem.
And indeed, that solved it.

I posted an issue on GitLab: GS290: after installing /e/OS, BT and WiFi do not work.


Nice done, it helped me, thanks ! :smile_cat:

However, an issue in “proprietary_vendor_gigaset_GS290” may not be seen by /e/ Team …
@Manoj can you confirm, and move it to /e/ Issues if necessary ? :pray:
I think that, until /e/ Team is able to build using latest Gigaset sources, this issue has to be mentioned in Install Guide.

1 Like

Thanks for pointing the issues out. Have moved them to Gitlab

Flashing the system was failing at the beginning for me, with following error message:

Invalid sparse file format at header magic
error: write_sparse_skip_chunk: don’t care size 967349354 is not a multiple of the block size 4096
error: write_sparse_skip_chunk: don’t care size 833135722 is not a multiple of the block size 4096
error: write_sparse_skip_chunk: don’t care size 698922090 is not a multiple of the block size 4096
error: write_sparse_skip_chunk: don’t care size 564708458 is not a multiple of the block size 4096
error: write_sparse_skip_chunk: don’t care size 430494826 is not a multiple of the block size 4096
error: write_sparse_skip_chunk: don’t care size 296281194 is not a multiple of the block size 4096
error: write_sparse_skip_chunk: don’t care size 162067562 is not a multiple of the block size 4096
error: write_sparse_skip_chunk: don’t care size 27853930 is not a multiple of the block size 4096
Sending sparse ‘system’ 1/9 (131068 KB) error: write_sparse_skip_chunk: don’t care size 967349354 is not a multiple of the block size 4096
error: write_sparse_skip_chunk: don’t care size 967349354 is not a multiple of the block size 4096
OKAY [ 6.513s]
Writing ‘system’ FAILED (remote: ‘Unknown chunk type’)
fastboot: error: Command failed

The reason was that I was trying to send the .zip file through fastboot, instead of sending the .img file inside the zip

It is explicitly written in the doc, but I did not notice, because I have the habit to send zip files through adb.

Maybe this could be mentioned in the troubleshooting tips of the documentation?

The installation guide has being updated and should be merged this coming week :crossed_fingers:


Wouhou, that’s fast! Many thanks!

I wanted to also add that it would be worth adding the download links for fastboot 30.0.5 (which is the version mentioned as working for sure):
They are in [SOLVED] Fastboot flash Boot shows uncaught exception of type std::out_of_range: basic_string - #12 by smu44

1 Like

There are changes in the installation steps for the GS290 which are what the documentation update will reflect.

I just installed /e/ on a brand new phone, with update may 2021 running. Still had the bluetooth/wifi error. Returned to stock rom using the instructions from this site. I would like to point out that the stock rom in the download link is a newer version than what/ e/ wants you to update to. Since I was already screwed I updated to last version. Installed /e/ again with the easy installer, and everything works correct now.
So perhaps the instructions should be changed/ or I got lucky
(Sorry if this was mentioned before)