Google Account required for purchase?

Thank you very much for your answers, AnotherElk and marcdw.

I will contact the developer of the Hexatrek app.

Regarding the GoPro, I know you can subscribe to their cloud online, I just wanted to try it from the app to see. Especially as it’s certified to run under MicroG.
But in the end, I’m not interested in their subscription, it was just a test.

Thanks again!

1 Like

I’m still looking for an in-app purchase on eOS.
So I created a Google account. It appears in the accounts section of the system settings as “Google microG”.
I’ve uninstalled the app downloaded from the App Lounge and cleared the cache and user data.
I installed Aurora Store and downloaded the app again from there.
But there’s nothing I can do: when I want to buy the option, I always get the same error message…

I’ve seen that there can be a difference between an app from Aurora Store and one from Play Store. Is this true?

What’s more, the GoPro Quick app I’m using as a test always tells me “Google Play services required” if I try to make a purchase.
That’s weird.

Device registration with Google and Google SafetyNet are enabled, and MicroG’s self-check ticks all the boxes.

I don’t get it…
No one here has made an in-app purchase on eOS?

Any help would be appreciated!

Thanks a lot!

APK are the same, but the apps that register the installation on the device is different, see Hi from Japan. Lots of help needed - #3 by smu44

I thought I explained it pretty well why none of that will work, on any ROM (not just /e/OS), without the Play Store being present.
Yet you then go about trying everything all over again and wondering why In-App Purchases are not working. :expressionless:

Also, adding a Google account to your ROM has nothing to do with anything, thus unnecessary.

To expand on the good point by @piero check out

this old post
this post
and maybe
this one(*)

(*) I believe the updated ‘FakeStore’ may be in the latest 1.12.3 builds. Do not have so cannot check.

Could be a very interresting solution for some users who complain about paid apps not available…

Okay, I’ve (finally!) understood that the Play Store is indispensable. I foolishly thought that Aurora Store could replace it. Sorry, folks.

The problem is: how do I install the Play Store on eOS?

App Lounge and Aurora Store only offer me Play Store updates, not the full app.

Certain items in the ROM share the same package name as their Google counterparts.

MicroG ( is the same as Play Services.
FakeStore / App Lounge Store ( is the same as Play Store.

Those need to be blacklisted in Aurora Store so as not to accidently try and update them. Updates will fail anyway since they are not actual Google products. Long press on the entries and you will see the blacklist option.

Regarding Play Store, hereafter Phonesky, I have touched on that also. Most recent post is this one I think. There is a Magisk module there.
A flashable zip is here…

Releases · FriendlyNeighborhoodShane/MinMicroG-abuse-CI · GitHub

I assume it will detect and remove an existing FakeStore if found. Have never tried nor had a need on /e/OS.

However, there is a big BUT now. For years the patched Phonesky worked fine. As of late it is now broken. Google normally updates Phonesky without user intervention. The nature of the patched version kept that from happening. This time something did. The app will crash when trying to do anything inside it. The main app page also changed showing huge icons (one per screen really).
Phonesky on my daily driver broke first. Then on another ROM. Cleared cache and data but still broken. Re-flashed but no go.
Only just now found this discussion so it is definitely a known issue.

Play Store suddenly crashes. Anyone else having issues? - r/MicroG

I still keep it installed as its other duties still work, such as license checking.
I may test an In-App Purchase to see what else still works.

Oh, that was quick. Trying to do premium icon requests from several icon packs all failing with “Unable to load InApp Purchase products”.
Same packs I used to get /e/ icons made.
Same failure on the other device.
Google did a good job on this breakage.

1 Like

Can you try to purchase your app on another phone, (friend’s phone), and copy the apk into yours ?

It is not possible to do that. Aurora Store (and App Lounge) has worked in the past to get new apps, and hopefully it will do so again, when they have overcome the ‘This account is rate limited’ problem

Well, let me recap.
To buy an option in an app, you need the Play Store.
It’s not possible to install the Play Store on eOS.
FakeStore and App Lounge Store are equivalent to Play Store.
I can’t find FakeStore anywhere, but App Lounge Store is included in eOS, so why isn’t it recognized as the Play Store?

@piero I don’t want to buy a whole app, but an option in an app. The app is called Hexatrek, which lets you explore this trek with a map and points of interest. I’d like to buy the map of the entire trek.

I am sorry I did not mention this tidbit…
App Lounge is the software one uses to install apps, as you know.
App Lounge Store is FakeStore with a new label.

My previous links explain what FakeStore is and why you can’t ‘find it’. It is a system app that cannot be launched because it (actively) does nothing.

When an app is installed, information about how it was installed is shown near the bottom of its AppInfo. If it shows FakeStore or App Lounge Store then the apps will think they were installed from the Play Store. Some apps will fail to run otherwise.
For additional info please read the linked posts.

Aurora Store using root method and App Lounge before FakeStore rename :point_down:

Google Play app installed from App Lounge :point_down:

F-Droid app installed from App Lounge :point_down:

Standard package installer :point_down:

F-Droid Privileged Extension (for F-Droid Classic) :point_down:

And other installation methods.

HexaTrek, the 3034 km hiking trail, connecting 14 of the most beautiful nationals parks and crossing France from the Vosges to the Pyrenees,, already has me day dreaming, but it does not engage me sufficiently to allow Google into my life or phone !

I see that GPX map(s) are available (various GPX viewers are available) in addition to the html Google_map presentation and this is only online.

I would also be looking for old school maps and local guides I imagine are available though the Association.

@marcdw : Thanks for these explanations, it’s clearer for me now.
On my system, Hexatrek is noted as installed from Aurora Store.
If I look at the GoPro Quick app I’m testing, I see that it’s installed from App Lounge Store. However, if I want to access their cloud offer, I get a message: Google Play service required.

@aibd : It’s a big challenge indeed. The app isn’t essential to get started, but it’s still a plus, if only for bivouac sites and sources of drinking water.
I’m in contact with the team to try to unlock the purchase of the map on eOS, but I’m not a priority, you think! There are only half a dozen of us in this situation.
So I alternate between here and there to sort things out. It’s not easy, but I’m not giving up hope!
As I say, it’s the first mountain on my Hexatrek!

I finally got around to checking that out. Same error message on a ROM with Play Store.
I expected that to not work, what with the recent breakage of Play Store on microG. As mentioned earlier I can no longer do InApp Purchases now. Not really a good test I guess.

Checked logs but I seriously can’t find anything that sticks out. :slightly_frowning_face:

The situation seems to be getting more complicated.
How do you access the log files? This could help me give info to the app dev.

The thing is, in your case the InApp Purchases will not work without Play Store being present to handle the transaction.

Logs will be of no consequence.

I only mentioned logs in relation to my now broken Play Store behavior where InApp Purchases no longer work.
Apologies if it added extra confusion.

No need to apologize, marcdw, I rather have the unpleasant impression that it’s me, the village idiot, who doesn’t understand a thing!

You need the Play Store to buy an in-app. App Lounge Store (Fakestore) is supposed to pretend to be the Play Store under eOS ( And yet, the purchases don’t work.
Why is this?
That’s why I’d like to have access to the log files. Maybe they could give me a clue. Maybe I could send them to the app dev.
I’m going to search the system with a file manager for these log files.

I’m beginning to despair of ever getting anywhere…

Could be in internal storage into the /android/data folder

I explained how FakeStore works in a couple of the previous links and posts. It literally does nothing. It cannot be executed.
It is an apk with the same package name as Play Store. Its purpose is to just sit there in case some app looks for the presence of Play Store and nothing more.

Examples I’ve used in the past concerns icon packs for instance, free or paid. After installation the pack checks to see if it was installed from the Play Store. If it sees it was not the app will present a dialog saying so, maybe implying piracy, and refuse to run.

It is in those kind of instances where FakeStore’s presence may be used (by Aurora Store w/root method or App Lounge where it’s used automatically).

So, once again, FakeStore is not an app that can be launched or run. It is just a stub. So of course purchases do not work.
There is literally nothing you can send to any dev about this because there is nothing.

This is the way it is on any ROM without GApps or working Play Store (the real one).