Google Account required for purchase?

No need to apologize, marcdw, I rather have the unpleasant impression that it’s me, the village idiot, who doesn’t understand a thing!

You need the Play Store to buy an in-app. App Lounge Store (Fakestore) is supposed to pretend to be the Play Store under eOS ( And yet, the purchases don’t work.
Why is this?
That’s why I’d like to have access to the log files. Maybe they could give me a clue. Maybe I could send them to the app dev.
I’m going to search the system with a file manager for these log files.

I’m beginning to despair of ever getting anywhere…

Could be in internal storage into the /android/data folder

I explained how FakeStore works in a couple of the previous links and posts. It literally does nothing. It cannot be executed.
It is an apk with the same package name as Play Store. Its purpose is to just sit there in case some app looks for the presence of Play Store and nothing more.

Examples I’ve used in the past concerns icon packs for instance, free or paid. After installation the pack checks to see if it was installed from the Play Store. If it sees it was not the app will present a dialog saying so, maybe implying piracy, and refuse to run.

It is in those kind of instances where FakeStore’s presence may be used (by Aurora Store w/root method or App Lounge where it’s used automatically).

So, once again, FakeStore is not an app that can be launched or run. It is just a stub. So of course purchases do not work.
There is literally nothing you can send to any dev about this because there is nothing.

This is the way it is on any ROM without GApps or working Play Store (the real one).

Okay, so no Play Store, no In-App purchase.
And you can’t install the Play Store on eOS.
So no in-app purchases possible on eOS.
Crazy, isn’t it?

In-App purchases may not be common, but I’m surprised that the eOS/LineageOS devs haven’t come up with a way around the problem.
And what about buying an complete app?

I think it has been reported that apps paid for at Amazon app store (aka Amazon Underground) are expected to work on /e/. But in a quick test Amazon store would not let me log in with my /e/OS phone !

/e/OS is actively degoogled. To what lengths should /e/OS developers go to re-google it? Problem of expectation, and of development resources (which are scarce as it is).

LineageOS developers don’t need to do anything in this regard, because after installing LineageOS you can simply install the genuine Google apps and services if you want, and in a capacity of your choice (via installer projects like Open GApps or MindTheGapps and the like).

1 Like

Let’s be clear: eOS is deggoglelized, and that’s just fine!
I’m just surprised that there’s no way to enable app purchases or in-app purchases without going through the Play Store.

Perhaps in a future version of MicroG?

You saw my post #25 re Amazon ?

Indeed ! The $15 Bounty is still open to solve this problem in microG

From above @mar-v-in explains (for a specific issue in 2017)

The problem is that Play Store tries to call a method that it is only allowed to call if Play Services and Play Store are signed with the same key. As this is not the case when using microG with original Play Store, it crashes.


And to reiterate, a patched Play Store that works with microG has been available for years. As I mentioned earlier, Google has recently found a way to break it.

mar-v-in’s comment from above pretty much shows there isn’t much that can be done regarding InApp Purchases.

Yes I saw your post, aibd. I didn’t know about Amazon Underground. I’ll give it a try, at least to check that the app I’m interested in is referenced there.

If you need In-App Purchases and don’t mind having Play Store, there may be some good news.

I mentioned that the Patched Play Store, used for years with microG, is now broken. Given its age part of the breakage is that it no longer matches the current UI used in recent Play Store releases among other reasons.

Anyway, the MinMicroG people have put out new stable builds of their installation packages. The Play Store included in some packages is now vanilla. No patches, no signature spoofing, straight Google.

On my Havoc OS Pie I removed the Patched Play Store and flashed the new 2.12.0 standalone Play Store package. It worked immediately. I then tested In-App Purchases (IAP). That is now back to working. No errors from apps that previously couldn’t do IAP after Play Store broke. Did a test purchase. All good.
Later I updated Play Store on my older Oreo-based microG ROM. Flawless functionality.
Guess I was the first to report successes (at least in the microG Telegram channel). Maintainer was pleased it worked for me.

If you decide to flash Play Store the package you want is this one…

Available from here…

GitHub - FriendlyNeighborhoodShane/MinMicroG_releases: Prebuilt flashable zip RELEASES for the MinMicroG project.

There is a gotcha. The matter of what to do with FakeStore. Since the package wasn’t intended as a FakeStore-to-PlayStore thing there is no search-find-remove function during installation. FakeStore will have to be manually removed beforehand.
I brought this up to the MinMicroG maintainer and he thought it was a good idea to maybe add a way to deal with existing FakeStore. Fingers crossed for a future package.

I have no intention of doing this on /e/OS but on existing microG ROMs that had Play Store, the vanilla version works way better than expected.


Good news!
But how do you integrate this into eOS without breaking the bank?
I’m afraid I’m doing more harm than good by tinkering with the system.
Perhaps this will be included in a future update?

Thanks a lot for your tests, @marcdw!

No, quite sure Play Siore would never be included. A Google app in a deGoogled ROM? Sends the wrong message. :grin:

As far as integrate, one just flashes the aforementioned zip.
The breaking part would be in manually removing FakeSore. :grimacing:

This topic was automatically closed after 90 days. New replies are no longer allowed.