Google Cloud Messaging doesn't seem to work

Hi everybody :wink:

As you can see, there is no application added in the GCM section of MicroG.
Screenshot_20190423-202348_microG_Services_Core
Notifications of Tutanota and Telegram work but not for Signal, ProtonMail, Snapchat and Brave.

Of course, those apps aren’t battery optimized, and are allowed to run in background. Furthermore, the Signal constant notification in order to keep an app alive in Oreo is active.

I’m desperate, I hope I won’t have to raise an issue on the gitlab, it would mean I have no solution. Thanks :slight_smile:

My device is a Samsung Galaxy J5 2015.

hello, I had the same problem like you and I’ve found a document on internet (in French sorry but you can translate with your favorite translate service) https://wiki.zaclys.com/index.php/Installation_de_microG with an interesting clue
“If you are using the AdAway ad blocker(or any other), be sure to add mtalk.google.com to your white list.”
that solve my problem

I’m French :wink: Blokada wasn’t blocking that link, so it changed nothing. Thank you for the try.

1 Like

ok, the quest continue for you… Courage !

1 Like

@Anonyme, Okay, so you say it’s not blocking it but have you added mtalk.google.com to the whitelist anyway? On microG-based setups it has always been necessary/recommemded to whitelist it if using an ad blocker. Do so anyway (if you haven’t) before discounting.

Yes I added it even if I was sure Blokada wasn’t blocking it.

1 Like

Woo, that was a quick response. Hmm, okay. Not sure what’s going on then. I assume you haven’t restored apps & data from a backup (apparently they won’t register for some reason). Odd.
Do you have Google device registration turned on?

Yes it’s turned on. I think I will go for a fresh start and take hours to reconfigure everything again, without encryt data this time in order not to have that issue.
Thanks for trying :slight_smile:

So, I’ve done a factory reset. The first thing I did was to use Signal.

Signal : I receive correctly Signal calls, but Signal messages aren’t notified until the phone is woken up (typically, as soon as I click on the home button the notification comes). But SMS (Signal is the default SMS app) notifications work properly, without intervention needed.

ProtonMail and Brave (and probably others) : still no notifications, and nothing appears in Google Cloud Messaging.

So I suppose I will have to wait a patch (from /e/ or MicroG, I can’t use LineageForMicroG in order to test because my device isn’t officialy supported by LineageOS) before using /e/ as a daily OS.

sorry to ear that, I think it’s device related, all is working great concerning the notifications push on my device (xiaomi redmi note 5) except for yuka (because you need an account to use the app and it’s impossible to connect) but it’s not really a problem, there’s a bunch of apps doing the same job which are working great like incy beauty…

I had the same problem with signal and no GCM-login, and i solved it by entering the following phone number
*#*#2432546#*#*
(found at https://github.com/microg/android_packages_apps_GmsCore/issues/740#issuecomment-478675965 )
my workflow was:

  • entering the phone number
  • backup signal data (check signal menu)
  • Signal App --> stop and delete all data and cache
  • stop blokada
  • reboot
  • wifi off
  • entering the phone number again
  • start signal and restore from backup
    Then Signal and other apps were registered in GCM
2 Likes