Google Pixel 4a5g stuck at fastboot, will not switch to recovery

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I have two Pixel 4a5g (my son and I). One has e/OS-s and the other keeps getting stuck trying to install at fastboot.

To get Android 12 on the one in question I use Googles flash tool:

Android Flash Tool

I then pick the older version of Android 12 to install SQA220205.002, API 31. Once I have that installed I add a simple password and turn on Developer mode, USB debugging and file transfer mode. Using the Easy installer the Pixel is detected after allowing the PC to connect. The installer gets to the point were it tells me to use the volume button to select “Recovery Mode”, confirm with Power button. At this point the phone boots to fastboot mode but no e/OS recovery. The phone will not and just loops back to fastboot or start, but it will not start the stock ROM or recovery.

I have also tried several time manually and it’s the same result. To get out of this mode I use the google installer again and select Android 11, then load e/OS-r.

I read about a special step that needs to be done to load ROM onto the Pixel 6 (have to find it). I wonder if Google has added this to their 4a5g ROMs? It is like the e/OS recovery image will not load on the device once at Android 12.

I actually have mine running at e/OS-s (very nice BTW) and I did it from e/OS-r manually, I think I was at e/OS-1.6-r. I will look at my comments and see if i can figure where I was at when it worked.

Anyone with information or thought please post. Also would be nice if the Developer can have a look, who do I message or how to report that?

OK so I solved this problem but I had to do it with Google flash tool then easy-installer, command line method was used in second step, not that difficult.

I rolled back to Android 11 using google Flash tool, I install Android 11 with option to wipe and force write to both partitions. Once at Android 11 I used easy-installer to install e/OS-1.7-r. From there after setting Developer Mode and USB debugging (was already unlocked). I then flashed e/OS-1.7-s using the power and down arrow to get into e-recovery mode.

I then just followed the instructions on the command install page for bramble:

" Steps to install /e/OS from recovery"

Thing to note is I could not manual (command line) install e/OS-1.7-r, I had to use easy installer, not sure why. I am also able to boot to e/OS recovery 1.7-s now.


On my Pixel 4a 5g, I wanted to install eOS 1.8.1 with easy installer.
I followed all the steps until the moment when it must restart in recovery mode but impossible to go further.
This is the screen I get to when I start the phone:

I tried to use but without success…
I need help please :cold_sweat:

Problem has existed for some time…

Were you able to get your back to normal?


I have to ask. Did you try the up down button on the phone to change from Start to Recovery Mode? Once you get Recovery press the power button to select that feature.

Gianna, I just did a redfin last night and it went perfect. First downgrade using google tool to the final version of android 12.xx then use command line to load e/OS as per instruction.


To use the android flash tool you need to use Chrome browser, I won’t install Chrome on my PC, but windows sticks me with Edge so I use it, it is compatible with the flash tool. I only use my windows PC for that, my daily PC is Ubuntu Linux.

Thank you for your answers.
I’m on linux and I had installed Chrome specifically to use Android Flash Tool.
Here is the error message that I systematically, even by following instructions:

Did you do the driver step? I did it in windows so I was able to see it in device manager.

I don’t know your experience level so I will list all things to check. Make sure the cable you are using is indeed a data cable and not a charger cable. Make sure the phone is in developer mode and USB debugging is enabled.

I notice the flash you selected is android 11, if you wan eOS-s you need to flash with last version of android 12.xx, the final one.

I am unsure how to verify that the driver is working in Linux. What Linux are you using Ubuntu?

@Jets, it is possible that now /e/OS-S V1.8.1 works better than the previous versions. As much as I appreciate /e/OS, I’ve been very pleased with an AOSP 13 CustomROM with relocked bootlaoder for some time now.

I’ve gotten stuck in fastboot mode on Pixel quite a few times trying to do dumb stuff with my phone, that’s just me. One thing that’s always worked for me is downloading the CalyxOS Linux installer and getting back to a usable phone. I don’t use Calyx very often, I mostly use /e/os, but their installer has pulled me out of a lot of jams. I didn’t want to advertise /e/ competitors on their forum, but you’re still looking for a solution, then I highly recommend the Calyx installer. At least you can then start over with installing /e/.

Hi @Jets
Thanks for your answer.
My main issue is that the phone no longer boots to Android. Only in Fastboot Mode…
Drivers and cable OK because I was able to do the Easy Installer steps until the step of restarting in Recovery Mode which did not work and which blocks me until now.

1 Like

Thanks a lot for the tip!!!
After the 2nd try, CalyxOS installed correctly :partying_face: :partying_face: :partying_face:
The opportunity for me to test CalyxOS before trying to install /e/OS again :wink:

1 Like

Good Deal! I’m glad you were able to unbrick your phone. That’s a method that’s always worked for me when I get myself into a mess. Calyx is a good OS. It’s like LineageOS with enhanced security. I like to check it out when they get new major updates like with most de-googled roms and Ubuntu Touch. /e/ is still my go-to tho.

I found why I was stuck, it was an ADB version issue. The version of the debian repository is not the latest.
After having solved this problem, I was able to manually install Android Factory Image in version 11 (Factory Images for Nexus and Pixel Devices  |  Google Play services  |  Google Developers), then launch the installation of /e/OS 1.8.1-R with easy installer (it would have been nice to be able to choose between R(11) and S(12)), and when it restarted in Recovery mode, I closed easy installer and manually continued the installation starting with the wipe then adb sideload with verion 1.8.1-S (as mentioned in the guide)!
Thanks @Jets for the tip!

1 Like