Got stuck: Odin fails to flash vbmeta.tar "Only official released binaries are allowed to be flashed (vbmeta)"

Hey guys,
today I wanted to install /e/OS on my Samsung Galaxy Tab S5e WiFi (SM-T720) and got already stuck when trying to Flash vbmeta.tar as suggested in the official /e/ installation instructions. Bootloader is unlocked, USB-Debugging is active, Odin version is v3.13.1, vbmeta.tar was just downloaded yesterday (2022-02-25), version of official samsung stock is Android 11, One Ui-Version 3.1, Kernel Version 4.9.227-22521289, Build number is RP1A.200720.012.T720XXU2DUL1. No updates available.

No matter what way I get into download mode, the message is “Only official released binaries are allowed to be flashed (vbmeta)”.
I have absolutely no idea how I can solve this. I would be grateful for any hint you can provide me with.

Thanks a lot in advance & best regards

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I think that the best way to start to look at this is for you to send an image of your Odin mode or Download mode screen. Often this is associated with some proprietary lock, this is usually revealed on the Odin mode screen as a certain lock or a variant of “Prenormal”. The text on this screen is quite small and hard to read.

More information (or clues at least !) in this article Know your hardware - Samsung.

I seem to recollect some issues with this model, revealed by a search Search results for 'Galaxy Tab S5e WiFi' - /e/ community and Samsung - Galaxy Tab S5e (Wi-Fi) - gts4lvwifi - Documentation Suggestions - #2 by trashHeap

Hi Aibd,
thanks a lot for quick reply. Here’s a photo of the Download Screen. Is that sufficient, or do you also need a screenshot of Odin?
Best regards

I read the article on how to prevent Prenormal, but the supported devices listed in this article do not list the Tab S5e. Any chance to bypass on this one?

Thank you for those images. that is the basic information I asked for; it tells us that you will not be able to flash anything at all except a Samsung Official binary till Prenormal is lifted.

You are at the Preinstall Instructions (and cannot move on). The target now is to have the Prenormal barrier lifted to “Checking”. Please be aware to keep checking for that clue on the device.

First of all this is a device “Built for Android 9” where you propose to install Android R using

Please can you tell me the version of Android is running at present.

My “Know your hardware” article gives some clues to the many reasons Prenormal might exist. Half the problem is to find out what hurdle you have to meet.

If the phone brand is new or refurbished “like new” you may have to use it “normally” for 7 days with a SIM and wifi. This is mentioned by @trashHeap as a blocker in the third link I already gave you.

Be aware:

Boot Modes
Recovery :
With the device powered off - hold Volume Up + Power.
Download :
With the device powered off - plug in the device while holding Volume up + Volume Down + Power.

The clue here is “plug in the device”. The physical connection of the USB cable is being used as a trigger of some sort. Any time you see a comment about what you are to do with your USB cable it is likely to be vital that you follow the exact sequence you are given.

As I do not have personal experience of this device, I am not going to tell you what to do, just point you to the material that has the clues you need! The second link points to 12 user experiences, one or two of which might be relevant to you; the third link is vital reading - Document Suggestions contains any user feedback where the successful installer kindly left clues for those who follow.

When you mention bypass method are you referring to the Corsicanu RMM/KG bypass? Notice that cannot be used beyond Pie.

Your Odin mode image does not go right to the margin ! So that you get all the clues and can tell for certain if something changes, it might be helpful to write down here exactly what you see in this format (correcting what I cannot see !):

xxM LOCK : OFF (U)

Post script As well as asking whether the phone was new, with regards to the possibility of a simple Region lock, I should have asked if you got it through a regular retail channel or whether there is any possibility the phone was not sold in its intended market? This is often seen in devices imported to USA !

Good luck

Hi aidb,

thank you very much for your reply. I really appreciate the effort you take. You mentioned that the target is to get the device to “checking” state. Interestingly enough, it just changed the state and now mentioned “checking” where to showed “prenormal” before. Should flashing vbmeta.tar now be possible without issues? It may just be my inability, but I didn´t manage to read this from the sources you mentioned. Apologies. Any further help you can provide is appreciated.
Thanks a lot in advance

Sorry, forgot to answer your question on the current Android version the device runs. Currently the Samsung stock is on Android 11.

You are good to go !

I didn’t manage to read this from the sources you mentioned

Just to confirm, was it only a reference to “checking” which you could not find elsewhere. ?
In which case I agree that it is not clearly mentioned often but it is ok. I do not expect you to see “Only official binaries …” again now !

1 Like

All worked perfectly fine. I was able to flash vbmeta. However, it did not reboot into Android as mentioned in the instructions. Instead it went back into recovery and said: “Can’t load Android system. Your data my be corrupt. If you continue to get this message, you may need to perform a factory data reset and erase all user data stored on this device”. Anyway, went into download mode and flashed TWRP, which worked nicely. Than flashing /e/OS was easy just like in the instruction. Now it runs perfectly well.

So it seems that once in prenormal it may be just about waiting a few days. Everything else works fine.

Thanks a lot for all your support - really appreciate this!


I actually have the same issue where I accidentally locked the bootloader in download mode when an unofficial package was still flashed and now the /vbmeta partition corrupted itself and now I don’t know how to unlock the bootloader anymore because the device unlock mode option in download mode is missing. It’s a Samsung Galaxy Tab A7 Lite (Wi-Fi) model. Here is the picture:

Hi @DeclanMiner2005 welcome to the /e/ forum.

I cannot read essential clues from your image.

Please can you look for these 4 lines which I had partially identified form the OP image:-

and type them exactly as you see them.

Please can you confirm if your device is codename: gtexslte SM-T285.

Do you have the device online with WiFi and with a SIM installed and active ?

open the image in your web browser or drag it to your desktop.

the warranty bit is set to void (0x1)

and it is doing the update over usb instead of wi-fi because android verified boot is corrupt.
new picture:

video so you can see the error:

Error log:
sec crtl status (2)
WARRANTY VOID: 0x1 (0x500)
DID: 4f7a0c911cbe
Only official released binaries are allowed to be flashed: vbmeta

Update failed:

Perhaps you have a totally different issue ?

Probably best to try to reflash stock ROM with Odin.


The key to your problem is that “Only official released binaries are allowed to be flashed” that is Samsung binaries and not Custom binaries.
I do not advise to keep flashing with any Custom binaries.
Your issues with any Custom ROM will not resolve until OEM Lock is OFF and KG Status has turned to either “Checking” or “Normal”.

  • If you need more info please can you explain why you ask in an /e/OS community support forum?

Source image:

I tried to flash it multipile times but the packages just failed to pass the SW REV CHECK in odin mode. And I joined this forum because I tried to flash vbmeta.tar and it failed ALL the time either giving me a security error saying I flashed unauthorized firmware or a vbmeta/AndroidVerifiedBoot image or a screen with a issue reporting on the screen like ERROR: error verifying vbmeta image, invalid vbmeta header and this weird corrupted-looking text. The text would be:

Partitions recovery
Reason avb_footer:c:41: ERROR: Footer magic is incorrect.
avb_vbmeta_image:c:65: ERROR: Magic is incorrect.
avb_slot_verify:c:65: ERROR: recovery: Error verifying vbmeta image: invalid vbmeta header
SAMSUNG vbmeta, T220XXS4CWG4, 68323112R
CUSTOM recovery

l H

OK. Thanks,

Please define “it” preferably with a link.

… and a bit more background … what was last running successfully.

yea but i do not have a picture of when it was last running okay. sorry
here is link to the firmware:

hello @DeclanMiner2005
what /e/OS install file did you tried to install on your device ?
i cannot find SM-T220 as supported device…

actully trying to do that is not what i am trying to do. i am trying to flash the stock ROM but nothing works.