GS290 easy-installer stops

And which one would that be?

Probably something already in Howto troubleshoot issues with the easy-installer?

It just states that there was a problem …
I’ll follow the link you sent, maybe this will fix it.

If not I will post again.

Thank you

I had a look but it seems that the right solution is not there.

I will try a different machine now … or I may try the manual installation … guess there is one …

Is OEM unlocking in the developer settings of Android enabled?

Yes of course …
OEM unlock
UDB Debugging
USB Settings: MTP

Hello @Ingo_FP_Angel, /e/asy installer specialist. If anyone knows, it’s you:

The Easy-installer (v0.12.0-beta) downloads the file, among others.Am I right in assuming that this is the “stable” version e-0.14-q- from January 2021?

The “dev” version IMG-e-0.14-q-2021012698290-dev-GS290 was withdrawn because of the bootloop bug.

It is the 12beta, I just followed the link for the installation.

@16locke, I would strongly recommend that you do this, because this was the only installation method I could use to get the GS290 to work. I was able to persuade the /e/asy installer to complete the installation including the creation of an /e/Account, but the restart ended in a bootloop. There were a few more surprises that cost me several hours of work to get the GS290 working again. More about this soon.

Tip: Please flash only this /e/ ROM for a successful experience: IMG-e-0.13-q-2020121590520-dev-GS290

Can you provide a screenshot, please? And the logfile(s) from %LOCALAPPDATA%\easy-installer (you can paste that into the location bar of the windows file explorer)?

As far as I know the installer always takes the “stable” version, yes. But I don’t know which exact version that corresponds to.

Edit: maybe I need to phrase it differently. As you wrote, it takes “” and these files labeled “latest” are the stable branch AFAIK. So the installer takes whatever the download server offers under that name at the time of execution. The installer always downloads a fresh copy of the checksum file. And if the file with the name “” has been downloaded before and updated on the server in the meantime, the checksum mismatch is detected and the updated “” is downloaded. Otherwise the already downloaded file is kept.


@Ingo_FP_Angel, thank you. That’s what I like about your posts: They contain more than a handful of words and are meaningful in content.

The Windows edition of the /e/asy installer (v0.12.0-beta) worked for me, but my installation was stopped several times, because my Windows PC did not automatically change the USB driver installations depending on the installation status in the Windows Device Manager under “Other Devices” | Android Device the correct driver software. I had to manually help several times and change the driver software so that the installation process continued.

For example, when the GS290 is connected to the Win PC for the first time, the device manager displays: "Other Devices" /!*\ GS290 and the device is not displayed by the Windows PC.

For example, if I change the Windows Device Manager to ADB Interface | ADB Testing Interface I’ve full access to the GS290’s internal memory. I’ve not been able to find a Windows Device Manager setting that has supported all installation stages of the /e/asy installer from start to finish. This is where I would like to learn.

But what I find unforgivable is that the /e/ allows a buggy version to be installed, which then ends in a bootloop. It must be withdrawn immediately to protect the users and the GS290 device. My GigaSet290 was non-functional after the /e/asy installer installation.

/!*\ = Exclamation mark yellow triangle

1 Like

The maual installation worked like a charm.

Flashed 3 phones in a row.

Thank you


I have bought a GS290 specifically to install /e/, but using the easy-installer (version 11.2 because v12.0 has some trouble running on linux), I get the message that the GS290 is not supported :frowning:
From the terminal:

   DEBUG e.e.i.tasks.DeviceDetectionTask - checkAdbDevicesResult(GS290CTM100088         device usb:2-1.2 product:GS290_EEA model:GS290 device:GS290 transport_id:1)

Note that the easy-installer requested to activate MTP, but this option was not available, and the phone was detecter when I activated usb file transfer and usb debugging.

Did anyone flash the GS290 successfully?

v0.11.2 of the installer in fact does not yet support the GS290.

You would need v0.12.0 for that and as you said, that’s broken on Linux ATM.

Yeah, but my recommendation is to flash /e/ OS version IMG-e-0.13-q-2020121590520-dev-GS290 using fastboot method described in the /e/ documention.

As a Linux user, you should be familiar with the operation of PC terminal and thus quickly achieve success with /e/ OS ‘Q’ on your GS290.

See also:

1 Like


I have the GS290 as well and wanted to use /e/, but after using the easy installer I ended up with a boot loop “Orange State…”
I updated the phone to Android10, set developer mode, activated MTP and unlocked the boot loader just as the installer told me to, but a short time after the start of flashing an error occured and now the phone is permanently rebooting…
How can I get out of the bootloop (and /e/ running)?

Can you give us more details about that error?
Ideally you could provide the log as described in Howto troubleshoot issues with the easy-installer

To get your phone up and running you can then follow the advice of SuzieQ above.

Several us/e/rs have already fallen into this trap. So have I, but only because I wanted to know why it happens the way it does.

My summary is quite simple. The /e/asy installer loads a buggy eOS ROM. But this is all sufficiently communicated - only nothing is changed on the part of /e/. That’s simply […]

easy installer showed an error, actually I didn’t take a pic :frowning:
the log file can’t be saved with
because it exceeds the maximum length…

How did you get out of the bootloop?