HD Voice compatibility

So I’m on oreo, not pie.

OK, got it. I’m not sure if the S7 Edge is “officially” getting the “Q” update- that info may be floating around the forum, so a search would be in order- if this fails to produce any tangible results, perhaps a short DM to @manoj can get that answered quickly.

If “official” support won’t be forthcoming, perhaps @itsclarence could be persuaded to prepare an UNOFFICIAL /e/OS “Q” ROM for the S7 series. I’m not trying to give him more work :wink: but he’s a prolific ROM builder for /e/ and an incredible asset to the /e/ team!

I noticed that S5 and S8 are on pie, at least. I’ll go look to see if anybody is working on Q. I’ll check into all that later today.

SUBJECTIVE opinion only: my preference would be an unofficial ‘Q’ build than an “Official” Pie build. Android 10 is that much better… Good luck and have a good day.

Thanks. I love to try new things, so I’ll check into getting Q done.

Hi @davking

Boy is it your lucky day… /e/OS ROM Builder par excellence @itsclarence has allowed me to share his new ‘Q’ UNOFFICIAL build for the S7 Edge: e-0.15-q-20210304-UNOFFICIAL-hero2lte.zip for you and others to test.

If you’re going to try it out, he reminds you to please backup your device first!

Please remember to share your results with the community. Best of luck to you.

Wow, many thanks to you and @itsclarence ! I will get on it soon, and see how well it works.

I appreciate the thanks, but ALL thanks goes to @itsclarence, I’m just the messenger.

Before he rolls this build out in its own thread, a few things to check and report back if you don’t mind:

  • Any install issues
  • Any issues with Wifi and SIM Card connectivity
  • Version of MicroG shown and does self-check “pass”
  • Dialer/Phone functionality
  • Any voice “echo” or other voice abnormalities during phone use?

@davking You are on the cutting edge of /e/OS development for this device! Good luck and many thanks for testing.

I am unable to install it. The first time I sideloaded it, it failed with a signal 7 error. The second time, I got a successful install, but when I reboot, TWRP says there is no OS installed. Perhaps I’m doing something wrong.

Search the forum for Error 7, it has been overcome. If still no luck, DM @SuzieQ who is a master Samsung installation guru, she will likely be able to help.

Okay, I’ll take a look.

I was able to fix the signal 7 error, but still no joy. I’ll get with SuzieQ and see if she can help.

Some good news. I managed to enable Enhanced 4G LTE on my phone, via a Magisk addon. So hopefully it never quits working.

Is the rom booting normally ?

Regards Edwin

No. It seems to install without error. But it won’t boot. It gets stuck on the Android splash screen. I had to reboot into recovery, and reinstall 0.14 oreo. Is this a situation where you have to reinstall stock Android, then install 0.15?

No, no need to install stock Android. But you have to make a clean install. So no dirty flashing.
I’ll build another one to test… ready in a couple of hours.

I take it that clean install is where you reformat, and wipe cache and Dalvik? I did that, it didn’t work. Thanks for putting another ROM together for me.

I meant wipe cache and system, not Dalvik.

That’s correct. A clean flash means formatting Data and wiping Dalvik/cache system and data.

OK, glad I got that right.