How to do a Nandroid backup without TWRP?


When I still had TWRP, I frequently made Nandroid backups, so I could go back when I broke something. Now, eOS isn’t compatible with TWRP any longer, and I wonder if there’s another way to do full (Nandroid) backups. The e-Recovery doesn’t support this (so it seems).

Cheers, Volker

Which device? TWRP still works for some devices

1 Like

Hi. It’s a Xiaomi Redmi Note 8T.

/e/OS probably inherited an install incompatibility with TWRP from LineageOS, at least on other devices this happened with LineageOS before.

But this doesn’t automatically mean that you can’t use TWRP to make backups.
If you can still install TWRP (the /e/OS updater has a toggle to enable/disable updating the recovery with OS updates), the limiting factor instead should be encryption support in TWRP.

/e/OS is on Android 11 (R) currently on your device, there’s a good chance that you could still use TWRP to make backups if this worked before for you with Android 11 (R).
On my device Android 12 (S) broke this for now, as TWRP can’t handle Android 12 encryption on my device apparently.
So your search for an alternative is still valid.

1 Like

Hi. I suffer from that encryption problem, and also - what it seems - from that install incompatibility with TWRP from LineageOS, like you said. Just flashing TWRP seems to break my eOS Installation.

So, any other ways to make a Nandroid backup…?

What happens, or how does it “break”?
I’m just trying to understand, since I don’t have the device … According to the device-specific install guide the bootloader is unlocked, according to the device-specific TWRP documentation TWRP simply gets flashed to the recovery partition … Looks fairly unobtrusive on paper.

I’m not aware of anything else which can do this.

If you are familiar with ADB and if your /e/OS build allows you to enable Rooted Debugging in the Developer options, you can run adb root and then theoretically pull everything in the Android directory tree over to the computer, most importantly the whole /data directory.
See also …

Hi. It breaks my eOS by making the Settings app crash, immediately after it has been started. I also had a similar problem with some Bluetooth app. And yes, I had to unlock the bootloader and I simply flashed TWRP.

I’ve used ADB before, and Rooted Debugging is activated. I don’t think it’s such a good idea to make a backup of a life system, because it may change while it’s being backed up, resulting in a inconsistent backup. And the data being backed up might be in a “running” state.

So I went into the eOS-recovery and tried ADB. I had to chose a menu item called “Enable ADB” or something similar. Then I could run “ADB shell” on the recovery. The idea is, that making a backup (by pulling the whole /data partition) would be consistent when done while eOS isn’t running.

But the /data partition wasn’t mounted. I tried to find a manual for the e-Recovery and found a lot of Howtos and special instructions, but no manual… I’d rather not play around and try everything out, without knowing what I’m doing.

I’ve had a look at the XDA thread you mentioned, but it seemed very involved.

Cheers, Volker

It really isn’t (so long as you have access to a computer or VM running linux). You just

  • download this zip file,
  • unzip it, which wll create a directory called android-backup-project-v2.1
  • cd to the android-backup-project-v2.1 directory
  • connect your device
  • run adb devices to check the device is properly connected
  • run adb root to check that rooted debugging is enabled on the device
  • run the script
  • wait for it to complete

This tool shuts the device down, then restarts it running busybox, so Android is not running and the system is not live

The backed up apps and data can be restores to the same device, or a different device, running the same, ROM, an updated version of teh same ROM, or a completely different ROM.

It really isn’t difficult


You’re right, it isn’t difficult. I’ve tried it (had to install “pv”).

After it has finished, my phone wouldn’t boot any longer. The “e” logo with the jumping dot was shown, but it never finished. Then I forced a reboot by pressing the power key several seconds and then it booted normally. It looks okay now.

I don’t know if I should use that tool now…

1 Like