[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

ok so first i need to find what version of software is on it ?

okay on this S9 which im using as my second phone until i learn how to get this installed properly was last updated in may 2020, so what do i need to do next

Please use manufacturer resources for your region, this page is UK.

I apprecaite your help…ok iv found I already have 10 on here and the phone is an S9+

Next I need to identify the twrp thing theres

Samsung Galaxy S9+ (Exynos) (star2lte)

**[Samsung Galaxy S9+ (Snapdragon) (star2qltechn)]

How do i know which of these

  1. …but you still need to know the phone is updated since over a year ago!

ok im updating phone I was hoping you said that

1 Like

Ok I found that with your great help

[Galaxy S9+] star2lte

Now onto the next step.
Ive run the process a couple of times via Odin and it fails. I got a green bar then the RED fail came up.

I downloaded samsung drivers again but its still failing.

If you think there is any possibility that it is a drivers issue, sometimes an upgrade in driver is needed to cope with change of booting mode, please thy this.

Open a device manager window. You will know you are looking for a yellow warning triangle :warning: if there is a driver missing. Now run Odin with the device manager open alongside. Check that a device warning does not appear, if necessary do the Windows update right then, while the phone and PC are still in the failing state.

Secondly, are you fully watching for any flags for user participation! Like something happens on the PC now you have to do something on the device, be sure to turn up the device screen timeout to 30 minutes and watch both screens.

Perhaps check out this Know your hardware - Samsung # First boot into TWRP

and thirdly did you do a factory reset/remove accounts before you started post 91 (although the detail there applies to a more complicated USA case)

If Driver is already installed on the windows PC, in device manager, you have to change the Samsung composite interface, no ?

From what I’ve read, you can’t downgrade the android version. If you have Android 10, you’re going to have to wait until an /e/ version 10 comes out for your phone.

On star2lte I could not downgrade any ROM once I had stock Android 9 or above installed. Likely due to regional lock (I’m in USA). RMM was locked “Prenormal”. This only happened if the stock ROM was upgraded to Android 9 or above before the bootloader was unlocked. If someone is in the USA my advice is use non Samsung hardware to flash yourself or buy direct from /e/ if you want star2lte.

1 Like

Hi Anonyme,

These instructions are brilliant and helped me trouble shoot my problem with my phone not using mobile data with the eOS easy-installer version.

Thank you so much, I doubt I could have done it without you.

Hi Anonyme,

Thank you very much for your detailed and excellent tutorial for installing the /e/OS using the ODIN tool.

Following its instructions I have managed to install /e/OS in my Samsung Galaxy S9 and found it is a lot more easy than doing it in Windows with Heimdall and having to compile this program with complex tools.

Without your tutorial, I would have to do the installation in Linux which is a lot more complex, following all those commands and instructions.

Before trying your tutorial, I have tried to install the /e/OS with the Easy Install but I became stuck in the TWRP transfer to the smartphone.

Thank you again for your help.
Regards,

Paulo Santos
Portugal

Hi Anomyme,
After a few tries it worked as a charm. Thank you very much for this spendid tutorial.

A great thread with lots of useful information.

Hello! I am stuck at point 5. Though Odin3 is recognizing my Samsung Galaxy S10, I receive a FAIL. Any ideas what I could do?/What I am doing wrong?
Help would be highly appreciated. Muchas gracias!

S10 is another story,
you need Odin 3.14
first unlock bootloader and flash the vbmeta.img.tar And the twrp.img.tar

Hola Leontin and welcome.

I have got a samsung s10e, and I have the same issue as you do… “Fail error” in Odin while trying to flash TWRP.

I tried to do what piero recommands flashing vbmeta.img.tar, but it didn’t work either.

If you succeed to do it, I would really appreciate if you could give a feedback :slight_smile: