[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

Hi Anomyme,
After a few tries it worked as a charm. Thank you very much for this spendid tutorial.

A great thread with lots of useful information.

Hello! I am stuck at point 5. Though Odin3 is recognizing my Samsung Galaxy S10, I receive a FAIL. Any ideas what I could do?/What I am doing wrong?
Help would be highly appreciated. Muchas gracias!

S10 is another story,
you need Odin 3.14
first unlock bootloader and flash the vbmeta.img.tar And the twrp.img.tar


Hola Leontin and welcome.

I have got a samsung s10e, and I have the same issue as you do… “Fail error” in Odin while trying to flash TWRP.

I tried to do what piero recommands flashing vbmeta.img.tar, but it didn’t work either.

If you succeed to do it, I would really appreciate if you could give a feedback :slight_smile:

@Leontin, I managed to install /e/ on a Samsung s10e. I explained everything here.

Just have a look ! Good luck

I was FINALLY able to get the OEM unlock to work and ran Odin to install TWRP. Odin says “PASS”, but my device - a Samsung Galaxy Tab S6 LTE, says this on a blue debug screen:

recovery: Error validating footer. (0)
recovery: Error verifying vbmeta image: invalid vbmeta header (0)
VBMETA P610XXU2DUK1, 45668820A

nothing i try will power the device off or get away from this screen. I can push PWR + VOL DWN but i get a momentary flash of the device page like it is going to boot, and then right back here. Can’t even power it off. Any suggestions???

I have the very same issue with my Galaxy Tab S6 Lite… I have not found a solution yet. It was pretty easy to get everything to work with my Xiaomi Mi10T, so this was a bummer.

Anyone with the know-how who could help PFCDroid and me?

EDIT: found this, but I am not experienced enough to test it:

For custom rom or recovery modifications u need to Flash null vbmeta or disable it. If not it will throw AVB fail
-Source: https://www.reddit.com/r/GalaxyTab/comments/pqyjr7/s6_lite_twrp_recovery_boot_avb_fail/

Where to get the files and what to do?

Thread ‘[HOWTO] Flash a blank vbmeta’ [HOWTO] Flash a blank vbmeta | XDA Forums

@PFCDroid The problem is that the TWRP is discontinued for Samsung S6 Lite, meaning that the developer will not update it and that the current version is unfinished, resulting in errors </3 I am trying to find a good solution.

@Anonyme I think it would be wise to mention early that TWRP is no longer an option for a lot of Samsung devices because devs do not update it anymore. Would have saved me a lot of hassle. I should have researched more myself before going ahead, but I am thinking about everyone else :slight_smile:

Something like:

BEFORE INSTALLING TWRP: make sure that TWRP for your model is properly maintained and up to date. If not, you will encounter an error and will need to run a recovery.

Anyone here with the proper knowledge on how to run a recovery if one is stuck in an Odin loop?

Please confirm is this Install /e/ on a Samsung Galaxy Tab S6 Lite (Wi-Fi) - “gta4xlwifi”. Please can you tell us what happens now if you try to install /e/ Recovery?

I just downloaded the firmware from SamMobile (free, but requires registration). I got out of the Odin boot loop and to the language screen now, so that’s good :slight_smile:

I used Odin v3 and the BL, AP and CSC_OMC_OXM files.

1 Like

Since I can’t use Odin and TWRP I have tried to make a package for Heimdall, but I cannot seem to get it right. I am not that technical and the instructions are not clear to me.

What does 1. Setup a MinGW-W64 build environment by utilising MSYS2: http://msys2.github.io/ mean? The explanation on the Github page makes no sense to me :thinking:

I think we need to up the clarity of the texts so anyone can do this. It was quite easy to get eOS up and running on my Mi10T.

I just wish /e/OS easy-installer worked for samsung tablets too.

What issue do you have with Odin and /e/ recovery?

You cannot use TWRP anymore as it results in an error and you get stuck in a boot loop. Just search a bit on the XDA forums. It is the case for several Samsung models, at least.

I am required to build a Heimdall package for Windows, but I cannot seem to do it, which is the only alternative I know of on Windows.

This is the reason I ask you about /e/ recovery which is linked on the page I first sent (unless you are using a different device, which is unconfirmed ! )

An (untested by me) Heimdall package for Windows is mentioned in LineageOS wiki, for instance this totally unrelated device Install LineageOS on beyond1lte | LineageOS Wiki

I have the S6 Lite (SM-P610).

TWRP for that unit is no longer updated and therefore results in a boot loop - so no use for Odin. I tried to build Heimdall myself, but was unsuccessful. I really do not understand what I am doing wrong.

Thanks! I will try the package and see if I can make it work :slight_smile:

No luck…

" Windows: Extract the Heimdall suite zip and take note of the new directory containing heimdall.exe. You can verify Heimdall is functioning by opening a Command Prompt or PowerShell in that directory and running heimdall version."

It does not manage to find Heimdall, even though i Ran PowerShell from the directory it is in :thinking:

I do not have a Windows machine to demonstrate this, but you are likely to need to:

cd /path/to/Heimdall
./ heimdall.exe

The ./ tells your PC to operate in this folder.

Follow @Marine she had give you the solution, TWRP is unfoundable OK but recovery-e


1 Like