[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

I failed to install /e/ on my S10e yesterday evening with this error.

I haven’t test your trick yet but I’m quite sure this will fix the problem. Many thanks for that!

@Anonyme May I suggest you amend your original post to add what @centaurus just mentionned for S10/S10e/S10+ devices? BTW many thanks for your very precious post!

I got the same error when trying to load without the vbmeta. Once I added the vmbeta file, the error went away.

Thank you very much for the help, this tutorial made it possible to install e/os/ after the easy installer failed on my Galaxy S9+ . However if someone runs into the same issue as me, I was not able to intsall the stable version with multiple different versions of TWPR. However what worked for me was to install the dev version on with an old version of TWRP (instead of the current twrp-3.7.0_9-0-star2lte.img.tar version fro my device , I used this version twrp-3.3.1-1-star2lte.img)

Excellent tutorial ! Thx mate :slight_smile: The easy installer was not working on my Samsung S9 SM-G960F. With this tutorial it went smooth as… (I don’t know what comes next, English is not my native tounge)

it says “in the “Options” tab (between “Log” and “Pit”) untick the “Auto-reboot” box.”, but I don’t even know where to look. in Android? in Download Mode? or in Odin? I cannot find an “options tab” in any of those places.


Other option is :
let the auto-reboot selected, click start,
Then hold ONLY the volume up bouton…
until the custom-recovery-manager logo (TWRP or recovery-e) appear on the phone.

thank you! but sadly, both don’t work, I never reach TWRP. with the method you described in your last post, also Android starts. with the method described in the original post (deselecting “auto-reboot” and sliding the finger from volume down to volume up while holding the two other buttons), my phone gets stuck in a screen just showing the logo “Samsung Galaxy S5 Neo”

I know how to reach this mode but this is no good right?


Unselect “auto-reboot” as it is recommanded, and click to start,
When “pass”, Unplug, extract the battery, reinsert the battery,
Then reboot by holdding volume up AND home AND power

with this method, again I’m stuck with the “Samsung Galaxy S5 neo” screen:(

do you try to install TWRP or the recovery-e ?
using Linux or Windows ?

Did you give up, or did you find a way?

I have done one 3-4 days ago… and I’m very impressed!
Great battery life!!

This is my TWRP and getting it into recovery mode is a bit of a hit and miss, unfortunately.
Needed 3 attempts right now, but hey it is worth it!

Also pleas note, you will get this warning on every boot, but you just click it away, it does not cause any problems.

[edit] in english

Does anybody know whether this works for Samsung S10?

TWRP or recovery-e ?
Linux or Windows ?

You may need to fash vbmeta along TWRP or recovery-e

In addition to the comment above, some users of this generation of phone have struggled with the more securely locked bootloader than earlier Samsungs. Be sure to additionally follow the preinstall instructions on the official install page https://doc.e.foundation/devices/beyond1lte/install and comments of documentation suggestions from other users Samsung - Galaxy S10 - beyond1lte - Documentation Suggestions.

Hello Piero,

reading all this I think I will give up, I love the eos but last time I had a phone which worked with the easy installer. I will try to get one again. I am not expert enough.

1 Like

Would it be possible to add to the guide that some smartphone (like newer Samsung Galaxy S10) do not work well with TWRP and thus we instead use the /e/ os or Lieneage recovery (that are available on each smartphone page as with OS installation zip).
This is not a problem for the OS installation as we can use the built-in functions of those recoveries to wipe the partitions and install the OS as with TWRP (either installing the OS .zip as an update or by using the sideload function, as with TWRP).
Your guide has been very uselful to some friends and I, so adding this detail will probably help some more people ! :slight_smile:

unfortunately not because the first post is not editable.
this one is :

Then tried to install TWRP using your method.
I get stuck at this part of the instructions.

If red error messages show up, your phone is probably encypted but TWRP can’t decrypt the /data partition (it’s a common issue on Samsung phones).

To solve that problem, go to Wipe > Advanced wipe, select “data”, click on “Repair or Change File System”, then on “Change filesystem”. Select exFAT (or another one if it doesn’t work, it doesn’t matter), then swipe from the left to the right. Redo the manipulation but this time select ext4 (which is the original file system) then slide from the left to the right.
Go to the 8)A)1. part of the howto.

I choose to format

On the screen it says

formatting data using mkexfat

but it keeps showing the blue moving bar and at the top of the screen at says formatting.
I am stuck in this screen now. Shut down phone and reinstalled TWRP. Now TWRP gets stuck at the starting screen.

Any help installing e/os is very much appreciated

Thank you very much

Which version of TWRP did you use? Did you install with ODIN?. By “starting screen” do you mean the screen before the starting screen (that is a “Splash screen” which is expected to be transient as TWRP loads) ?

Were you sure to remove all accounts from the phone before starting /e/OS install ?