[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

with this method, again I’m stuck with the “Samsung Galaxy S5 neo” screen:(

do you try to install TWRP or the recovery-e ?
using Linux or Windows ?

Did you give up, or did you find a way?

I have done one 3-4 days ago… and I’m very impressed!
Great battery life!!

This is my TWRP and getting it into recovery mode is a bit of a hit and miss, unfortunately.
Needed 3 attempts right now, but hey it is worth it!

Also pleas note, you will get this warning on every boot, but you just click it away, it does not cause any problems.

[edit] in english

Does anybody know whether this works for Samsung S10?

TWRP or recovery-e ?
Linux or Windows ?

You may need to fash vbmeta along TWRP or recovery-e

In addition to the comment above, some users of this generation of phone have struggled with the more securely locked bootloader than earlier Samsungs. Be sure to additionally follow the preinstall instructions on the official install page https://doc.e.foundation/devices/beyond1lte/install and comments of documentation suggestions from other users Samsung - Galaxy S10 - beyond1lte - Documentation Suggestions.

Hello Piero,

reading all this I think I will give up, I love the eos but last time I had a phone which worked with the easy installer. I will try to get one again. I am not expert enough.

1 Like

Would it be possible to add to the guide that some smartphone (like newer Samsung Galaxy S10) do not work well with TWRP and thus we instead use the /e/ os or Lieneage recovery (that are available on each smartphone page as with OS installation zip).
This is not a problem for the OS installation as we can use the built-in functions of those recoveries to wipe the partitions and install the OS as with TWRP (either installing the OS .zip as an update or by using the sideload function, as with TWRP).
Your guide has been very uselful to some friends and I, so adding this detail will probably help some more people ! :slight_smile:

unfortunately not because the first post is not editable.
this one is :

1 Like

Then tried to install TWRP using your method.
I get stuck at this part of the instructions.

If red error messages show up, your phone is probably encypted but TWRP can’t decrypt the /data partition (it’s a common issue on Samsung phones).

To solve that problem, go to Wipe > Advanced wipe, select “data”, click on “Repair or Change File System”, then on “Change filesystem”. Select exFAT (or another one if it doesn’t work, it doesn’t matter), then swipe from the left to the right. Redo the manipulation but this time select ext4 (which is the original file system) then slide from the left to the right.
Go to the 8)A)1. part of the howto.

I choose to format

On the screen it says

formatting data using mkexfat

but it keeps showing the blue moving bar and at the top of the screen at says formatting.
I am stuck in this screen now. Shut down phone and reinstalled TWRP. Now TWRP gets stuck at the starting screen.

Any help installing e/os is very much appreciated

Thank you very much

Which version of TWRP did you use? Did you install with ODIN?. By “starting screen” do you mean the screen before the starting screen (that is a “Splash screen” which is expected to be transient as TWRP loads) ?

Were you sure to remove all accounts from the phone before starting /e/OS install ?

TWRP 3.7.0_9-1
Yes installed with Odin. Everything went fine. Rebooted in TWRP. Did the advanced wipe as mentioned in the link. During the formatting process something seems to have gone wrong. Now I am stuck in the teamwin screen with the blue circle with the arrows. So yes the splash screen.

Yep all account were removed.

So you are in the situation where this job is incomplete.

Tbh I do not know if this can influence failure of TWRP to load, but I would try Odin to flash perhaps an earlier version of TWRP, then the most recent (again) in order to get back and finish the formatting job.

A detail you mention is

On the screen it says
formatting data using mkexfat

but it keeps showing the blue moving bar

I would believe “done”, the persisting animation I would be less concerned about.

Just a thought, should you find yourself in that situation again, be sure to use the “Back” buttons under the TWRP screen.

Thank you for the advise. I did not see a back button. Guess I had to use back button on the phone but was not familiar with this phone. Found out later the touch buttons ;-). Was stuck although it said formatting done.

@piero I use Windows. I gave up in June, now I want to try again but in the meantime the S5 Neo dissappeared from the devices list: https://doc.e.foundation/devices . so I will have to try installing another OS now?

@make-nz darf ich fragen wo Du wohnst und ob Du mir persönlich helfen kannst oder zufällig jemanden kennst?:slight_smile:

It is just masqued by default has it has been dropped like all devices stucked on android “Q”.
You must enable " legacy devices" (at the bottom) in the search options :

Last Official build :


However our loved build maniac @ronnz98 have shared an Up to Date “R” based /e/OS version :

[UNOFFICIAL BUILD] Samsung Galaxy S5 (s5neolte) - #7 by ronnz98

1 Like

Please help me. Odin is not recognising my phone.

More information required.

Please can you tell us if you accomplished everything before this point – or was anything not as expected?

Have you done and double checked everything in the quoted passage?

Thank you soooo much for your “HowTo”! EasyInstaller didn’t work. But your instructions did! Thank you for your effort!!!

1 Like