[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

Thanks, Anonyme!

My phone is on Nougat indeed. Will read a bit further. Or wait for the automated tools by e-people.

This (almost) worked. In Odin options I deselected “Auto reboot”. Then after Odin had done its magic, I unplugged my phone, pressed Power+VolDown+Home and when screen turned black changed VolDown to VolUp --> entered TWRP.

Have now E up and running, great result. Thanks again!

2 Likes

This ‘how to’ is just great! I would have not been able to flash the device without it! Thanks a lot for it!
I got the error 7 as well which makes updates a bit more complicated because I can’t do it from the mobile. I need to download it on a desktop, change the file that needs to be changeds and zip again the whole thing before copy/pasting in the internal storage… Same for you @Anonyme or did you find a way to go around this on the mobile itself?

The version of TWRP for my device in the official website wasn’t updated for 2 years, that’s why the error 7 occurred.

I found this repo with recent version of TWRP that work great with my device, no error 7 anymore.

1 Like

Hello, good topic but i’m trying to install /e/ on my samsung galaxy s6 and the download link “primary (europe)” doesn’t work in TWRP (https://twrp.me/Devices/Samsung/). Do you have an idea to fix it ? (choose (Americas) that works ? )
Thanks.

and now… it works ! the link is back ! great !

Hi there, I have a Samsung SIII, i9300 the international version, I have managed up to the point where I have installed TWRP and wipe what is here described. Then I have copied the right zip file ( [e-0.6-n-2019061613637-dev-i9300.zip] ) to a sd card. The card is recognized by TWRP as an external_sd card. The problem is that when I try to install it I get the error 7. From the link I tried to edit the script in the zip file and tried to install again but I always get new errors (not the error 7 but for example error 6 or others) in TWRP. Any suggestions are welcome.

Hello.

Thanks for the documentation which really helped me into getting /e/.
Based on the different tips I managed to get until the end of step 7 and the installation of /e/ (I get an error 7 which I bypassed).

Unfortunatelly when I restart the device on system I’m stuck on “Samsung Galaxy J7” white screen.
I got no error and I have not found yet how to debug it.
I have a Samsung Galaxy J7 SM-J730F/DS which is not exactly the model supported but the processor is the same Galaxy J7 SM-J700.

Have you any idea of what can be the issue or how I can troubleshoot ?

Hi @jean78 if it is not on the supported list chances are the build will not work. You may get it to install but the OS would throw up weird errors. At worst a mismatched ROM can brick your phone. You have already added a request for a device - the more the users requesting for support the better the chances of a build for this phone.

@Anonyme thank you so much for your turotial, I succeeded installing /e/ and I feel so happy now!

@anyone;
But now new challenges arise… I followed the steps, including to select the option NOT to install TWRP after flashing the device. However, after installing /e/ a system-update is being offered and I get a message;

Apply update

you are about to upgrade to /e/OS 0.7 - 24 Jan 2020.

If you press OK, the device will restart itself in recovery mode to install the update.

Note: This feature requires a compatible Recovery or updates will need to be installed manually.

When I press OK my device will reboot, but I enter in TWRP menu again. So it seems TWRP is installed, after selecting “do not install”.

My question is;
*is there a possibility to remove TWRP from my device?
*is it safe to remove TWRP from my device?
*how can I install the system-update?

I have to admit I allready tried some ideas myself, for example;
*after being in the TWRP menu I noticed the e-xxx-xxx-xx.zip-file is still there, so I choose to remove the .zip file and the TWRP-directory which where installed and used in the flashing proces.

*have I screwed up when doing this experiment?

thank you

How can I uninstall or remove TWRP from my device?

For the vast majority of devices, you don’t actually remove TWRP to get back to the stock recovery. Installing a different recovery is your only real option. Simply install whatever recovery that you want and that will overwrite or replace TWRP. Usually you can follow the instructions on our website for installing TWRP manually, only use the file for whatever recovery you are choosing to install instead of the TWRP file.

Note, we don’t keep or maintain a database of stock recoveries. If you are trying to reinstall the stock recovery, you will have to find a copy of the stock recovery on your own.

1 Like

my apologies

I found a post precisely answering my questions on this forum in the link below. (also by @Anonyme) @archje thank you for your quick response. Hopefully I keep learning everyday, for a long time to come. :mortar_board:

I want to thank everybody involved and contributing with the /e/ project. You are making my day.

1 Like

I’m hoping someone can guide me around a problem I have come up against, while preparing my Samsung Galaxy III International i5300 phone for flashing with /e/ OS. I have never flashed a phone before, and this phone is only being used as a music player at the moment as I upgraded last year to a Motorola G7.

I am using Anonyme’s very clear instructions “[HOWTO] Install /e/ on a Samsung smartphone with Windows easily” as my knowledge of command- line is sketchy. I realise the phone he has flashed is not the same as my phone, but this phone is on the list of supported devices.

I didn’t get very far… When I came to “3) OEM Unlock” it was missing, so I followed the instructions to activate Developer Options [it was already activated], then looked again but OEM Unlock still wasn’t in Developer Options.

I then attempted to update Android; I unchecked Automatic Date and Time/ changed the date on the phone to 10 days in the past, looked for ‘Auto Update System’ [not there], found ‘Software Update/ Auto Updates’ and unchecked it, tapped on ‘Update’, got the message “latest updates already installed”.

Next I rebooted the phone and turned on ‘automatic date and time’ again; restarted the phone and check to see if OEM Unlock had magically appeared; still not there.

I then did a Factory Reset to see if that changed anything. The Android version is still 4.3 as before.
Where do I go from here? I’m thinking I should save up for one of the refurbished phones with /e/ already installed, anyone think of something else I can try?

If you mean this Samsung Galaxy S III (International) - “i9300” then please read on here …

So far I have avoided Samsung phones, because the instructions seemed to require building “Heimdall” on Windows (build “not available”?) I could set up a Linux PC just for Heimdall, but overall this is all very confusing.

Is there a problem with installing Odin instead, and why is it not mentioned in the official instructions? Thanks!

There is no difference in the final resulat. Both methods will install TWRP on your Samsung phone.

It’s true it’s not mentioned directly in the installation page of Samsung devices, maybe it should since this HOWTO seems safe a tested by many users.

No, I don’t know any problems of this kind: Wind°ws and “Odin 3” fit together as well as Linux and “Heimdall”.

The majority of “professionals” especially software developers use a Linux derivate and have already given up using Wind°ws a long time ago. Wind°ws is as reluctant to be put into the mouth as G°°gle. So tools are primarily mentioned on Linux basis. They simply “forget” that 3/4 of the “normal” desktop PC / notebook users work with Wind°ws as operating system. An effective Wind°ws tool is Samfirm, a fast free downloader of Samsung Android firmware.

I belong to the Wind°owsers of the first hour. My W°Systems are largely “closed”, so that it can only rarely “phone home”

Good point. Will have a reference to installing Odin also added to the official /e/ documentation.

That’s brilliant. I remember when checking out /e/ for the first time the Samsung instructions looked like a big hurdle, so I only looked at Motorola. Samsung being the most ubiquitous models, it should be as easy as possible for Windows users.

Hello, I installed a Samsung S9 via this method. Worked like a charm and today I tried my luck on the Galaxy S7. No luck this time. I bricked it twice but via Odin I could bring it back to the original Samsung installation. The problem actually was not Windows or Odin related but the phone seemed to be encrypted. In case of wiping as written in the article do this:

Boot into TWRP after the upload to the phone

Choose the button “Keep Read Only” It seems to me that the Galaxy S7 had encryption on by default.

Choose the “Wipe” button

Choose “Format Data”

Type: “yes” and now everything is wiped off the phone

Reboot into Recovery and choose “Do not install”

Choose “Keep Read Only”

Now you can go on with the installation of /e/

Everything went well