[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

I’m tellin’ ya brothers and sisters, fate has something else in store for me. My collection of phones just don’t conform. I checked the Bootloader and its not one of the two needed for this untested install. See below:

WARNING: Your device must be on bootloader version I337UCUAMDB / I337UCUAMDL , otherwise the instructions found in this page will not work.
My Device Bootloader = I337UCSGOK3 - so won’t work.

One of these days something will go right. Until then I have a fabulous collection of useless Samsung phones! :wink:

I appreciate the fantastic helpful spirit of the eOS community.
Ells

Can you tell if jflteatt is correct?

If you are on
I337 UCS GOK3
You can easily downdate to
I337 UCU AMDB
with Odin
https://samfrew.com/download/GALAXY__S4__/r650/ATT/I337UCUAMDB/I337ATTAMDB/

Because retrodating was not blocked on this device generation

.

1 Like

piero, DL the appropriate boot loader from Samsung. Followed their directions, and it failed in Odin just like TWRP.

I think Samsung wins - I lose the S4 wars. I certainly do not know where to go from here. The phone is clearly unlocked as my RedPocket acct recognizes it and developer options is set for ADB debugging. Its at the Odin/Heimdall stage that it fails every time as shown in the uploaded screen grab.

Have you tried the nanderase option ?

Hi, Ells, if you ever stop for a bit of reflection I wonder how you see your position compared to this user:

I have chosen a rather random point to break into a long unresolved thread :slightly_smiling_face:

Any point in this saga is random so its all good to me. Point about Nanderase above, yes I checked that option and retried and it did some stuff I do not know about and then just seemed to be done with no Fail or Success. So I tried running Odin again with Nanderase unchecked and it failed immediately. Not sure about what anything actually means or does. One note though reading through this other thread about the S9 - It brings up clearing all traces of ownership accts. I have searched high and low on the phone for how to even sign out of my alias Google acct and then there is an ATT contacts acct that I also do not know how to remove. Would these accts be the source of the failure? How do I eliminate them?

The rule of thumb is “remove all accounts” so if ATT appears to have some sort of prior claim on the device, that would be bad.

I definitely think it is worth further research how to remove them, because it is not clear ATT is claiming an account, as owner, is it?

Anything that exists in accounts, would be a blocker from what I understand.

It would trigger Factory Reset Protection. I cannot remember if you tried, but what happens when you do a Factory Reset from within Settings >> System ?

You might look at the Download mode screen, any clues there, you could perhaps send an image if in doubt.

Here is the fail screen in Odin failing with Nanderase checked.

Hi!
When I try to download both e-0.16-o-20210505112607-dev-herolte.zip and twrp-3.5.2_9-0-herolte.img.tar for my Samsung Galaxy S7, both downloads fail the SHA 256 checksum. Can someone explain either if I am doing this wrong, or how to proceed? I am on Windows 10 and running the following commands in command prompt:
SHA256 hash of C:\...etc
Thank you so much!

Hi @a.txteditor, welcome.

It took me more than 5 minutes to find out how to do this easy job on Windows 10. Here is an answers.microsoft link.

If that does not seem to work, try to post the error, perhaps. :slight_smile:

1 Like

Hello!
Thanks for the welcome and response! I actually successfully got the checksum values for both (following the same steps recommended on the link you provided) and the problem is that the values do not match. They have to match, right? So I am not sure if there is a problem with the checksum, or something else?

So for example here were my results (I’ve removed the path information):
SHA256 hash of C:…\twrp-3.5.2_9-0-herolte.img.tar:
e24c8a9437021db58ff09b4d8f321b0a787baa37725e7771781dc5ce6f6af291
CertUtil: -hashfile command completed successfully.

SHA256 hash of C:\...\twrp-3.5.2_9-0-herolte.img.tar.sha256:
a9e39c4688ad6d1c8e03e54d747e7389627c55510de39bf7b830db1307d59e8f
CertUtil: -hashfile command completed successfully.

And then I had the same issue for the e-0.16-o-20210505112607-dev-herolte.zip file.

Perhaps your method is wrong, :slight_smile: try to compare what you are doing with this example in Linux:

chimp@laptop $:sha256sum e-0.14-o-2021012798648-dev-a3xeltexx.zip
53af25b3d07652ddf386a56b90d0962942234df073cb528668df63e41de06636 e-0.14-o-2021012798648-dev-a3xeltexx.zip

chimp@laptop $:cat e-0.14-o-2021012798648-dev-a3xeltexx.zip.sha256sum
53af25b3d07652ddf386a56b90d0962942234df073cb528668df63e41de06636 e-0.14-o-2021012798648-dev-a3xeltexx.zip

I run the sha256sum command against the “file”.zip

Then I expect to get same string returned by cat “file”.zip.sha256sum.

cat reveals the text contents of the “file”.zip.sha256sum

You will find you could alternatively open the “file”.zip.sha256sum in a notepad editor to reveal its contents.

3 Likes

Hi! Oh my god thank you so much for taking the time to explain this and work through this with me. You are so right, I had the whole process mixed up. Now they have passed and everything looks good. On to the next steps.

Again, thank you very much!

Edit: IT WORKED!!! /E/ OS IS UP AND RUNNING <3 Thank you and @Anonyme so much.

Hi, I am absolutely not a tech-specialist and I was a bit scared of the “conversion”. But thanks to your super great description everything worked. Thank you very much for that. :pray: :nerd_face:

Thanks for this @aibd !

Hi there my samsung is a galaxy S9 smG96F im not sure which twrp file to get

First you must search TWRP Devices for the exact correct name for your device.

Usually the latest version is the best for an up to date phone. If there is no change in Android version involved in your install, that is, your phone is already on 10 and you plan to install /e/ Q, please be sure to apply any OTA manufactures updates before you proceed.

ok so first i need to find what version of software is on it ?

okay on this S9 which im using as my second phone until i learn how to get this installed properly was last updated in may 2020, so what do i need to do next