[HOWTO] Install TWRP

Working ADB and Fastboot
Developer options enabled
Unlock bootloader
On your computer type:
adb reboot bootloader

Your phone/device should now be in fastboot mode.

Download the correct TWRP image file search here and copy the file into the same folder as your adb and fastboot binaries on your computer. Rename the just downloaded TWRP image to twrp.img.

On your computer type:
fastboot flash recovery twrp.img
fastboot reboot

Note many devices will replace your custom recovery automatically during first boot. To prevent this, use DuckDuckGo to find the proper key combo to enter recovery. After typing fastboot reboot on your computer, hold the key combo on your device/phone and boot to TWRP. Once TWRP is booted, TWRP will patch the stock ROM to prevent the stock ROM from replacing TWRP. If you don’t follow this step, you will have to repeat the install.


this is really useful for all the tech newbies !

Doesn’t work for me, here is what I get:

fastboot flash recovery ./twrp.img
target reported max download size of 534773760 bytes
Sending 'recovery' (29486 KB)...
OKAY [  0.893s]
Writing 'recovery'...
FAILED (remote: partition table doesn't exist)
Finished. Total time: 0.974s

(534773760 B = 492754 KB >> 29486 KB )

I can boot into /e/ after locking everything up…

The HOWTO on https://twrp.me/fairphone/fairphone3.html from the TWRP people is quite different.
This HOWTO looks more quite straight-forward so I tried this.
What am I doing wrong here?

When I do the other HOWTO at the step “fix recovery bootloop” I get an “Error patching kernel.”

The HowTo in this topic here doesn’t apply to A/B devices like the Fairphone 3, since they have no recovery partition and work differently.

Stick to https://twrp.me/fairphone/fairphone3.html.

I can’t help with the error message, unfortunately, because I don’t install TWRP, I just boot it when I need it.
At least until somebody confirms that altering the boot partition, as installing TWRP on the Fairphone 3 does, doesn’t break /e/ OTA updates. (Altering the boot partition does break Fairphone OS OTA updates, so better safe than sorry.)


Alright, thanks a lot!

Hi there,

I got stuck during my installation process because the american server of twrp.me was down: Wrong TWRP link for Lenovo YTX703 (docs update request)

This is not so much of a problem, just wait one day.
I searched a lot and actually found this wiki-entry.

A problem is, that I found out, that not all TWRP images might fit for the current version of Android/LineageOS and therefore /e/OS. (I don’t have a link anymore, but it said that TWRP 3.5.1 supported more the newer versions of Android while TWRP 3.3.x the older versions.) You see that I am a newbie…
You are more experts to decide whether a hint on the version of a TWRP image might matter.

And last, but not least: your note:

Once TWRP is booted, TWRP will patch the stock ROM to prevent the stock ROM from replacing TWRP. If you don’t follow this step, you will have to repeat the install.

should be more prominent. I did not find this valuable piece of information anywhere else and - as a newbie - I was not quite sure if I did everything necessary to prevent the stock ROM from replacing TWRP.

Thanks for the entry in any case.

1 Like

If a reboot to recovery gives the stock recovery, then TWRP is not installed.
In this case you’ll have to retry the installation, including the “key combo” reboot.
After that, if you can reboot straight to TWRP using key combo or power menu or ADB command, then you’re good to go :slight_smile:

Has anybody succeeded in having TWRP and Magisk installed in the FP3? I have failed so far various times. After following topjohnwus installation instruction, twrp was gone afterward. And after installing twrp, Magisk and root were gone. Any hints?

you have to extract the boot.img from the /e/.zip,
patch it with the magisk app,
and flash the patched boot.img on the device, alone using TWRP,
or replace it in the /e/.zip and flash the modified /e/.zip using TWRP.

Hi Piero,
thanks for your reply. Have you tried this method successfully yourself or is this just a conjecture of yours?

It is the official method !

But each time you will overwrite the /boot partition with other things than the “current magisk patched /e/ boot.img”, you will lose its benefits.

I have finally managed to have both TWRP and Magisk running.

  1. I have patched the TWRP.img with Magisk, but got stuck with bootloops to the bootloader, not even to the TWRP recovery.
  2. I have booted with fastboot into TWRP and tried to install TWRP - after having installed Magisk. But after that Magisk and root were GONE.
  3. I followed the offical instruction to the letter now (having overlooked previously to navigate to the Advanced > Install Recovery Ramdisk option.)
  4. I then installed Magisk23.apk using TWRP, although this is the deprecated method

Has anyone tried this on a Moto G7 Plus successfully?

hello all, first post here :wink:

well, i’m a bit losy with twrp with FP2
(after a homeric fight to install the drivers on fastboot mode, the solution was as ever - under the hand - just beside the securite glass… hahahaha )

there’s many version of twrp, found here and there on the net…
on the dowload page of /e/
next to the e-0.18rxxx.img => recovery-e-0.18-r-20210831132813-dev-FP2 ??

  • what is that recovery.stuff (important, or just a funny way to lose newbies as i :wink: )

here above => me.twrp.twrpapp-26.apk (i have installed it as an app (apk oblige))

and => twrp-3.5.2_9-0-FP2.img (found on twrp website, last version for FP2)

then, what do i have to follow, and the trwp to use ???

thank’s a lot


/e/ recovery is simple, but enough anyway to flash your device.
TWRP is more powerfull, always get it from TWRP web site and follow their install guide carefully (Fairphone 2 , Fastboot method).

APK is useless, you can drop it into your trashcan :wink:

1 Like

yep, nice answer… i was blocked on these three equivalent solution

then i continue with twrp-3.5.2_9-0-FP2.img

thanks a lot

Important for automatic update compatibility
and simply basic.

But it only manage .ZIP, not .IMG, ( .TAR ? )
it don’t backup, don’t wipe /partitions, just format /data including internal storage, don’t have root file-manager …

eelo all :wink:
it’s done since this mornig… i’m on eelo or just /e/ ??

i finaly went onto with this howto(in french, easiest for me)

there is a video, that allow me to understand (with less fair) the last step (backup, wipe and install)

Today I wanted to update the OS to 1.1. But that went wrong. After downloading the OTA, the updater proceeded to install the update, but on the way the updater app crashed. There was no way to complete the installation. I tried a reboot and after that the update was unexpectedly completed and Magisk and TWRP were gone. The phone is now on 1.1-20220705201319. I’ve tried to get Magisk back and TWRP, but: every time I installed Magisk out of TWRP, TWRP was gone. And every time I installed TWRP, Magisk was gone afterward. Does anybody know a proven method to install BOTH Magisk and TWRP on the FP3?

Hi, I couldn’t find twrp for redmi note 9 pro (joyeuse). Are there any alternatives for twrp to use with eos?