Howto troubleshoot issues with the easy-installer

General hints

If your problem is not mentioned in this topic, maybe you can find something in the official Installer FAQ.

Please specify operating system and phone model

In case you ask for help, please specify which operating system you are using on the computer running the installer and which exact phone model you try to install on (e.g. FP3 or FP3+ or …). Please also specify the current major Android version on your phone (e.g. Android 10, 11, …).

Where to find the log

The installer creates a log file with a randomly generated name (e.g. 45761d08-711f-435a-881d-a236949654bb.log) that might contain useful information if something doesn’t work as expected.

Location of the log file:

  • Linux: ~/snap/easy-installer/common
  • Windows: %LOCALAPPDATA%\easy-installer
    • if you don’t know how to open this location, press the Windows key plus the “r” key at the same time and paste %LOCALAPPDATA%\easy-installer into the box that appears, then hit the Enter key)
  • Mac OS: we still need a Mac user to confirm, but the log on Mac should be in one of those two folders
    • /tmp/easy-installer
    • the bin subfolder of the path the application gets installed to on Mac OS

The log file is too large to upload to the forum directly. If you report a problem, please paste the contents of the logfile to and click the save icon there which will generate a link which you can then use here.

If the log is too large even for haste and you already have an /e/ account, you can ZIP the log and upload it to your /e/ account cloud storage.

Problems running the installer

If the installer just doesn’t start as if nothing happens (on Linux)

If you click on the easy-installer icon and nothing happens at all, please open a terminal and execute

snap run easy-installer

This will likely generate some error output you can check against the known issues below.

Unable to open DISPLAY (on Linux)

This happens when the installer is run on wayland. It should work in an xorg session. See: Running Easy Installer on Linux

To check what kind of session you are running, execute the following in a terminal: loginctl show-session ID -p Type

The full error looks like this:

    Exception in thread "main" java.lang.reflect.InvocationTargetException
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.base/java.lang.reflect.Method.invoke(Unknown Source)
	at java.base/sun.launcher.LauncherHelper$FXHelper.main(Unknown Source)
Caused by: java.lang.UnsupportedOperationException: Unable to open DISPLAY
	at$new$6(Unknown Source)
	at java.base/ Method)
	at<init>(Unknown Source)
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)
	... 5 more

Internal Error (on Linux)

This so far only happened with version v0.12.0-beta and is fixed in v0.12.1-beta, so just upgrade your installer via:

snap refresh easy-installer --channel=latest/beta

You may have to prepend sudo to the command above.

Full error is

Exception in thread “main” java.lang.reflect.InvocationTargetException
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at java.base/sun.launcher.LauncherHelper$FXHelper.main(Unknown Source)
Caused by: java.lang.UnsupportedOperationException: Internal Error
at$new$6(Unknown Source)
at java.base/ Method)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
… 5 more

Installer hangs after unlock instructions in “Start device in Fastboot mode” (on Windows)

If detection of the phone in fastboot mode fails on Windows (also when a manual fastboot devices doesn’t see the phone) you might have to install extra drivers.

For detailed instructions (incl. Screenshots) see [HOWTO] Fairphone 3/3+ stuck in fastboot/bootloader mode with the Easy Installer on Windows or FP3+ no USB conection via fastboot, unlocking bootloader not possible - #6 by andrelam

The installer does not start the download (on Mac)

We had reports that on Mac the installer doesn’t download the install image, e.g. Easy installer does not start download latest or FF3+ - Easy Installer (Mac Version) failed downloading

The best hint so far is to move the .app to the Programs folder as Mac OS restricts apps residing in the Downloads folder.

If you run into the same problem on Mac, please help us out by trying the steps in this post.

Phone is not detected when using the easy-installer inside a virtual machine

At the time of writing, the easy-installer does not support MacOS yet so people with an Apple computer may try to use the installer inside a VM.

At least for VirtualBox it is important to attach the connected phone to the VM both when the phone is booted normally and also when it is in fastboot/bootloader mode.

More details can be found in How to pass "rebooting in bootloader mode" in Easy Installer - #24 by underdog

Problems installing or compiling the installer

Jlink complains about unexpected hash (Arch Linux)

When installing the AUR package on Arch Linux you might run into

Task :jlink FAILED
Error: Hash of java.xml (4b805321762bc6762fabcde937d39fbc32cbfb19ab44bcf5cd6dd69a83960a9e) differs to expected hash (91ebb0c25713aacebb2071a372e7a358ef31f69f265094464d3e2e81dcce553a) recorded in java.base

A fix is described in aur: fix jlink error during build (!167) · Merge requests · e / devices / Easy Installer · GitLab

You need to edit the pkg/arch/PKGBUILD file to use the Java version bundled with the easy-installer instead of the Java version installed in the OS.

$JAVA_HOME not set

To compile the easy-installer the $JAVA_HOME environment variable needs to be set. See Can't compile easy installer

The error message is not very helpful in this case, it just outputs the following:

./gradlew dist


> Task :prepareMergedJarsDir FAILED
:prepareMergedJarsDir (Thread[Task worker for ':',5,main]) completed. Took 0.0 secs.

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':prepareMergedJarsDir'.
> No value has been specified for this provider.

To see a more detailed compile log, execute

./gradlew dist --debug --stacktrace

Running in IntelliJ: JavaFXPlugin has been compiled by a more recent version of the Java Runtime

The full error message is

Cause: org/openjfx/gradle/JavaFXPlugin has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0

This can be fixed by selecting a JDK with version 11 as “Gradle JVM” in the IntelliJ settings:

By default, IntelliJ uses a bundled JVM which is not new enough.

Easy Installer on Win 10 w/ FP3+ : device not detected
Easy installer - "continue" button not visible
Easy Installer failed - Fairphone 3 blocked on fastboot mode
The /e/OS Easy Installer now supports the FP3 & FP3+, and its contributor tells us all about it
Easy Install on S7 G930F | Android Debug?
Help! Easy-installer process interrupted - how do I continue?
Installation /e/os/ sur Fairphone 4 via macOS : impossible de passer en recovery
Easy installer does not start download latest
No "continue" button on first screen
Easy-installer failed on samsung S9
Install /e/OS on Samsung S8 SF-G950F
Easy Installer Samsung Galaxy S9 no Teamwin
Easy Installer issue : Teracube Emerald not recognised
Easy Installer on MacOS not able to download latest file
Easy Installer auf Pixel 4a 5G hängt fest
No new Easy Installer instructions/steps after 'Do not install' TWRP
Easy installer incorrectly reports /e/OS compatibility
FF3+ - Easy Installer (Mac Version) failed downloading
Error while installing e os installer in arch linux
Drivers for s9 plus on windows 7?
Install easy-installer on Fedora
Installing /e/ on Fairphone 2
Fix for: stuck during installation when you are in Fastboot mode
Installation auf Fairphone3+ lässt sich mit easy-installer nicht fortführen
Need help using easy-installer with S6
Newbie having problems with installing on Samsung S7, device is not found
Easy-Install not working on Ubuntu
Can’t find 'Keep Read Only' with Galaxy S9 (with Easy Installer)
/e/ easy installer Samsung Galaxy S7 no TEAMWIN? Help please
GS290 easy-installer stops
FP3+ easy installer just stops
Stuck on fastboot flashing unlock(Now Black screen)
GS290 easy-installer stops
Install /e/ on Gigaset GS290, Windows, using Easy Installer success second pass
[SOLVED] Gigaset GS290 + Windows 10 + Easy installer = Local file cannot be found (recovery-e-lastest-gs290.img)
How to pass "rebooting in bootloader mode" in Easy Installer
GS290 easy-installer stops
Black screen, don't start
Stuck with "could not unpack /e/ install archive" Easy-installer - FP3 - Windows - fastboot/bootloader
Installation Easy-Installer Galaxy S9+ - support needed
Fairphone 3 and /e/OS
Gigaset 290 (GS290-not preinstalled /e/) Bricked
Pixel 4A, impossible de unlock OEM
How to root/ flash samsung s7
Easy Installer does not work on Windows 10
E OS auf Fairphone 3 installieren
Installation issues using easyinstaller with Samsung S8
[LIST] Devices working with the Easy Installer
Galaxy S7 new installation with easyinstaller on MacOS stuck at download step
Feedback installing easy-installer on Debian 10/GNU Linux
Hung installation on Samsung S9+
Easy Installer bleibt stehen
Fairphone stuck in unlocked boot loader & easy installer crashed
Samsung s9 install e/os with easy installer failed
Hilfe für FP3+ gesucht nach abgebrochener Installation
Share your Questions about the Easy Installer
Easy installer does not find GS290
Easy Installer: Local File not found
/e/ installé avec easy installer sur GS290... le téléphone ne démarre plus
Encryption unsuccessful / Galaxy 9+
Internal storage not shown in files app
/e/ installation on galaxy s9 plus can't get into Teamwin
Installation of e/OS fails on Samsung S9 DualSim
Installation issue with Easy Installer for Teracube 2e
Teracube stuck in recovery
Easy Installer stuck while "wait for bootloader to restart" process
Problem installin /e/ os on fairphone 3
Easy Installer - Cannot download
Easy Intall hanging! Please help
Help! In the middle of installation
GS290 now a brick after running through /e/ easy installer
Unable to start TWRP on Samsung S8
Teracube stuck in bootloader while flashing easy installer

when will be the next /e/installer release ?

Edit : i mean with more devices

The easy installer is open for developers from the community to update. If there are users who would want to upgrade the Easy Installer they are welcome to modify the code.

The documentation to get someone started adding new devices is at:

If you want a rough breakdown of the steps involved, see

Just updates my FP3 from and. 9 to and. 10 using Easy Installer on Manjaro linux. Superb.
Lots off data is stored on /e/cloud, perfect for me.

Thanks a lot!

1 Like

The missing driver seem to be a frequent error. Do you see a possibility to include a mention of this in your howto? There are multiple ways of solving it (different drivers). No idea which one is the best practice.

Well, there is already one entry about missing drivers what do you think is missing there (except the full solution which is so long I’d rather not include it here but point to the existing post with all the details and screenshots)?

My idea behind the existing entries of this troubleshooting document was to describe the situation people might find themselves in and then give hints how to solve it or at least where to find more information.

Talking about “missing drivers”: I probably missed some people’s issues but the ones I remember should be covered by the " Installer hangs after unlock instructions in “Start device in Fastboot mode” (on Windows)" section.
If someone writes a Howto install necessary drivers in Windows I’d happily link it from here if the existing one is not sufficient (I found it to be helpful in the situation where fastboot cannot detect the phone).

Sorry, I didn’t see the section. Adding a screenshot to the section of the moment where easy-installer hangs would increase visibility.

1 Like

Bonjour Piero,
excusez-moi de passer par ici, mais je ne savais comment vous contacter.
Je suis un Finistérien de 67 ans qui boycotte les GAFAM.
Mon ordi est sous Linux Mint. Je ne connaissais pas l’existence de /e/ quans j’ai acheté mon FP3 chez Orange.
Je voudrais donc installer /e/ mais je n’y arrive pas. J’ai installé Easy installer et suivi toutes les procédures jusqu’à l’étape “transfert de fichiers” comprise, mais ensuite easy installer ne trouve pas mon téléphone. Il semble quela procédure de déblocage du bootloader ne marche pas, pourtant je suis la procédure décrite sur le site de Fairphone, avec le code de déblocage". Rien, j’ai essayé +eurs fois.
J’ai passé près de 6h à m’acharner sur ce machin et je ne sais plus quoi faire. L’aide de Ingo FP Angel ne m’a pas permis d’avancer.
Pouvez-vous quelquechose pour moi?

1 Like

Can someone please add an topic or a point out an emergency case when a phone get bricked.

Gigaset 290 (Android 9)
Fedora 33 (unstable)

1 Like

This kind of post, above, is very significant for me -actually it’s a reason to buy straight on /e/ here a Fairphone with /e/ preinstalled
Let’s hope the new model they mysteriously announce on Fairphone (FP4? Tablet?) will be also available here with /e/ preinstalled…
( @yguignot dans quelle région de France êtes-vous?)

Hello Herve5,
I live in Finistere.
My FP3 works well now with the latest version of “e” (0.17)
The only remaining problem is for transferring my agenda from my computer to my phone. I have issues with my “e” cloud account. Doesn’t work, can’t get a new password. Its a problem I put aside as “I had other fish to fry”, but I’ll try again when I can.

1 Like

Hi savers of the good cause,
The “Easy Installer” app running on Ubuntu does not continue the installation process on Galaxy S9 (MS-G960F) It waits after tapping “keep read only”
After having clicked on “keep read only” the TWRP is loaded and is showing its menu starting with “INSTALL” and 7 other functions like “BOOT” and “BACKUP” etc. The Easy installer has no continue button and does not give any instructions about what to do next. The only possible thing to do is to close de app by clicking on de cross on the top right of the window. Here is the log:

P.S. There was an other thing not possible further up in the installation process: in the android version 10 that came with the phone, it was not possible to : Disable “Auto download over Wi-Fi”. In “Settings” → “Software update” there is only “Download and install” and “Last update” info

Thank you for clearing this out, if possible. I am now back to be forced to be marred with google.

Hi @encantades your log just shows all going well, then “waiting for recovery”.

What is odd about your story is that the “Keep Read Only” button should be a “get me out of here” call to TWRP. At this point you leave TWRP, a signal is sent to Easy Installer, which it picks straight up, the “Continue” button lights up and the process continues.

Easy Installer is fine at starting again. Every step is checked and verified; any completed downloads are checked as up to date, and the install should pick up in the correct place.

From what we see TWRP is already installed, so the hard bit is done!

Did you navigate out of TWRP ok? If you keep hitting the back button you will arrive at a TWRP Home screen with “Install” at top left and “Reboot” bottom Right. Tap Reboot > System to return to System. In the event System is now missing, the device will return to TWRP.

When running Easy Installer in this state, use Reboot to mimic/signal “Keep Read only”.

Good luck.

(PS, I have seen before that sometimes TWRP misses the “Keep Read Only” initial screen. My guess had been that it should however be shown at the first use of TWRP)

However the log continues; to include:

 last instruction reached instruction
 stage is closing

It will be interesting to see what you find when you reboot!

Hi, thanks for replying so quickly.
I think we miss understand each other (about your ps in the bottom: "I have see before…use of TWARP). Yes I did see de screen with the “Keep Read only” button. When I clicked on it the program went to the menu with: “INSTALL” etc. (The menu of TWARP) here Twarp waits for my action and on my pc screen on Easy installer is see still the last instructions with de last one Tap on “Keep Read only” and no continue button in de right down part of the window. You can wait here for hours, nothing is happening.
I did mange to get back to the phone running on Android 10. And did the hole installation again with same results. Did you read the PS in my last post. Is that not strange to?
You said: It will be interesting to see what you find when you reboot!
Well, the first time I thought I had Bricked my phone, but a very small menu in just text lines appeared after I had tried several times the button combinations and with volume up and down navigable and to confirm with the power button, I confirmed on back to factory settings and that worked. Than I started over again. The second time went a bit different and I came back to Android 10 where my wifi still worked, only the google account was of course gone.

So I have to try again and at the point where nothing happens anymore and I am in the TWARP menu, I click on REBOOT and see if that does the trick. Is that what your are proposing to do?

Sorry for the misreading your description, I guess I am still missing being able to see the broader picture for your situation.

Following on from Disable “Auto download over Wi-Fi” being missing, I see no mention of unlocking. I wonder if we are actually looking for a very simple explanation!

Please can you send a photo of you Odin mode, or Download mode screen. It will be hard to capture the smallest print, perfection not required!.

(I had proposed the reboot button only as an alternative to the “Keep read only” if it were missing.)

Old threads, may contain insights Installing /e/ OS on Samsung S9+ - need step by step help Easy installer - "continue" button not visible

Hi aibd,
OK, I can do the installing again and take pictures with an other phone of de screens of the SM-G960F
Which is running on Android 10 (version: G960FXXSHFUJ2), to document the Installation process.

Before I continue I had link to know what version of /e/OS will be installed with Easy Installer these days (dec.2021) Is it "Q dev " or “Oreo Stable” (I could not find this info)

On this page: Install /e/ on a Samsung Galaxy S9 - “starlte” I found instructions on manual installation
and the files.
I am interested in the “Q dev” version because it uses the Android 10 version (I suppose; it having the “Q” name too, like V10 is sometimes called)

And then next, If I continue a manual installation, do I pick this file: [] and this one: [recovery-e-0.20-q-20211216151800-dev-starlte.img] (At /e/ image ROM download)
or one below (with lower version number)?

For debugging purpose on my case; for you “being able to see the broader picture for [this] situation.” I want to help if this can help improving the installer for others, so what can I do for this? (without bricking my phone of course)
[This] situation is: Easy installer works normal until instruction saying [Tab on “Keep Read Only”]
After taping on this on the phone, the menu of TWARP arrives and the Easy installer won’t show the continue button. Nothing will happen. In this state Easy installer in in a dead end

So I think we really need to review if you should be using Easy Installer at all! :slight_smile:

Today Easy Installer will install Oreo. Discoverable here: [LIST] Devices working with the Easy Installer

As this is an Easy Installer thread, I propose to answer the rest of your question in another thread.

1 Like

I thought of making a new thread, but couldn’t find out how.

Adding my troubleshooting experience, as I did not find it mentioned anywhere:

Libusb couldn’t open USB device /dev/bus/usb/002/017

device: Samsung Galaxy S7
pc with Manjaro Linux and Easy-installer installed via the software manager

Easyinstaller was displaying below error and the logs were showing this

libusb couldn't open USB device /dev/bus/usb/002/017, errno=13
Exit value 1

Eventually, I found out that the installation of Heimdall was a pre-requisite, because after installing Heimdall (no need to open the program or do anything else other than install) the Easy-installer passed the step successfully. Heimdall is a Samsung proprietary tool that is conveniently available in Manjaro software manager:

1 Like