I9305- Flash this patch on your Device

Hi Folks,

I’ve got a question. I try to install e OS, but the sideload installation doesn’t work. Terminal says “no emulators/devices”. I didn’t install the additional patch because I don’t know how. In the tutorial it says: " Additional Patches : Flash this patch on your i9305 before flashing /e/OS".

But how can I do that? ADB also says no such device. Could someone give me the command please?

I also tried to install it from micro sd card. But after 1 hour 15 and still not finished I stopped the installation. There must be something wrong.

Has anybody some tips for me?

Thank you!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

hi @h2b2,

welcome to /e/Land

you have to apply this patch using TWRP, it is an additional step, specific to your device, it will fix GSM/LTE capacity.

1 Like

I didn’t install the additional patch because I don’t know how.

First get that patch onto the SD card of your device.

Now boot into TWRP.

TWRP >> Install >> Select storage location [external SD card] >> Select patch.zip >> Swipe to confirm

then you should be set to carry on as before. :slight_smile:

Apropos (assumed) Samsung S III i9305


I installed the patch from sd card now. After that I tried to install the OS from the sd card. In half of the installation the blue bar stops in the middle of the screen. The installation process says:
“Patching system image unconditionally”. What does that mean?

Is usually a “good thing” (in that TWRP is reporting what you asked for: to overwrite system with no barriers), from memory that is usually followed by a few more lines … then the “success” message.

1 Like

The setup process run over night. It’s still running without progress. I guess something is wrong. It can not be that it takes so long. Has anybody an idea? TWRP and patch are installed. Maybe I try again with laptop and fastboot with adb? Don’t know what else I can do.

Sorry I did not say above “this should be 10minutes to complete”!

If you now abort the process,

is the phone stable, with it’s original system + TWRP?

I deleted the original system (Android 4.4). I think it is stable so far. The installation process should happen in 1 or 2 hours. I can not imagine an installation process that takes 2 days. Something is wrong. Do I need to delete something on the device first?

Each of the “Wipe” actions specified here

are important.

Deletion of the original system is not specified, how did you achieve that?

Edit: https://www.sammobile.com/ suggests Android 4.4 was the last original software. /e/ is built on such foundation.

It is part of the installation documentation

  1. Return to the previous menu and tap Advanced Wipe.
  2. Select the Cache and System partitions to be wiped and then Swipe to Wipe
1 Like

My error, I was reading you, @h2b2 , as if you had done a delete by some other method, sorry.

Edit. I had only wanted to cover other possibilities for a fail! :slight_smile: - before answering the “what shall I do next” question, with run it again.

I think you must rename the patch file, because of the " ( " character in system(sim_support).zip, that is not supported here by the adb sideload command

I run the setup now over the whole night again (3. time). No progress. The patch with the sim support is installed. What is the problem is that the OS doesn’t install. The bar stops in the middle and the system says: “Patching system image unconditionally”.

Have you tried to re-downloaded the /e/.zip fle file ?

"Samsung - Galaxy S III (LTE / International) - i9305 - Documentation Suggestions,
twrp-3.0.2-1-i9305.img needs to be used

I finally have made it to install e-0.16-n. It happened very quick. Some problem must be in e-0.17-n. Don’t know what it is. But the problem now is: my sim card is not recognized. Don’t know what to do. Have no internet and can’t call somebody.

The sim patch has to be applied with TWRP

  • Using the TWRP install feature, select storage, select zip, install the recommended version for the patch : twrp-3.0.2-1-i9305.img, go back to the main menu, and choose reboot to recovery
  • after the format /data (if needed), and go back to main menu, choose reboot to recovery,
    do the advanced wipe /system, and NOW
  • with the install feature, after selecting the sim patch, don’t swipe to confirm flash immediately,
  • choose add more zip, now select the /e/for-i9305.zip and then swipe to confirm flash.
  • wipe /cache and /dalvik-cache
  • reboot

The problem is that the download site is not available: https://dl.twrp.me/i9305

On the alternative site the twrp-3.0.2-1-i9305.img is not listed: https://eu.dl.twrp.me/i9305/

The TWRP runs (I installed the latest version). I will try to do how you describe, but have not the suggested img (twrp-3.0.2-1-i9305.img).

1 Like

It could was a custom TWRP, and its particular feature have probably been committed in the newer version

Even if you are a windows user,
Refer to the too much illustrated guide I wrote :
([HOWTO] install /e/ on a Samsung device from a GNU/Linux PC successfully)

If you still don’t get SIM, download the latest official Samsung firmware for the i9305
and flash it with Odin Windows or with Heimdall Linux,

Do we know if the device was on the latest Samsung stock ROM, before you started?

/e/ is built on such foundation.

Your link https://eu.dl.twrp.me/i9305/ shows an unusual development history for this device (4 recent TWRP versions in 3 months). It seemed to evolve naturally to v.2.8 - December 2015 (where it remained top dog for 5 years) till it was jumped up to v.3.5 this spring! (One could speculate that v3.5 is not problem-free for this device!)

If you are now adept at flashing the device, you could even go back to v2.8, there is no guarantee it will work, but this is likely the generation of TWRP in use when our documentation was produced.

It is also worth studying https://wiki.lineageos.org/devices/i9305/install for clues.

Bon chance :slight_smile:

1 Like