Installation Easy-Installer Galaxy S9+ - support needed

@Lonad_West : Thanks for your answer.

I tried to continue but I am not sure what I have to do exactly.
I clicked on Software-Update and Download & Install, then a new update version appears but I didn’t install it and restart the smartphone as it is written in the easy-installer. Was this correct or do I have to install the update before restarting the system?
After restarting the smartphone a new block with OEM Unlock appears in the easy-installer but with the tasks are the same as on the side before. Is this correct? I found a button where I can activate OEM unlock (under developer mode)?
At the end there should be an error message when I click on Download & Install under Software-Update but there still appears the button for downloading the new update. It seems that it is not working or?

Would be really appreciate for your support because I have never done anything like this before.

I am not clear if Easy Installer has installed /e/OS to the phone … if not … perhaps you could share a log from Easy Installer. It can be found as described here:

Hi @aibd

I think there is no installation on the phone so far.
In the folder common there are six files. The last created log file:

If you need the other five files, I can upload these too. I can imagine that these files were created because I started the easy-installer several times because the easy-installer hadn’t recognized the phone at first.

The latest log is probably the most useful. It seems all was ok in the early stages and, just as you said, that the download was successful … near the foot of the log we see

compare checksum: … ok … DownloadService.succeeded() … startNextDownload() … taskIterator has next ? {} false … onDownloadsComplete()

I am afraid I do not recognise the subsequent steps and unfortunately what you are being asked to do next is not shown in the very last few lines of the log.

Perhaps a German speaker will recognise a little more what needs to be done next.

Perhaps a photo of the problematic screen would help ?

I wonder if you did a very recent update of the phone ? If yes I would be inclined to wait for knowledgeable advice.

I would certainly resist any further upgrading of the phone at this stage, especially if it is the phone giving you this advice !

I guess I am not clear if you are being “prompted” by the phone to do “update type things”.

Thanks for your support so far.

You can find a screenshot of my current step below. It seems that I cannot go to the previous step to create a screenshot or?
The tasks are identical with the tasks before the restart but in the marked step there is no error message on my phone. Instead of the error message I can see that there is a newer update exists and I can click on later or download. I am a little bit surprised that the headline is called OEM unblock but there is no step to unblock the OEM in the tasks.

Is there a possibility to switch to English in the easy installer, so it might be easier for you?

Hi again,

  1. My knowledge here is very thin. I can only tell from one phone (a refurbished Galaxy S9+ with android 8) and give my thoughts and assumptions.
  2. I do not know what might be the consequences of using easy installer on the S9+ with Android 10.
    2.a) I could imagine, that a higher version of Knox Guard (KG) might negatively interfere with your installatoin attempt. I think that in this case, KG won´t let you install an other OS. THIS IS ONLY AN ASSUMPTION!
  3. The installation step requires you to wait for a response. If you get any respose, you may proceed (=reboot). It may also help you to use the easy installer in English, as well as your phone. (German: So wie ich es verstehe, sollst du hier einfach einmal draufklicken. Keine Ahnung warum das hier wichtig ist. Nach dem Klicken dann Neustarten. Es kann sein, dass es bei den verschiedenen Sprache beim Easy installer keine perfekte Übereinstimmung der Überschriften mit den Inhalten hat. Ich habe die ganze Prozedur ca. 15 mal bei meinem Phone durchgeführt, weil irgendwas nicht gepasst hat. Siehe auch meinen thread hierzu: Galaxy S9+ Installation with easy-Installer on WIN - no booting in TWRP Hier findest du ggf. auch schon weitere hilfreiche Links.)

I think it would be best to wait for an informed reply.

1 Like

Regarding language, I think that I once noticed that Snap causes Easy Installer to inherit the language of the machine on which it is installed.

The experience of @Lonad_West would be useful for comparison, although your log is different from his you might have very similar issues !

While waiting for anyone who might recognise the issue with Easy installer please check out the links in his post regarding KG / RMM Prenormal. In this context, was your phone in use online and with a tested SIM card since you acquired it ? As mentioned in the links above do any clues appear on the Odin mode (Download mode) screen ?

To help you learn where Easy Installer is in the process you might compare with the command line instructions Install /e/OS on a Samsung Galaxy S9+ - “star2lte” – it is still “about to start” installation.

I think that’s a wrong assumption. I’m not familiar with Samsung phones so I don’t know for sure but to me the text clearly says that an error is ok as well, i.e. it doesn’t matter for this step if there is an error on the phone or not (my interpretation of the manual install docs is that you just need your phone to search for updates once, not actually do anything with the result).

About the log file: the info it provides is just that the image file was successfully downloaded. And then the log ends “abruptly”. Which I think is ok in the situation shown in the screenshot.

One more thing: looking at the manual install instructions I think your screenshot is about this step:

Enable OEM unlock in the Developer options under device Settings.

It appears sometime that the OEM unlock option is missing from Development options, especially on new devices. Please connect your device to the wifi and check of system updates. After a reboot, the option should appear.

My interpretation is that you successfully checked for system updates to ensure the OEM unlock option on the phone is present.

You wrote “I found a button where I can activate OEM unlock (under developer mode)?”
I’m a bit confused by your use of the question mark here. Do you have the OEM unlock button on the phone or not?

In any case: have you tried to just continue even if the instructions stay the same?
Background of my question is that the installer only ever does something after clicking on “Weiter” and I would assume that it will try to reboot the phone in the correct mode to do the actual OEM unlock on a next screen.

1 Like

You need to restart the phone by hand. The Easy installer will not reboot your device. Then hit “weiter” and see what happens.

From my many attempts I can tell, that easy installer does not check if you did the steps and you may click through the steps once you have activated all necessary options (like OEM unlock etc.).
You will come to the point, when you need to restart the device in “forgot the name” - mode. If you do not manage to enter the required menu, then see my linked post above for more information.
If you just fail to press the right combination, you may restart easy installer. It may also help to reinstall easy installer.

Thanks for your support.
I rebooted the phone again and the OEM unlock tasks appear on the next page.
Now I have to activate “OEM unlocking”.
Before confirming it with “enable”, I shall press the buttons “on”, “bixby” and “volume down”.
The phone wants to update the bixby version.
I think I shouldn’t do that or?
When I am pressing all three buttons, I cannot open the download mode.
I found an option Bixby key where I can click on Get started.
Do I have to activate bixby at first?

In the meantime I changed the language on the phone from German to English.
Ubuntu wants to reboot the system.
Is this critical because I have to restart the easy-installer again (e.g. download file).
Until now I haven’t got a sim card in my phone, so I read in your links that I should use one.

Thanks so much for your support!!

You can only engage Download mode from device powered off – hold Volume Down + Bixby + Power.

No problem – Easy Installer is generally fine if you have to start again. Rather than download again, Easy Installer will at first just verify the existing downloads.

I think this is critical … but

I think you will need to read some of the links already provided by @Lonad_West in his thread repeated here ! :slight_smile:

In general I would avoid taking advice / hints from the phone.

After using a sim card, I had the possibility to deactivate the automatic WLAN updates under Software Update (it seems that a sim card is required for this option) and some steps later after restarting the phone I was in the developer mode. But now I am struggeling again. For a short time after restarting from the developer mode I saw the /e/ logo on the screen but then I lost track (Samsung logo appears etc), currently I am in recovery mode anyway and I am not sure what I have to do.

Phone and easy-installer are in English now:

Great ( I think). The tail of the log reads:

(debug)RECOVERY upload successful
(debug)waiting for recovery

… then aborts suddenly.

Having flashed a custom recovery you have really cracked the job. Please confirm to yourself that you have successfully flashed the /e/ Recovery.

You say you have seen “the /e/ logo” … the above would imply that this is the colourful e of /e/ Recovery and not the bouncing black e of the system boot animation ?

So refer to the manual instructions … you are now at

Steps to install /e/OS from recovery

I would be inclined to just follow this manually … the reason for this choice is that this way one is in control of one’s own mistakes !

It was the black /e/…

I think it is the same issue like @Lonad_West

CURRENT BINARY: Samsung Official
KG STATE: Checking
Secure Download: Enabled

I inserted my sim card in the morning and hat a 15min call too.
The differences between Lonad_West and my seetings are
Activate GPS Location
Reinstall Easy-Installer
Change USB cable
How can I change the GPS settings. When I start the phone with the power button, then I have to chosse the language and can enter my wifi access again. Is this way correct?

Why ? This will be an important step after a successful install. :slight_smile:

Are you describing a Samsung “First start wizard” rather than that of /e/OS ?

It was the black /e/…

CURRENT BINARY: Samsung Official

These two statements conflict.

The black /e/ logo appeared only once but I have never seen the /e/ recovery mode.

When I click on volume up, bixby and power I can only open the Android recovery mode. Instead of this I should open the /e/ recovery mode or?

My understanding was that Lonad_West used the Samsung Android in the meantime to make a call and so on.

I keep misunderstanding this use of a question mark following “or” ! :slight_smile:

Maybe you should scroll though the 3 booting modes and see what you have ?

Do you stll have a regular unmodified Samsung Android ? Further evidence of this would be

CURRENT BINARY: Samsung Official

Is this what you see ?

If yes to the above, you maybe uploaded the custom recovery, but failed to boot into it with the right timing … as in Your first boot into TWRP

My understanding was that he wisely did this on his unmodified phone and you wisely did the same.

I mean with the questition mark that this should happen but it doesn’t happen.

I think that I have still a unmodified Samsung Android.

I opened the download mode and stopped it with volume down, bixby and power for 7 to 10 seconds. When the screen was black I pressed volume up, bixby and power for 7-10 seconds but there is always the Samsung Official recovery mode.

I only made a call and inserted a sim but I didn’t activate my gps location and I didn’t reinstalled Easy-Installer and I didn’t change the usb cable. So my plan would be to reinstall Easy-Installer, change the usb cable and use Samsung Official to aktivate my gps location and then restarting the Easy-Installer again. What do you think about this plan?
In this case I have to start Samsung Official. If I click on the power button then the official process with language settings and wifi password will start. Is this correct when I want to restart again?

So my plan would be to reinstall Easy-Installer,

Not convinced reinstall is needed – the last log reflected reality when it said waiting for recovery.

I am guessing that First boot into Recovery is the main issue – many people might do this stage many times before they get it !

change the usb cable

Not convinced this is needed – adb and heimdall are already demonstrated working.

and use Samsung Official to aktivate my gps location

idk, but this sounds like following a “Samsung hint”, I cannot see the necessity.

and then restarting the Easy-Installer again.


the official process with language settings and wifi password will start

ok – if you are still KG Checking, having the phone online with wifi might allow to “check for updates” if asked – might be a good trick to lift KG Checking → Normal.

It works now!!
After reinstalling Easy-Installer and starting from the beginning, everything worked as expected.
Thank you so much for your great support !!