Installer stops after downloading, no error or acknowledgement just a “Try again” button still open


unfortunately this bug is still open, tried to “e-os” a pixel 4, but ending up with this checksum error:

2024-06-07 22:11:05,496 DEBUG [Thread-54] e.e.i.t.DownloadTask [null:-1] ChecksumLine = 123347885d7fd2cdd0cfe39f23292d76770f9be926e5162614f12c3ecafc3d9c
2024-06-07 22:11:05,496 DEBUG [Thread-54] e.e.i.t.DownloadTask [null:-1] createFileChecksum()
2024-06-07 22:11:12,325 DEBUG [Thread-54] e.e.i.t.DownloadTask [null:-1] compare checksum: c79a65da525c5985f1dcd3afda1796a2695822b3994b2e38aa28e9ed79a8ac30 vs 123347885d7fd2cdd0cfe39f23292d76770f9be926e5162614f12c3ecafc3d9c

any chance that this will work again?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Installer stops after downloading, no error or acknowledgement just a "Try again" button.

Firstly what version of Easy Installer are you using? The fixing if this issue was hoped for (in in Easy Installer v0.21, otherwise there is a workaround mentioned Installer stops after downloading, no error or acknowledgement just a "Try again" button - #7 by lma

Edit If you are on Easy Installer v0.20.1 it is probably worth checking your log for the download location (depends on PC OS) … (this example from Windows)


Note the files in sources then try progressively deleting the checksum file(s), the ROM, all contents of sources, trying again each time. Perhaps this will bump Easy Installer into finding the correct files.

where do I get the 0.21?
snap says I have the most recent (but it’s 0.20.1) and can’t find one for windows…

thanks for your help

I am sorry, my typo :blush: . I think I shortened my first draft of a reply which might have expressed the idea that v0.21 may have a “full” fix for all devices, but I believe it is still in testing, vO.20.1 seems to have been producing fewer reports of failure.

I have corrected my first post – yours is the version where I think deleting source is worth a try.

hmm, that interesting i checked the SHA256 off all dev/stable version, none of them corresponds to the one wanted by easy installer…
deleting doesn’t change the outcome… :frowning:

Agreed but I do find a match here:


Not very desirable as it is the last S build so will need a manual upgrade. So you would better do a manual install of T

I’m confused, the site I looked is:
the link: [MD5 | SHA256] -


for me???

on this side

I have only [MD5 | SHA256] -

with an -t- inside…?

forget it - found it…

and there is no way to get via ota to the e-os 2.1?

with manual it now says can’t find valid operating system
device will not start

fastboot devices doesnt find it anymore

is there a way to “debrick” it?

No, not on T (that is e-2.1-t-dev moving from e-1.17-s-dev) … we see that the S build terminated [1] and because OTA Upgrade of Android version only happens on stable.

[1] Post #6 as I say “Not very desirable as it is the last S build”.

You also hit Easy Installer always delivers Stable build ? - No, sometimes dev #7645

So the manual instructions are expected to be accurate for the t-dev builds. Did you use your own platform-tools or did you contrive to use adb / fastboot supplied to you with Easy Installer, potentially hitting easy-installer: Old version of fastboot #7154 ? Or did Easy Installer actually transfer something to your phone at some point ?

Depending on the circumstances the message “can’t find valid operating system” is actually valid at the point where you are partway through flashing various partitions.

Not just

Since the device resets completely, you will need to re-enable USB debugging to continue.

after unlock?

One more thing, as you moved up to a T build (somewhat unexpectedly) did you satisfy

Before following these instructions please ensure that the device is on the latest Android 13 firmware.

It may be necessary to upgrade the firmware using a method described here You have some reading to do on this page (worth spending a bit of time) before hitting Acknowledge at the apparent foot of the page; after which you can search the page for flame.

yes, device was updated to A 13, I downloaded and used platform-tools freshly
now I can’t boot, so there is no way to re-enable usb debugging…

Edit @tiro on reflection, I think this has come up before and lack of USB debugging affects adb (and thus adb sideload) but not fastboot. I just switched off USB debugging on my OnePlus One and Moto G7 Power ocean and fastboot devices finds both devices. Does you phone boot into fastboot?

So at this point I think you need to determine if failure of fastboot devices is from the PC side or phone.

Nearly always if you have fastboot available on the device there is a way out.

(Which method did you use to upgrade ? Did you notice did it rely on fastboot ? There may be some lower level method to flash the SOC, I don’t recall the Pixel method.)

This link talks about various methods, but I would avoid spamming the phone on guesswork.

I notice that the OP seems to open a second thread “Update Solved”. His remarks on a fully charged battery are interesting, and I believe important particularly when you have to have a second run at a problem.

In some searching I found also but without a Google account / login I could not further research the tool.

Same issue here with a Pixel 4 flame. The ongoing saga of updating to v2.0 continues. Mac user.

Anyone got a way through this? Upgrading to 2.0 shouldn’t be this difficult

When /e/OS is installed on a device, you also already have the recovery-e installed, so you simply have to boot in recovery mode to easily update/upgrade…

The issue is getting e/OS onto what is now a factory reset Pixel 4 which has Android 13 installed.

you can’t install /e/OS-S based on Android 12 on a device running a GogolOS based on Android 13 !
you have two options :

  • install /e/OS-T


  • downgrading GogolOS to an Android 12 based, then install /e/OS-S

That’s the problem, e.os didn’t start, says no valid operating system…

@tiro i can guide you in PM…

I misunderstood you, I imagined that you were stuck mid-install. I think you and @PhaleBot are in the same area as this Issue: 2.0 /e/OS update not booting #8009.

done !
using the traditionnal way skipping the easy installer

one thing that surprise me and scared a bit was

fastboot flashing unlock

i was a bit reassured by the “ignoring” word,
but english and android are not my native language,
so, @aibd @tcecyk or others i don’t think about at this moment,

what do you understand on this ?…

1 Like