Installing gmail app [updated: issue is microG logging in]

Before anyone says it, yes, I see the irony. The problem is that I am not ready yet to move out of gmail. I have moved out of chrome, google search, google photos, google maps, google drive. Now I want to move out from Android, but I will still need to use gmail for the forceable future, as my company uses google workspace for email + calendar + contacts.

K9 email and the whole system of Account Manager does not work yet well enough for me. I am sure the developers will get it better and at some point I will be able to use these tools. But this moment has not arrived yet for me.

So, I want to install the gmail app. I can download it through the app store, it installs, it asks for microG, I am able to login microG, set my account, password, accepting terms of service. Then when I am about to finish, I receive a message:

There was a problem communicating with Google servers
Try again later.

And I get back to the first page.

How can I fix that? Do I have to install google play services in order to get it to work?

That’s strange. Is any app on your smartphone blocking the connection to Google servers?

/e/OS is Android, too, technically.

With microG not being removable in /e/OS this is not possible, because microG poses as those Google services to Apps which rely on them.

/e/OS can not and does not guarantee that you will be able to use any Google-dependent App at any given point in time. Even if you could get it to work now, this could break anytime. microG is very good, but changes on Google’s side can break compatibility, with microG then having to catch up again.
You want to take that risk in a work environment?

I use fair mail, seems to do the job.
Does it have to be Gmail App?
Back in the Google days I used outlook app also with a Gmail address and it worked fine.

1 Like

I actually receive the same error when I try to log into an account via the microG settings (microG/Google Services/Account/Add google account). Normally, would I be able to log in?

Fair point :slight_smile:

Well, aurora store keeps asking me to “update google play services” which, from what I read in another post, is microG. If I tell Aurora to update it, then, would’nt I have installed google play services?

Of course, because that’s what microG is for. Do you use a firewall, for example? Then it might not work.

No, I installed /e/ on my teracube two days ago.

It might be related: when I tried to Test SafetyNet attestation in microG Settings/Google Safety Net , I received an error

Waning CTS profile does not match
Bootloader is not lock

so maybe I have to lock to bootloader back?

Better not do that. I once locked the bootloader again after rooting a device and after that the device could not boot anymore and could not be restored because of the locked bootloader.

If that install attempt wouldn’t fail, it would be very, very surprising.

This very much depends on the device.
Some bootloaders should be perfectly lockable (e.g. Fairphone 3/3+), some should be but experienced issues temporarily (e.g. Fairphone 4), and some should indeed not be locked (e.g. every device with install instructions which don’t lock the bootloader).

Quick reminder: Locking as well as unlocking the bootloader will force a factory reset for security reasons.

1 Like

Thank you @AnotherElk and @Tux17 . My conclusion is that the problem is microG.

Other users are reporting the same problem. I will close this post, but I would really appreciate if anyone has an idea on how to fix this :slight_smile:

I have Gmail, Google Calendar, and Google Keep apps working fine in /e/: under “Settings > Accounts” under the “Google microG” entry when clicking “Account Sync” there are now entries for “Gmail”, “Google Calendar”, and “Keep Notes”, and I have enabled all of them.

As far as I can tell, all 3 apps are working fine. Do you have these “Account Sync” entries and are they enabled?

Note I also couldn’t directly login to Google under the hidden “microG Services Core” app.

Logging in through there does not work either (this is how I originally tried).

My installation is basically clean, barely installed any app. This seems like a bug.

Does anyone know where can I find the log of microG? So that I can report a bug in the gitlab?

I also have a fairly new install, less than 2 weeks old at using /e/ myself.

If you go to Settings > "Apps & Notifications" > "See all xyz apps" > microG Services Core > "Open" can you check your microG settings compared to what I have listed below? I can’t recall if I made some changes to them or not?

  • Google Device Registration: on
  • Cloud Messaging: on
  • Google Safety Net: on
  • Self Check:
    • All items checked

Lastly, can you check in Apps > Gmail and confirm all permissions (necessary) are turned on there? I saw that some apps when you install they do not prompt for permissions but need to get permissions manually turned on before they will work correctly.

Yes, all is the same. With the caveat that SafetyNet attestation test fails with the answer:

Warning: CTS profile does not match
Bootloader is not locked

Thanks, this did not solve the issue, but I am happy to know about it if I ever fix microG’s issue :wink:

One more question is that in permissions for Gmail there is an “Additional Permissions” which when clicked shows “Google Mail” as the additional permission. Is this one “allowed”? For now I just turned on all permissions gmail is asking for, with a plan to later restrict it to what I want it to have after I confirm it is working. But again for now it seems to work for me, sorry you aren’t getting it to work.