Installlation stuck - please help

Hi everybody,

I was trying to install the OS on my Galaxy S7 G930 F using the easy installer under Win10. I am using the German version so I hope my translations of messages are correct.

I have little understanding of smartphones, because the lack of privacy always kept me from getting one finding /e/OS made me change my mind, but sadly I’m stuck now. So please excuse my ignorance.

I’m stuck at the point where I’m supposed to press ON+HOME+Vol- to turn the phone off and ON+HOME+Vol+ until the “Teamwin symbol is shown”.
The phone gets turned off, but in the next step there is no such symbol and after a while the phone enters the Android Recovery mode and after another short while the computer suddenly says that my device is not recognized and one second later the Android recovery says “no command” and I’m getting a Android Recovery menu with choices like “Reboot system now”, “Reboot to bootloader”, etc. (just so you know what I mean).

Factory reset (where this was supposed to take me) is not one of the options. On the bottom of the screen it says “#fail to open recovery_cause(No such file or directory#” etc…

I have no idea what to do next and ould appreciate any help very much. Thanks!!!

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

Hi @Arthur welcome to the /e/ forum.

It is simply a matter of timing not well explained by Easy Installer. More fully explained here Your first boot into TWRP

See also, Easy Installer Samsung users fail to boot into TWRP,

I think you will find at this point that Easy Installer has made no changes to your phone. Generally Easy Installer will pick up again if you simply restart from the beginning.

Hey @aibd - thanks for the welcome and your swift reply!!

So - to be sure - should I turn off the phone via the menu I’m in and then run the easy installer from the start, then do what it says in “Your first boot into TWRP”?

I tried getting into TWRP from here by force stop and quickly switching to VOL+, but I’m just getting back where I came from.

Thanks again, much appreciated!!!


Assuming TWRP was flashed to the phone successfully, it will have been immediately overwritten and inaccessible.

Thank you. I’ll try this and report back!

Didn’t work. I did just what was described, released the VOL- button the instant the screen went black (before the “buzz”) and then it displayed the Samsung S7 screen and then went into restore mode.

Anything else I can do?

I read something about having to leave the download mode… is it necessary/would it help and if so, how do I do this?

Maybe read the already linked article from the start to become more familiar with the phone and Download mode. You should have been “leaving Download mode” when you performed the Force stop.

You might find the log as here Howto troubleshoot issues with the easy-installer – maybe something else is wrong.

I see. Thanks, I will.

A family emergency has occured and that will keep me too busy to proceed over the next few days. :frowning:

Thank you so much for your help so far. I really appreciate it.

Please don’t close this yet, I’ll report back and/or may need some more help. Thanks!!!

No problem.

You might read this reply (in the context of the thread which has similarities with yours) [Solved] Easy Installer not working on GalaxyS9 - libusb error: -12 - #9 by aibd.