Issues updating my Samsung S7 hérolte

Hello everyone,

I have successfully installed /e/OS on my samsung galaxy S7 and, after few weeks, an update appears: the 1.17 one. As I already had difficulties installing /e/OS on my phone, which is quite old, I had new ones installing the update. When I installed /e/OS, I had the TWRP recovery partition and then the /e/OS recovery partition. But, when I downloaded the update and then tried to install it, the phone booted on the android recovery, and I was unable to install the update. Besides, I notice that before trying to install the update, the recovery was still the /e/OS one, but now it automatically boots on the android one…
If anyone can help me, I would be glad,
Yours faithfully,

Hi @VinK3645 welcome to the /e/ forum.

This seems very unusual, to have Android recovery reappear after the phone has been successfully running a Custom ROM for a while.

It should be possible to re flash recovery with either Heimdall (Linux) or Odin (Windows) without disturbing the system partition containing e-1.17-xxx.

If this presents any difficulty I guess I should first ask which method you originally used to install TWRP ?

This seems now the default behaviour.

There is a setting in Developer options to Update recovery which will overwrite TWRP.

Only if you want to depart from default and you want to keep TWRP you should enable Developer options:-

  • Settings > About phone, scroll to bottom, Build Number. Tap rapidly 7 - 10 times on Build number until you see a message Developer options enabled.

Now you can use the Search option in Settings and search for “Update recovery”. Toggle this item off in order to depart from default.

Just in case this is a misunderstanding relevant to the issue … there is one recovery partition only. Either the “simplified” e-Recovery may be flashed to it or alternatively the “older style” TWRP.

Hello @aibd,

I think you should know that I had some issues installing /e/OS on my phone, I firstly tried to use the easy installer, but when it told me to use the recovery, which was supposed to be the /e/OS one, it booted on the android recovery, so I wasn’t able to install /e/OS. Then, I rooted my phone via Odin and flashed TWRP on the recovery. It worked, and so I was able to install /e/OS. BUT, after installing, the recovery was still TWRP and not the /e/OS one as it should be, according to the pictures shown in the easy installer. I still wasn’t able to install it. After a mistaken move, I deleted the whole system on my phone, which was rebooting in loops. I finally managed to install the system by using ADB via my computer and the /e/OS recovery partition (which was installed, I don’t remember how).

After failing to install the update, I did activate the developer option as I guessed it was the same way as in android and that it could be useful. I saw the option you are talking about, but I didn’t want to touch that as I was enough traumatized… By the way, this option was already switched off, does it matter ?

I’m sorry if what I said was confusing, I don’t have both recovery at the same time. It used to be the /e/OS recovery but since I tried the update, it switched on the default android recovery. I just don’t know how this is possible as the /e/OS recovery was still activated before.

The default /e/ setup is to install e Recovery and toggle ON Update recovery;

“does it matter ?”

… well this has been decided by devs to be default for a combination of reasons.

Users familiar with TWRP might choose this (but Update recovery needs to be off, or else it will be overwritten with e Recovery !).

Easy Installer installs stable Build type … is this what you finally installed ? [HOWTO] Give complete /e/OS version info easily for support, answers, comparison etc.

Anyway, it was switched OFF when I entered the dev options, so is it possible that the recovery bug comes from this ?

Well, I don’t have a preference, the only thing that matter to me is to be able to do an update without erasing my data…

I’ve sent via ADB the 1.16 update through the default /e/OS recovery. It successfully installed it as the terminal sent me back a successful message (crashed at 47% “failed to read command: No Error”). I already asked on the forum about this message, and the person who responded to me told me that it was okay. For further info, see that post, it’s from me when trying installing it:

I’m on an Android 10 version, with the 1.16-q-20231017342506-stable-herolte

Probably not … I recollect that during the “First Start Wizard” there is a screen where “Update recovery” is mentioned … validate / cancel are available.

I don’t think I can explain why the Android recovery backup was retained and deployed in your case; as far as I understand it is overwritten by a standard custom ROM installation procedure.

I think the best you can do now is re flash e-recovery 1.16 with Odin. You will be familiar with need for careful reboot Your first boot into TWRP or it might be overwritten again !

Maybe I can… I’ve Seen this some times, when installing a recovery fails, the device boots into ODIN-RECOVERY where it informs you something went wrong and you need to press volume up, I think, to start ODIN download mode.

@VinK3645 Please take a picture and post it here, when you see this again

Could look like this

Could also be, you need to long press: Volume Down + Home + Power On, to get to ODIN screen.

Hello guys,

I have nothing else installed on my phone except /e/OS, as I told you, I made a mistake when installing the ROM, I press delete system via the /e/OS recovery as the installation failed. Now that the system is operational, I guess there is nothing else (I clarify that, after deleting the system, the recovery was still the same). I don’t think it’s coming from there.

I assume this is what I need to do… I’ll try it, but I’m still scared of updating the recovery on this phone, but better now than later. I’ll tell you when done. Anyway, is the update supposed to be installed by itself ? Or will I need to do something when in the recovery ?

I’ve never seen this screen since I use the phone, even when entering the downloading mode. It loads correctly.

Well I’ve used download mode plenty of time, especially when installing /e/OS, I’ve never dealt with a recovery that didn’t install (and I don’t want to). I just can’t explain. The day before it was the /e/OS recovery and after trying to install the update, it just booted on the default android recovery, with no more information about what to do. According to the /e/OS documentation, update should be installed by itself when entering the recovery: Update /e/OS software
Everything is okay until the

I’m going to try flashing the recovery via Odin, I think this is the way to go. Can you just send me the link where the recovery file to flash is ?
Thank you for your help !

herolte here

recovery via

We find


Yes – provided you have a “suitable Recovery”.

Thanks @aibd,

Just a last question, I have now the file downloaded on my computer, should I make a backup before proceeding ? I don’t know if there is a risk that the phone format my data…
Just to be sure, in order to install the recovery I need to enable ADB, to put my phone in recovery mode and send via my computer the file in ADB sideload ?

Sorry to waste your time with such details, but as I’m not sure of what I do, I prefer being guided step by step :man_shrugging:

Thanks for your cooperation !

That is correct, you will not be able to override Android recovery by sending via ADB sideload.

Sure you should have a back up, at least of essentials.

You will also notice in @piero’s link above the instructions for the e-recovery.img has to be converted to .tar in order for it to work with Odin.

Hello @aibd,

I have installed twrp on my phone by mistake… I suppose it’s not a problem as it will be replaced by the /e/OS recovery. Anyway, I just want to know how you can convert the .img recovery in .tar as it won’t be recognized by Odin.

Thanks for your patience

Well that will be just fine.

The command you were looking for is

Hello @aibd,

I’m trying your command, but it says that it failed to open the file. I assume I don’t have the correct syntax… Can you give me an example ? Besides, what’s a user profile ? Is it my username on Windows ?

Sorry to waste your time (I’m a toddler in IT)

I do not use Windows; maybe it is something to do with the described path/to/recovery.img ??

Here I run the command in a test folder containing only recovery.img in Linux

$ ls
$ tar -cvf recovery.tar recovery.img
$ ls
recovery.img  recovery.tar

But you have TWRP, you have verified it ? … that is boot into TWRP, explore a bit … boot back to system.
There is no need to change it !

Hello @aibd ,

So according to you, I can make my update using TWRP ?
When I run the command under Windows, this is what it does:

C:\Windows\System32>tar -cvf %USERPROFILE%\Downloads\recovery.tar %USERPROFILE%\Downloads\recovery.img
tar: Removing leading drive letter from member names
a Users/xx/Downloads/recovery.img

with xx my username

Thanks for your help !

Hello @aibd,

Some GOOD news !!
I installed the update in OTA after installing TWRP and IT WORKED !! This time the recovery has not been erased, and I’m totally done ! I verified, I’m under 1.17 and my data have not been lost.
Thanks for your patience which allowed me to achieve this.
See you !!


This topic was automatically closed after 90 days. New replies are no longer allowed.